17
ответов

Как я могу обновить NodeJS и NPM до следующих версий?

Я только что установил Node.js и npm (для дополнительных модулей). Как я могу обновить Node.js и модули, которые я использую, до последних версий? Может ли это сделать npm или мне нужно удалить и переустановить Node ....
вопрос задан: 27.12.2018
9
ответов

Как мне обновить каждую зависимость в package.json до последней версии?

Я скопировал package.json из другого проекта и теперь хочу перевести все зависимости в их последние версии, так как это свежий проект, и я не против исправить что-то, если оно сломается. Что ...
вопрос задан: 02.05.2019
7
ответов

узел: команда не найдена

Я не понимаю, почему команда узла не будет работать, в то время как работает nodejs: $ node --version zsh: команда не найдена: node $ nodejs --version v0.10.15 Я попытался apt-get установить nodejs, но последний .. ,
вопрос задан: 04.05.2020
6
ответов

Ошибки Npm при установке пакетов на общий ресурс Windows

У меня Ubuntu 12.10 работает в качестве гостя VMware на моем хосте Windows 8. У меня есть общая папка на моем хосте Windows 8, и она запускается в гостевой системе Ubuntu при запуске, используя эту запись в fstab: // myhost / ...
вопрос задан: 05.03.2020
6
ответов

Команда NPM не найдена после установки узла

Мне очень трудно заставить работать команду npm, и, к сожалению, мои знания Unix недостаточно хороши, чтобы решить эту проблему самостоятельно. Все, что я сделал, это установил brew, и я получил ...
вопрос задан: 23.05.2017
6
ответов

не может установить npm на Ubuntu

Пытался установить nodejs и npm на Ubuntu 12.04. Я погуглил и сделал это. Теперь я не смог установить npm на машину. sudo apt-get install npm, что дает мне это Следующие пакеты имеют unmet ...
вопрос задан: 07.05.2014
5
ответов

Как я могу установить npm на 17.10?

Я просто хотел установить npm через терминал, и теперь я просто застрял с некоторыми зависимостями. Он хочет, чтобы я установил несколько зависимостей, например: libssl1.0-dev nodejs-dev node-gyp Даже если я попытаюсь ...
вопрос задан: 10.01.2018
5
ответов

Как вы устанавливаете меньше компилятора командной строки CSS?

Насколько я понимаю, и поправьте меня, если я ошибаюсь, мне нужно установить ruby ​​или NPM, чтобы работал компилятор css. У меня не установлено никакого рубина, и я не совсем уверен, как получить мой ...
вопрос задан: 14.04.2017
5
ответов

Что такое опция --save для установки npm?

Я видел учебник, где была команда: npm install --save Что означает опция --save? Не удалось найти ответ в Google.
вопрос задан: 03.08.2016
4
ответа

разрывы npm после обновления nodejs до 0.10

Я на 12.04LTS. Я обновил свою систему сегодня, и в этом процессе nodejs был обновлен. Теперь мой npm перестал работать. Например, $ npm: установить экспресс-протокол npm http GET https: // registry ....
вопрос задан: 05.03.2020
4
ответа

Зависит от ветки или тега, используя git URL в package.json?

Скажем, я разветвил модуль узла с ошибкой и хочу использовать свою фиксированную версию, конечно же, в ветке функций, пока исправление не будет объединено и выпущено. Как бы я сослался на мою исправленную версию в ...
вопрос задан: 30.08.2018
4
ответа

Зависимости не установлены в Visual Studio

В настоящее время я обновляю свой ASP.Net RC1 до ASP.Net Core RC2. Обозреватель решений в Visual Studio выдает предупреждение «Зависимости - не установлены» с подпапкой «npm - не установлен». ...
вопрос задан: 21.06.2016
4
ответа

установка npm, требующая сбоя в работе узла, в Windows

У меня есть проект NPM, который использует bufferutils и utf-8-validate, оба требуют, чтобы node-gyp установил их. Когда я выполняю установку npm, я получаю следующую ошибку: > bufferutil@1.2.1 установить C: \ Users \ Marek \ WEB \ ...
вопрос задан: 09.02.2016
4
ответа

Ubuntu / Установить NodeJS & amp; НПМ

Я пытаюсь установить nodejs и npm, однако это не удается. Это мой терминал: sudo apt-get install nodejs npm Чтение списков пакетов ... Готово Создание дерева зависимостей Чтение информации о состоянии ... Готово ...
вопрос задан: 31.05.2014
3
ответа

После установки кофейного скрипта команда coffee найдена, но ничего не делает

Я только что установил скрипт coffe с NPM (sudo npm install -g coffee-script) Когда я печатаю кофе в моем терминале, ничего не происходит. Команда найдена, но не показывает никакой реакции. Кто-нибудь знает ...
вопрос задан: 20.04.2020
3
ответа

& ldquo; Нет такого файла или каталога & rdquo; ошибка при использовании npm

Я установил node и npm, используя приведенные здесь инструкции, и смог успешно использовать узел. Однако, когда я пытаюсь установить модуль узла «Потрясающий», я получаю следующую ошибку: $ npm ...
вопрос задан: 26.02.2020
3
ответа

внутренняя / modules / cjs / loader.js: выпуск 584

У меня проблема при вводе любого npm cmd, он говорит: internal / modules / cjs / loader.js: 584 Операционная система: Windows 10 64bit Что мне делать, чтобы решить эту проблему? внутренняя / modules / cjs / loader.js: 584 ...
вопрос задан: 28.03.2019
3
ответа

Как установить пакет Node.js без сети?

Я разработан на ОС Linux без сети. Из-за этого команда npm не может установить пакет. Поэтому, когда я искал способ установить его, я нашел способ загрузить zip-файл из ...
вопрос задан: 27.03.2019
3
ответа

Удар по package-lock.json и package.lock одновременно?

Перед публикацией в NPM мне нужно поднять минорную версию. Обычно я делаю следующее: - меняю package.json - запускаю npm i, который синхронизирует package-lock.json с этим изменением. Теперь оба могут быть опубликованы. Является ...
вопрос задан: 19.03.2019
3
ответа

команда create-реакции-app, прерывающая установку Почему?

узел windows 10 v10.15.1 npm v6.8.0; I: \ > npx create-Reaction-app newpomodoro Создание нового приложения React в I: \ newpomodoro. Установка пакетов. Это может занять пару минут. Установка реагирует, ...
вопрос задан: 04.03.2019
3
ответа

Как манипулировать и использовать npm init & amp; package.json

У меня есть новый проект с AngularJS, я клонирую существующий проект в основной ветке master (master -> origin) (essential-react@0.3.0). Я запускаю npm init и у меня есть файл package.json. ...
вопрос задан: 20.02.2019
3
ответа

Команда npm для удаления или удаления неиспользуемых пакетов в Node.js

Есть ли способ просто удалить все неиспользуемые (необъявленные) зависимости из проекта Node.js (которые больше не определены в моем package.json.) Когда я обновляю свое приложение, мне нравится иметь ...
вопрос задан: 15.03.2018
3
ответа

Как установить Node.js без доступа sudo, но с установленным npm 1.3.10?

У меня мало знаний об Ubuntu 14.04. Мне нужно установить Node.js. Используемая мной Ubuntu - это большая система для организации, поэтому у меня нет доступа к sudo, но я обнаружил, что установлен npm 1.3.10. ...
вопрос задан: 01.12.2017
2
ответа

Phonegap Ошибка установки в Ubuntu

Всем доброго времени суток, я пытался установить PhoneGap на свой ПК, но я решаю проблему, надеюсь, любой сможет мне помочь. Вот идентификатор распространителя версии Ubuntu: Ubuntu Описание: Ubuntu 12.04.4 LTS ...
вопрос задан: 17.05.2020
2
ответа

Как обновить кофейный скрипт?

Я получил следующую ошибку, когда попытался посмотреть сценарии кофе с помощью coffee -o js -cw coffee. /usr/local/lib/node_modules/coffee-script/lib/coffee-script/command.js:321 throw e; ^ ...
вопрос задан: 16.04.2020
2
ответа

Почему в моем проекте Angular 7 40000 пакетов? Как удалить неиспользуемые зависимости?

При запуске аудита npm в моей консоли я получил следующий вывод: [...] обнаружил 0 уязвимостей в 40256 отсканированных пакетах. Почему в моем проекте 40000+ пакетов? Это количество пакетов ...
вопрос задан: 30.03.2019
2
ответа

Ограничение пользователя на ввод специальных символов с помощью Angular

Пользователю разрешено вводить все алфавиты и цифры, но когда вводятся специальные символы, их нельзя вводить в текстовое поле. Я попытался сделать это с помощью (ng-pattern-restrict) ...
вопрос задан: 24.03.2019
2
ответа

Как использовать переменные «set» для консоли Windows в сценариях NPM?

Это работает в консоли Windows, как и ожидалось: set A = "qwerty" & amp; & amp; echo% A% вывод: "qwerty" Но когда я пытаюсь запустить те же команды в scmts NPM: package.json: "scripts": {"qwerty": "...
вопрос задан: 19.03.2019
2
ответа

не могу установить пакет пряжи из GitHub

Я пытаюсь установить пакет из GitHub с пряжей. Я делал это много раньше, но я не добился успеха в этом репо: https://github.com/coolwanglu/pdf2htmlEX Я уже попробовал без удачи:
вопрос задан: 10.03.2019
2
ответа

Проверка обновления npm не удалась

на самом деле я пытался установить nodejs вместе с npm на моем Ubuntu 17.04. я скачал версию linux с nodejs.org и создал мягкую ссылку для node и nodejs. после проверки версии nodejs это ...
вопрос задан: 06.03.2019