5
ответов

Как я могу запустить Turbo C ++?

Как я могу использовать приложения для Windows, такие как Turbo C ++, в Ubuntu? Wine говорит "не применимо на вашем компьютере" или что-то в этом роде. Мне нужно специально использовать Turbo C ++ в Ubuntu для моей курсовой работы.
вопрос задан: 16.02.2020
5
ответов

Как мне установить gcc-4.3?

Есть ли простой способ установить gcc-4.3 на Oneiric? Я действительно нуждаюсь в этом, потому что matlab зависит от меня для создания mex-файлов. Я попытался изменить все свои resopistories обратно на Maverick просто для установки ...
вопрос задан: 14.12.2019
4
ответа

Как мне скомпилировать gcc 4.3.4? [Дубликат]

Возможное дублирование: как мне установить gcc-4.3? Как я могу скомпилировать (или просто установить) gcc 4.3.4 на моем Ubuntu 11.10? Я пытался скачать и скомпилировать его с помощью следующих инструкций: http: // ...
вопрос задан: 14.04.2017
3
ответа

Есть ли какая-либо библиотека, похожая на < conio.h & gt ;?

Я использовал IDE DEV C ++ для компиляции программ на C в Windows, и я использовал библиотеки и, но теперь я использую Ubuntu и загрузил Codeblocks, но у него нет этих библиотек. Я просто хотел использовать ...
вопрос задан: 06.04.2020
3
ответа

Почему я получаю эти неопределенные ошибки при компиляции программы C ++ в терминале?

У меня есть программа на C ++, которая отлично компилируется и работает в блоках кода. Однако, когда я пытаюсь скомпилировать его из терминала, используя: gcc -g main.cpp -o Main, я получаю много неопределенных ссылок: И это ...
вопрос задан: 29.04.2019
2
ответа

apt-build на ubuntu, если я поменяю процессор, то возникнет проблема?

Я установил apt-build в Ubuntu, это программа, которая компилирует и устанавливает программы. Он оптимально компилируется для пользовательского процессора, что ускоряет запуск программ. Но я подумал, что если я изменюсь ...
вопрос задан: 15.05.2020
2
ответа

Настройка Ubuntu 12.04 для распознавания недавно установленного компилятора icc

У меня есть Ubuntu 12.04. Я установил компилятор icc (composer_xe_2013_sp1.0.080), но когда я пытаюсь скомпилировать его, я получаю сообщение: icc: команда не найдена. Я где-то читал, что когда ты ...
вопрос задан: 20.04.2020
2
ответа

Ubuntu 13.04 с gcc / g ++ / gfortran 4.8 по умолчанию?

Я планирую загрузить и установить Ubuntu 13.04, и я хотел бы иметь два компилятора в моей системе. Первый вопрос: какая версия gcc / g ++ / gfortran поставляется с ubuntu 13.04? (это 4.7.3?). ...
вопрос задан: 14.03.2020
2
ответа

как установить g77 на Ubuntu 12.04

Мне нужен компилятор Workin G77 на моем 64-битном ноутбуке Ubuntu 12.04. так же было сделано следующее: я изменил sources.list, добавив следующие строки: deb http ... hu.archive.ubuntu.com/ubuntu/ hardy ...
вопрос задан: 10.02.2020
2
ответа

LLVM / Clang 3.1 & amp; Libc ++

Кто-нибудь создал и настроил Ubuntu Precise PPA для LLVM / Clang 3.1? Бонусом может быть также включение в нее последней версии libc ++.
вопрос задан: 11.01.2020
2
ответа

Больше не могу ссылаться на OpenGL

После обновления до 11.10 я не могу связать код с libgl / glut. freeglut3-dev и т. д. установлены, и, похоже, их тоже можно найти. Я действительно не уверен, что происходит. Makefile gltest: gltest ....
вопрос задан: 05.12.2019
2
ответа

Проект Codeblocks C ++ не собирается и не запускается

Я новый пользователь Ubuntu. Я начал программировать на C ++ в Windows, используя Code :: Blocks, и хотел бы попробовать среду с открытым исходным кодом Linux. Я ищу для установки Code :: Blocks IDE для разработки на C ++. ...
вопрос задан: 18.08.2018
2
ответа

Совместимые компиляторы для Matlab R2015a

Я пытался установить Matlab R2015a, и все работало отлично, пока это сообщение не появилось и не озадачило меня, потому что, как вы видите, я уже установил все компиляторы, необходимые для ...
вопрос задан: 15.03.2016
2
ответа

Как настроить NetBeans 8.0.2 для C ++ в Ubuntu 14.04?

Я новичок в программировании, NetBeans и Ubuntu. Я установил netbeans ide с пакетом c / c ++ по адресу https://netbeans.org/downloads/. Я понятия не имею, что еще установить. Пожалуйста, помогите мне в ...
вопрос задан: 20.03.2015
1
ответ

Есть ли в Ubuntu Touch терминал и / или компилятор?

Есть ли в Ubuntu Tablet какой-либо компилятор, на котором Python / C / C ++ может быть написан и запущен? Кроме того, у него есть терминал?
вопрос задан: 13.05.2020
1
ответ

Clang Ошибка «файл stddef.h не найден»?

После обновления до Saucy Clang теперь выдает мне сообщение об ошибке: clang -Wall -Werror -std = c99 -ggdb -O0 5.1.c -o 5.1 В файле, включенном в 5.1.c: 1: /usr/include/stdio.h : 33: 11: фатальная ошибка: 'stddef.h' ...
вопрос задан: 28.04.2020
1
ответ

Невозможно скомпилировать программы в Ubuntu с Geany

У меня проблемы с компиляцией простой программы на C ++ в Geany. Результат такой же, даже если я просто использую терминал (не используя Geany).
вопрос задан: 17.04.2020
1
ответ

Отсутствует ошибка компилятора в QtCreator и Qt5.1.0 в Lubuntu 13.04

Я не могу скомпилировать любую программу в QtCreator на Lubuntu 13.04. У меня есть эта ошибка: QtCreator нужен компилятор, настроенный для сборки. Настроить компилятор в настройках комплекта Прежде всего я установил из ...
вопрос задан: 03.04.2020
1
ответ

независимый от архитектуры инструмент мониторинга производительности

Я познакомился с инструментом "perf" в "linux-tools-3.2.0-43" для Ubuntu 12.04, который может отслеживать показатели производительности для некоторых микроархитектур, однако инструмент зависит от архитектуры процессора и ...
вопрос задан: 18.03.2020
1
ответ

Как установить Open64 Compiler?

Open64 - это компилятор, поддерживаемый AMD, вот ссылки: http://developer.amd.com/tools/cpu-development/x86-open64-compiler-suite/ и Сообщество поддерживает один http: //www.open64 net / home.html ...
вопрос задан: 07.03.2020
1
ответ

связать объектный файл cpp с объектным файлом c и создать исполняемый файл

Предположим, у меня есть файл c ++, создан объектный файл, а файл c - другой объектный файл. Теперь мне нужно связать оба в один исполняемый файл. Хотя я пытаюсь это дает ошибки о C ++ не найден. Можно ...
вопрос задан: 25.02.2020
1
ответ

Я не могу скомпилировать программу на C ++ с помощью команды g ++

Если я попытаюсь скомпилировать исходный файл C ++ с помощью следующей команды: g ++ a.cpp, он выдает: Программа 'g ++' может быть найдена в следующих пакетах: * g ++ * попытка сборки pentium: sudo apt-get intsall & ...
вопрос задан: 16.02.2020
1
ответ

Ошибки компилятора GCC с & ldquo; Нет такого файла или каталога & rdquo;

Моя версия Ubuntu - 12.04 LTS. Я написал несколько программ на Си. Но есть проблема с компилятором. Я гуглил и обнаружил, что мне нужен сборочный комплект. Поэтому я скачал и установил его. После установки ...
вопрос задан: 12.02.2020
1
ответ

Как установить gcc 4.6.3 на 12.10?

Я хочу установить предыдущую версию gcc, чтобы компиляторы Intel работали правильно. Могу ли я использовать apt-get для установки? Если да, то какой репозиторий мне следует использовать? Любая помощь приветствуется.
вопрос задан: 11.02.2020
1
ответ

Не могу скомпилировать любой код C под Xubuntu

Я не опытный программист на Си, но иногда я компилирую некоторый код на Си. В прошлый раз, когда я успешно скомпилировал и запустил некоторый код на C, я сделал это на той же системе, что и сейчас (та же самая ОС на ...
вопрос задан: 22.01.2020
1
ответ

Как мне найти зависимости для программы, прежде чем пытаться ее скомпилировать?

Я пытался кросс-компилировать программу для ARM. Во время компиляции я был очень раздражен, так как мне пришлось искать ряд зависимостей, например, фатальная ошибка: abc / xyz.h: такого файла или каталога нет ...
вопрос задан: 17.01.2020
1
ответ

Директория x11, указанная в make-файле, не существует, но проект компилируется и отлично работает

Таким образом, каталог x11, определенный в make-файле: однако проект отлично компилируется в Kdevelop и запускается без проблем. Если я уберу все включения ...
вопрос задан: 13.01.2020
1
ответ

Не удается установить пакет `libxerces27-dev` при установке` phc` php-компилятора

Чтобы установить phc в соответствии с этим руководством в Ubuntu Oneiric 11.04, я получаю сообщение об ошибке, говорящее о том, что пакет недоступен, как показано на скриншоте ниже Поиск пакета по результату страницы поиска пакетов в Ubuntu ...
вопрос задан: 27.12.2019
1
ответ

Как мне установить Clang версии 3 в 10.10?

Как мне установить версию 3 Clang / LLVM в Ubuntu 10.10? Ubuntu 10.10 устанавливает версию 2.8 по умолчанию. Версия 3 имеет более обширную / актуальную поддержку C ++ и, возможно, C (я не ...
вопрос задан: 15.12.2019
1
ответ

Как я могу установить g77 на Ubuntu 19.04?

Я только что скачал Ubuntu 19.04. Я хочу установить программу, для запуска которой требуется компилятор g77. Я следовал инструкциям, описанным в Установка G77 на Ubuntu> = 14.04, но при вводе команды ...
вопрос задан: 03.07.2019