Установите Sopcast в 64-битной версии

Я новый пользователь Ubuntu, и я нахожу много трудностей при установке Sopcat

Я использовал следующий код:

sudo add-apt-repository ppa:ferramroberto/sopcast
sudo apt-get update
sudo apt-get install sopcast-player

После последней команды у меня было следующий ответ

The following packages have unmet dependencies.
sopcast-player : Depends: sp-auth (>= 3.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

Я погуглил проблему и обнаружил, что мне нужно установить пакет sp-auth_3.2.6.1 ~ lffl ~ natty ~ ppa_i386.deb на https: // launchpad.net/~ferramroberto/+archive/sopcast/+build/2405344

Но когда я пытаюсь установить его, он появляется в моем программном центре "неправильная архитектура 'i386'"

Есть предложения?

4
задан 18.05.2020, 08:03

2 ответа

Сначала у меня была та же проблема с установкой Sopcast , многие уроки в интернете были просто пустой тратой времени. Основная проблема заключалась в том, что ссылка была разорвана на форуме Ubuntu, а панель запуска выдает ошибку 404 при нажатии на страницу. Я перешел на страницу femroberto, но для 64-битного пакета не было ссылки на скачивание. В панели запуска содержалась ошибка об установке sp-auth, и ссылка на скачивание для архитектуры amd64 недоступна. Итак, что я сделал для установки:

  • sudo add-apt-repository ppa: ferramroberto / sopcast ( Чтобы добавить репозиторий )
  • Скачал sp -auth пакет с этого сайта http://www.n00bsonubuntu.net/content/how-to-install-sopcast-on-ubuntu-13-04/
  • Установил sp- пакет auth сначала с помощью gdebi package installer. Вы можете щелкнуть правой кнопкой мыши и использовать ubuntu software centre тоже.
  • Из терминала: sudo apt-get update
  • sudo apt-get install sopcast-player
  • Наконец, Firefox распознает ссылку sop:// ( Хотя это не важно для последней версии Firefox )
    • В адресной строке Firefox введите about:config и введите конфигурацию
    • Найдите network.protocol-handler.expose-all и попробуйте изменив значение на true или false. В моем случае это работало с true.

Теперь я использую Sop-Cast Player

0
ответ дан 18.05.2020, 08:04
  • 1
    Этот won' t работают над 13.04 Полными нетерпения вверх. – Adarsh Bhatt 18.05.2020, 08:04
  • 2
    Я использую Sopcast в 13,10 с тем же методом. Объясните как это doesn' t работа? с какой проблемой Вы столкнулись? что ступает, Вы сделали? – VK1 18.05.2020, 08:04
  • 3
    Работы над Linux Mint 17. Спасибо! – wicky 18.05.2020, 08:05
  • 4
    Вы уверенный, я просто попробовал sudo add-apt-repository ppa:ferramroberto/sopcast и репозиторий didn' t имеют ни дерзкие пакеты полные нетерпения. Это может проверенный здесь , где это говорит " Этот PPA в настоящее время публикует пакеты для Quantal, Точного, Сновещательного, Аккуратного, Индивидуалистка, Lucid, Кармическая, Бойкая, и Выносливая " Если Вы можете, it' s, возможно, потому что Ваш - обновленная система. – Sarmad Shah 18.05.2020, 08:05
  • 5
    btw я установил sopcast плеер от Google Code следующим шагом 2 здесь вместо Ваших инструкций выше: sysads.co.uk/2014/06/install-sopcast-player-0-8-5-ubuntu-14-04. По некоторым причинам, sopcast-плеер wouldn' t установка через способный - добираются (ppa, repo проблема?). – SylvainF 18.05.2020, 08:05

К сожалению, PPA не будет работать для Raring (13.04) и выше. Вам нужна версия командной строки. Для 64-битных систем вам необходимо сначала установить пакет libstdc++5:i386:

sudo apt-get install libstdc++5:i386

Скачать двоичный файл и распаковать его:

wget http://download.easetuner.com/download/sp-auth.tgz
tar xf sp-auth.tgz
cd sp-auth

Теперь вы можете запустить его, просто используя:

> ./sp-sc-auth    
SC Version: 3.2.6  Build time: 2009-11-09 15:09
Usage:
./sp-sc [-TpI] [-b ipaddr] [-u username:password] [-n out:total] <sop://url> <localport> <playerport>

Если вы получили подобное сообщение, вы не установили библиотеку libstdc ++ 5: i386 при запуске:

./sp-sc-auth
zsh: no such file or directory: ./sp-sc-auth

Для использования программы я рекомендую использовать этот помощник .

Простой пример командной строки sp-sc-auth (см. Файл README внутри директории sp-auth):

./sp-sc-auth sop://broker.sopcast.com:3912/148248 3908 8908  > /dev/null &

начнет передавать канал National Geographic, и вы можете Воспроизведите его на порту 8908 с VLC или mplayer, например, открыв URL:

http://localhost:8908/tv.asf
0
ответ дан 18.05.2020, 08:04

Теги

Похожие вопросы