Ubuntu 13.04 Bluetooth A2DP не работает

Скомпилируйте сам выпуск, протестированный с Ubuntu 15.04, таким образом, это работает хорошо с Ubuntu 14.04:

  1. Загрузка исходный код от [1 113] здесь

    cd
    wget http://archive.ubuntu.com/ubuntu/pool/universe/n/netcdf/netcdf_4.1.1.orig.tar.gz
    
  2. Извлечение архив

    tar xf netcdf_4.1.1.orig.tar.gz
    
  3. Входит в папку netcdf-4.1.1/upstream/

    cd netcdf-4.1.1/upstream/
    
  4. Извлечение, следующий архив

    tar xf netcdf-4.1.1.tar.gz
    
  5. Входит в извлеченную папку

    cd netcdf-4.1.1
    
  6. , Выполнение ./configure

    ./configure
    
  7. Запускает компиляцию

    make
    
  8. Установка инструмент checkinstall

    sudo apt-get install checkinstall
    
  9. Установка с [1 112]

    , Это создаст и установит пакет DEB.

    sudo checkinstall
    

12
задан 13.03.2020, 19:42

3 ответа

Это сработало для меня:

1) Откройте /etc/bluetooth/audio.conf с помощью следующей команды *:

gksudo gedit /etc/bluetooth/audio.conf

(*) Для приведенной выше командной строки требуются gedit и gksu пакеты.

2) найдите «Enable = ...» в разделе [General] и удалите Socket из списка.

[General]
Enable = ....

3) Добавьте эту строку в раздел General:

Disable = Socket

4) Сохраните и закройте gedit

5) Перезапустите службу Bluetooth с помощью следующего Команда:

sudo service bluetooth restart

6) Перезапустите pulseaudio для хорошей меры.

pulseaudio -k 
pulseaudio -D

7) Скрестите пальцы и попробуйте.

8
ответ дан 13.03.2020, 19:43
  • 1
    Редактирование этого файла помогло мне. Я не видел Enable=... под [General], но добавил Disable=Socket опция. Я также непрокомментированный AutoConnect=True. Это включило оба режима в pulseaudio, позволив мне измениться от HSP/HFP до A2DP, и звук прибывает стерео. – hugsbrugs 13.03.2020, 19:44
  • 2
    Подобная проблема в 16,04: askubuntu.com/questions/775523/… – Jakob Abfalter 13.03.2020, 19:44

У меня работает Ubuntu 13.04, и после обновления с 12.10 у меня возникла похожая проблема, мне удалось ее временно обойти, но, к сожалению, ее нужно повторять после каждой перезагрузки. Если кто-нибудь может автоматизировать этот процесс, пожалуйста, дайте мне знать, как. Спасибо.

Сначала нам нужно убить pulseaudio, но pulseaudio всегда перезапускается, поэтому нам нужно отключить это - В терминал;

sudo gedit /etc/pulse/client.conf

изменить autospawn = yes на autospawn = no и установите daemon-binary в /bin/true. Убедитесь, что эти строки не закомментированы. Сохраните и закройте файл. Готово, импульсный звук больше не перезапускается после сбоя или принудительного закрытия.

При следующем запуске

sudo gedit /etc/bluetooth/audio.conf

и под General добавьте

Enable=Socket

и закройте файл. Запустите в терминале;

sudo service bluetooth restart

запустите в терминале;

pulseaudio --kill

теперь подключитесь к устройству Bluetooth (я проверял это с помощью BLUEMAN). Запустите в терминале;

pulseaudio

, затем в другом окне терминала;

sudo gedit /etc/bluetooth/audio.conf

удалите Socket, оставив Enable=. Сохраните и закройте файл и запустите в терминале;

sudo service bluetooth restart

снова подключитесь к вашему устройству Bluetooth; - и это должно (надеюсь) сработать.

3
ответ дан 13.03.2020, 19:44
  • 1
    Это - хорошая информация, но для большей помощи, откройте новый вопрос. Спасибо! – falsetru 13.03.2020, 19:44
  • 2
    Это - некоторый сумасшедший материал, но это был единственный способ, которым я получил работу a2dp, благодарит совместно использовать! Вы когда-либо находили лучшее решение? – AJW 13.03.2020, 19:45

У меня были такие же проблемы после обновления с 12.10. После удаления всех файлов конфигурации из моего домашнего каталога и переустановки с нуля bluetooth ad2p снова заработал. Не самое идеальное решение, но оно сработало.

0
ответ дан 13.03.2020, 19:44

Теги

Похожие вопросы