Broadcom BCM4313 13.04 [закрыто]

После того, как у меня возникли те же проблемы с зависанием в linux и моем asrock Q2900, я нашел на немецком IT-сайте решение / обходной путь, предоставленный Intel. ( https://www.golem.de/news/intel-einfrieren-bei-intels-bay-trail-socs-durch-patch-abgefedert-1609-123546.html ) Существует общая проблема с Bay-Trail-SoC от Intel. Ссылка на патч: https://bugzilla.kernel.org/attachment.cgi?id=223851

Дополнительная информация: Этот патч / скрипт действительно получает режим энергосбережения. Приведенное выше решение для темы вообще исключает этот режим.

7
задан 13.04.2017, 15:23

5 ответов

Это известная ошибка с большим количеством дубликатов.

Я последовал совету robamler и понизил версию драйвера до предыдущей версии. Это сработало, по крайней мере, для меня.

Шаги:

  1. Удалить версию bcmwl-kernel-source 6.20

    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

  2. Я перезагрузился, просто чтобы ничего не осталось от старого драйвера. Не уверен, если это необходимо.

  3. Загрузите и установите bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb с http://packages.ubuntu.com/quantal/amd64/bcmwl-kernel-source/download

  4. [ 1128] ОБНОВЛЕНИЕ: Игнорировать обновления до bcmwl-kernel-source_6.20.155.1, пока не появится новая версия, написав:

    Пакет: bcmwl-kernel-source
    Pin: версия 6.20.155.1 + bdcom- 0ubuntu6
    Pin-Priority: -1

- /etc/apt/preferences. (Из этого ответа )


Другие новости: Обновление до Ubuntu 13.10 Saucy Salamander получит предупреждение о пакете 5.100, но о беспроводном интерфейсе все еще работает вполне нормально.


Обновление: теперь, когда доступен bcmwl-kernel-source_6.30.223.141, вы можете переключиться на новый драйвер.

  1. Удалить запись закрепления из /etc/apt/preferences

  2. Удалить версию драйвера 5.100.

    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

  3. Установите последнюю версию из «Центра программного обеспечения» -> «Источники программного обеспечения» -> «Дополнительные драйверы».

7
ответ дан 11.10.2019, 11:32
  • 1
    Хотя я не протестировал это решение, я отметил его как корректный ответ, поскольку это, кажется, обеспечивает достаточно детали, чтобы объяснить, как откатывать драйвер к предыдущей версии в случае, если Вы используете 13.04. – Matt 16.09.2013, 17:28
  • 2
    Я протестировал его, это хорошо работает! – marcovtwout 13.10.2013, 15:25
  • 3
    На Монетном дворе 17 (на основе Ubuntu 14.04), я didn' t имеют bcmwl-kernel-source пакет, устанавливание его вытянуло последнюю версию, которая работает как чемпион! – Ja͢ck 16.06.2014, 06:19
  • 4
    Quantal repos удалены, кто-то знает, где я могу загрузить старый пакет? – Bruno 09.08.2014, 13:35

Ubuntu 13.04 использует ядро ​​linux 3.8, поэтому ваш модуль беспроводной связи может не сработать. Это известная проблема ( Bug Report ).

Пожалуйста, следуйте этим инструкциям:

  • Скачать этот файл (amd64 для вашей 64-битной системы)
  • запустить dpkg -i ~/Downloads/bcmwl-kernel-source_6.20.155.1+bdcom-0ubuntu6_amd64.deb [116 ]
  • sudo modprobe wl

Этот ответ зачислен на Glutanimate в на этот вопрос .

1
ответ дан 11.10.2019, 11:32

Я заметил, что получил популярный значок вопроса для этого вопроса, который должен означать, что я определенно не единственный, у кого есть эти проблемы.

Не знаю, помогает ли это кому-то еще, но для меня было решение выпустить релиз 13.04, и я начал использовать 12.04 LTS x64. Wifi адаптер работает безупречно везде, где я его пробую. И лучшая часть это работает из коробки . Он работал во время загрузки рабочего стола с USB и продолжал работать после того, как я установил Ubuntu на HD.

В моих ограниченных знаниях, и, как я понимаю, это должно относиться к версии драйвера, используемого в 12.04 LTS x64. По какой-то причине версия, которая поставляется с 13.04 (не знаю о 13.10, не пробовала), не работает, как положено.

Надеюсь, это кому-нибудь поможет, даже если он получит только необходимую информацию для отката драйвера до стабильной точки в будущих версиях.

1
ответ дан 11.10.2019, 11:32
  • 1
    Ответ хорош, но мнения don' t действительно вписывается в этот сайт, который пытается быть объективным и они doesn' t отвечают на этот вопрос. Я удалю их, не стесняйтесь редактировать затем обратно, если Вы хотите. – selfawaresoup 16.09.2013, 12:19
  • 2
    Я склонен соглашаться... Напыщенная речь wasn' t полезный вообще, gj! – Tomas M 16.09.2013, 12:37

Попробуйте удалить этот пакет bcmwl-kernel-source через sudo apt-get remove bcmwl-kernel-source и запустить эту команду в терминале sudo modprobe brcmsmac.

0
ответ дан 11.10.2019, 11:32
  • 1
    попробованный это уже, не работал – Gumbo 04.07.2013, 18:35

У меня тоже есть адаптер Broadcom 4313 [14e4: 4727] (rev 01). В нашем доме есть три разные сети Wi-Fi, все с шифрованием WPA / WPA2. В Ubuntu 13.04 у меня не было проблем с Wi-Fi, я мог использовать любую из сетей.

Но когда я обновил Ubuntu до 13.10, я смог использовать только две из трех сетей. Я все еще мог подключиться к третьей сети, и информация DHCP была бы передана, но я не мог отправить какие-либо пользовательские данные в этой сети. Например: проверка связи с маршрутизатором не приведет к возврату пакетов.

Понижение версии bcmwl-kernel-source решило мою проблему.

Совет: когда я понизил версию драйвера, мне пришлось удалить черный список в /etc/modprobe.d: cd /etc/modprobe.d sudo mv blacklist-bcm43.conf ..

0
ответ дан 11.10.2019, 11:32

Теги

Похожие вопросы