Кодовые блоки не работают вообще после установки

Небольшая история:

Кодовые блоки 10.05 использовались в моем Ubuntu без сбоев. Теперь я скачал пакет deb с кодовыми блоками 12.11 и установил. Но, как ни странно, он забывает каждую мою модификацию каждый раз, когда я закрываюсь. Итак, я удалил пакет deb, затем автоматически удалил поврежденные пакеты, а затем переустановил кодовые блоки 10.05.


Но у меня не было счастливого конца. Теперь кодовые блоки устанавливаются правильно. Но если я нажимаю на значок кодовых блоков, он не открывается или вообще не отвечает. Я даже пытался переустановить, та же проблема.

Примечание: он устанавливается правильно, без каких-либо сообщений об ошибках, просто не работает вообще. Нет сообщения об ошибке или что-нибудь.

1
задан 13.04.2020, 11:03

1 ответ

Нечто подобное случилось со мной. Правильнее всего сделать попытку полной переустановки.

$ sudo apt-get autoremove --purge codeblocks

Это удалит все ваши файлы конфигурации и удалит использованные пакеты вместе с кодовыми блоками, такими как codeblocks-common и т. Д.

Если вы установите снова, он будет запускаться без видимых ошибок, но, скорее всего, он не установит codeblocks-contrib из-за несовместимости версий, если ваши пакеты сломаны, как у меня. И попытка запустить codeblocks from даст вам «codeblocks: error lookup error»

Для меня исправление состояло в том, чтобы сначала очистить libcodeblocks0, который был сломан для меня

$ sudo apt-get remove --purge libcodeblocks0

Затем установить его снова с

$ sudo apt-get update
$ sudo apt-get install codeblocks
0
ответ дан 13.04.2020, 11:04
  • 1
    Я должен сделать это один раз в месяц – Frank 13.04.2020, 11:04

Теги

Похожие вопросы