Обновление apt-get не работает (Не найдено [IP: 91.189.92.201 80]) [закрыто]

Когда я пытаюсь запустить обновление apt-get, я получаю следующие сообщения об ошибках: Я использую:

Distributor ID: Ubuntu
Description:    Ubuntu 11.04
Release:    11.04
Codename:   natty




W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty-security/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

E: Some index files failed to download. They have been ignored, or old ones used

Я пробовал несколько решений:

  1. Как выбрать лучший сервер из раздела Ubuntu Software: он никогда не мог выбрать лучший сервер, так как он выдал ошибку (Проверьте ваше интернет-соединение.) Мой интернет работает нормально, и я могу просматривать.

  2. sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

  3. sudo dpkg --configure -a

Ничего не работает. Я не могу опубликовать полное сообщение об ошибке, так как оно не позволяет мне публиковать более двух ссылок.

18
задан 13.04.2020, 15:04

1 ответ

Natty больше не поддерживается или получает обновления. Вам нужно перейти с archive.ubuntu.com на сервер old-releases.ubuntu.com , который является целью упомянутой вами команды sed (у меня не было шансов чтобы подтвердить, работает ли это или нет). Откройте и замените все записи в следующем файле:

sudo gedit /etc/apt/sources.list

Затем выполните команды обновления и обновления, как обычно.

0
ответ дан 13.04.2020, 15:05
  • 1
    Doesn' t работают на меня. продолжайте входить в старые выпуски WARNING:root:file ' сновещательный tar.gz.gpg' пропавшие без вести Неудавшегося для выборки Выборки отказавшего обновления. Может быть сетевая проблема. Испытанные различные зеркала, ни один не хочет играть в бейсбол, обновляя аккуратный до сновещательного. – Paul 13.04.2020, 15:05
  • 2
    Это [частично] работало на меня с " zesty" выпуск. – Josh Caswell 13.04.2020, 15:06
  • 3
    С 2 015 этих doesn' t больше работают. Сосет ту человечность, такой clusterfuck сложности что это can' t выдерживают немного более старые выпуски. Собираясь попытка убедить моего администратора переключаться на OpenBSD. – Michael Kay 13.04.2020, 15:06

Теги

Похожие вопросы