Установка драйверов для & ldquo; BT-930 BusLogic flashpoint LT & rdquo ;, Ubuntu 12.04

Я пытаюсь установить драйвер для платы контроллера SCSI: BT-930 BusLogic flashpoint LT.

Я нахожусь на 64-битной Ubuntu 12.04 с ядром 3.2.0-54.

У меня есть (я думаю) архив, который мне нужен, и он находится на рабочем столе: BusLogic-2.0.15.tar.gz, и я уже разархивировал его, и он содержит 9 файлов, 2 из которых - файлы .c, а один - один. .h файл, а также различные документы readme и заметки о выпуске.

Это мои инструкции по установке, но я думаю, что они были написаны для другой и / или более ранней версии Linux.

  588 This distribution was prepared for Linux kernel version 2.0.35, but should be
  589 compatible with 2.0.4 or any later 2.0 series kernel.
  590 
  591 To install the new BusLogic SCSI driver, you may use the following commands,
  592 replacing "/usr/src" with wherever you keep your Linux kernel source tree:
  593 
  594   cd /usr/src
  595   tar -xvzf BusLogic-2.0.15.tar.gz
  596   mv README.* LICENSE.* BusLogic.[ch] FlashPoint.c linux/drivers/scsi
  597   patch -p0 < BusLogic.patch (only for 2.0.33 and below)
  598   cd linux
  599   make config
  600   make depend
  601   make zImage
  602 
  603 Then install "arch/i386/boot/zImage" as your standard kernel, run lilo if
  604 appropriate, and reboot.

Как новичок в Linux, большинство этих строк для меня абсолютно НИЧЕГО, но я набрал их в Терминале, даже скопировал и вставил, но все безрезультатно.

Может кто-нибудь написать мне новый набор инструкций для моей версии Ubuntu, который будет работать. Спасибо.

1
задан 13.04.2020, 21:41

1 ответ

Источники драйверов, которые вы скачали, очень устарели и не будут компилироваться для вашего текущего ядра Linux, которое вы используете. Источник упоминает 2.0 series Linux kernel, они были современными около 10 - 15 лет назад.

Я не думаю, что можно запустить и запустить этот контроллер с Ubuntu. Google дал мне это: http://www.tomshardware.com/answers/id-1819571/linux-buslogic-930-flashpoint-scsi-card.html

Редактировать Подведение итогов из других «ответов».

Похоже, это SCSI-контроллер, изначально продаваемый вместе с Iomega JAZ-Drive. Так что я думаю, что вы действительно пытаетесь заставить это старое оборудование снова работать.

Если бы это был мой собственный JAZ-диск, я бы попытался запустить его с другим более новым SCSI-контроллером.

Но, видя, что для этого нужно что-то серьезное, я настоятельно советую пойти в вашу следующую локальную Linux User Group , если вы принесете им свое оборудование и спросите у них ] обернется и постарается сделать все, чтобы это сработало ...

Я могу сказать из опыта. Я запускаю свой собственный LUG там, где я живу; -)

Также, пожалуйста, не сердитесь, когда (или если) моды будут удалять ваши другие «ответы», так работает askubuntu.com.

1
ответ дан 13.04.2020, 21:42

Теги

Похожие вопросы