Как обновить кофейный скрипт?

Я получил следующую ошибку, когда попытался посмотреть сценарии кофе coffee -o js -cw coffee.

/usr/local/lib/node_modules/coffee-script/lib/coffee-script/command.js:321
        throw e;
              ^
Error: watch Unknown system errno 28
    at errnoException (fs.js:636:11)
    at FSWatcher.start (fs.js:663:11)
    at Object.watch (fs.js:691:11)
    at /usr/local/lib/node_modules/coffee-script/lib/coffee-script/command.js:287:27
    at Object.oncomplete (/usr/local/lib/node_modules/coffee-script/lib/coffee-script/command.js:100:11)

Я понятия не имею, что происходит с ошибкой.

Затем я проверил версии, coffee -v - 1.6.1, а node -v - v0.6.12.

Согласно официальному сайту ( http://coffeescript.org/ ) последняя версия - 1.6.3, поэтому я хотел обновить coffee до npm update -g coffee-script, но это также не помогло. [1120 ]

npm WARN coffee-script@1.6.1 package.json: bugs['name'] should probably be bugs['url']
npm http GET https://registry.npmjs.org/coffee-script
npm http 304 https://registry.npmjs.org/coffee-script

Как я могу обновить скрипт кофе?

Редактировать 2013/10/11

В моем каталоге скриптов кофе есть только один файл box_wrapper.coffee .

$ ->
  $("body").children().wrap ->
    "
"

Редактировать 2013/10/16

Я попытался переустановить coffee, поэтому я сделал так.

$ sudo npm -g rm coffee
npm WARN Not installed in /usr/local/lib/node_modules coffee
$ coffee -v
CoffeeScript version 1.6.1

Я не могу удалить coffee. И я тоже так пытался.

$ sudo apt-get remove npm
$ npm -v
-bash: /usr/bin/npm: No such file or directory
$ sudo apt-get install npm
$ npm -v
1.1.4
$ sudo npm -g install coffee

# I omit a lot of `GET` parts.

npm http 304 https://registry.npmjs.org/mkdirp/0.3.4
npm ERR! error installing express@3.2.6
npm http 304 https://registry.npmjs.org/assertion-error/1.0.0
npm http 304 https://registry.npmjs.org/growl
npm http 304 https://registry.npmjs.org/jade/0.26.3
npm http 304 https://registry.npmjs.org/diff/1.0.2
npm http 304 https://registry.npmjs.org/mkdirp/0.3.5
npm http 304 https://registry.npmjs.org/glob/3.2.1
npm http 304 https://registry.npmjs.org/ms/0.3.0
npm ERR! error rolling back express@3.2.6 Error: UNKNOWN, unknown error '/usr/local/lib/node_modules/coffee/node_modules/express'
npm ERR! error installing coffee@0.0.1

npm ERR! EEXIST, file already exists '/usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules'
npm ERR! File exists: /usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules
npm ERR! Move it away, and try again.
npm ERR! 
npm ERR! System Linux 3.2.0-54-generic-pae
npm ERR! command "node" "/usr/bin/npm" "-g" "install" "coffee"
npm ERR! cwd /home/ironsand
npm ERR! node -v v0.6.12
npm ERR! npm -v 1.1.4
npm ERR! path /usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules
npm ERR! fstream_path /usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules/___debug.npm
npm ERR! fstream_type Directory
npm ERR! fstream_class DirWriter
npm ERR! code EEXIST
npm ERR! message EEXIST, file already exists '/usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules'
npm ERR! errno {}
npm ERR! fstream_stack /usr/lib/nodejs/fstream/lib/writer.js:161:23
npm ERR! fstream_stack Object.oncomplete (/usr/lib/nodejs/mkdirp.js:34:53)

npm ERR! EEXIST, file already exists '/usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules'
npm ERR! File exists: /usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules
npm ERR! Move it away, and try again.
npm ERR! 
npm ERR! System Linux 3.2.0-54-generic-pae
npm ERR! command "node" "/usr/bin/npm" "-g" "install" "coffee"
npm ERR! cwd /home/ironsand
npm ERR! node -v v0.6.12
npm ERR! npm -v 1.1.4
npm ERR! path /usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules
npm ERR! fstream_path /usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules/___debug.npm
npm ERR! fstream_type Directory
npm ERR! fstream_class DirWriter
npm ERR! code EEXIST
npm ERR! message EEXIST, file already exists '/usr/local/lib/node_modules/coffee/node_modules/mocha/node_modules'
npm ERR! errno {}
npm ERR! fstream_stack /usr/lib/nodejs/fstream/lib/writer.js:161:23
npm ERR! fstream_stack Object.oncomplete (/usr/lib/nodejs/mkdirp.js:34:53)
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/ironsand/npm-debug.log
npm not ok

И npm-debug.log - это пустой файл.

5
задан 16.04.2020, 00:21

2 ответа

Ошибка возникает из-за старой версии nodejs. Пакет Ubuntu 12.04, 13.04 по умолчанию nodejs - версия 0.6.x.

Я обновил версию nodejs до v0.10.20 следующим образом, и проблема решена.

sudo apt-get update
sudo apt-get install python-software-properties python g++ make
sudo add-apt-repository ppa:chris-lea/node.js
sudo apt-get update
sudo apt-get install nodejs

Я следовал инструкциям отсюда. https://github.com/joyent/node/wiki/Installing-Node.js-via-package-manager

5
ответ дан 16.04.2020, 00:23

Дело в том, что репозитории npmjs имеют не 1.6.3, а 1.6.1. Я предполагаю здесь, но причина вашей ошибки в том, что ваш код , а не CoffeeScript:

    } catch (e) {
      if (e.code !== 'ENOENT') {
        throw e;
      }
    }
  };

Выше указано, что если e.code не совсем совпадает с [ 115], затем выдайте ошибку, которая в вашем случае:

Error: watch Unknown system errno 28
    at errnoException (fs.js:636:11)
    at FSWatcher.start (fs.js:663:11)
    at Object.watch (fs.js:691:11)
    at /usr/local/lib/node_modules/coffee-script/lib/coffee-script/command.js:287:27
    at Object.oncomplete (/usr/local/lib/node_modules/coffee-script/lib/coffee-script/command.js:100:11)

Я бы проверил файл fs.js и / или отменил последние изменения, которые вы внесли в свой код. С CoffeScript все в порядке, проблема в другом.


Для людей, которые действительно могут обновить свой CoffeScript

Если вы действительно хотите использовать последнюю версию CoffeScript, то для ее установки используется метод:

npm install -g http://github.com/jashkenas/coffee-script/tarball/master

Это будет установите последнюю версию CoffeScript, если вы хотите версию 1.6.3, вам следует использовать:

npm install -g http://github.com/jashkenas/coffee-script/tarball/1.6.3

Замените 1.6.3 версией CoffeScript, которая вам нравится.

5
ответ дан 16.04.2020, 00:22

Теги

Похожие вопросы