GLIB_GSETTINGS не найден при компиляции расширения gnome

Не сумев установить расширение gnome с сайта, я искал другой путь. Руководство, которое я нашел в Google, выглядело так:

sudo apt-get install gnome-common
git clone git://git.gnome.org/gnome-shell-extensions
cd gnome-shell-extensions
./autogen.sh --prefix=$HOME/.local --enable-extensions="drop-down-terminal"

Последняя команда завершилась неудачно, но со следующей ошибкой:

./configure: line 4276: GLIB_GSETTINGS: command not found
configure: error: invalid extension drop-down-terminal

К сожалению, я не нашел ничего полезного в Google. [112 ]
Любое предложение?

Спасибо.

0
задан 14.04.2020, 01:29

1 ответ

Конфигурирование ошибок скрипта трудно читать. Скорее всего, вам не хватает библиотеки для разработки.

Если этот пакет уже существует в Ubuntu, но вы хотите скомпилировать более новую версию, вы можете сделать что-то вроде:

sudo apt-get build-dep gnome-shell-extensions

Это установит все отсутствующие зависимости сборки.

0
ответ дан 14.04.2020, 01:30
  • 1
    ' Неспособный найти исходный пакет для gnome-shell-extensions'. Вы разобрались в нем, хотя, необходимый пакет был libglib2.0-dev – Navin 14.04.2020, 01:30

Теги

Похожие вопросы