Беспроводная карта показывается в одном месте, а не в другом?

У меня странная проблема, на которую я не смог найти ответ после нескольких часов работы Google. Сервер Ubuntu версии 12.04.

lspci -v показывает мою беспроводную карту в следующем виде:

Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
Subsystem: Linksys WMP54GS v1.1 802.11g Wireless-G PCI Adapter with SpeedBooster
Flags: bus master, fast devsel, latency 64, IRQ 16
Memory at fe9fc000 (32-bit, non-prefetchable) [size=8K]
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb

Однако ifconfig показывает:

eth0      Link encap:Ethernet  HWaddr 00:12:3f:d4:6c:d2
          inet addr:192.168.2.14  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::212:3fff:fed4:6cd2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:318642 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36376 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:89728370 (89.7 MB)  TX bytes:7303647 (7.3 MB)
          Interrupt:17

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

и iwconfig показывает:

lo        no wireless extensions.

eth0      no wireless extensions.

Как сделать так, чтобы моя беспроводная карта отображалась в качестве действующего сетевого адаптера для команд конфигурации сети? Компьютер ясно читает это, согласно lspci.

1
задан 14.04.2020, 19:05

1 ответ

Для правильной работы вашей карты требуется прошивка. Пожалуйста, получите временное проводное Ethernet-соединение, откройте терминал и выполните:

sudo apt-get install linux-firmware-nonfree
sudo modprobe -r b43 && sudo modprobe b43

. Может потребоваться перезагрузка.

0
ответ дан 14.04.2020, 19:05
  • 1
    Это заставило его обнаруживаться правильно в iwconfig. Спасибо! – J VBA 14.04.2020, 19:06

Теги

Похожие вопросы