Исходники Puppetlabs apt приводят к ошибке неаутентифицированных пакетов

Я только что создал новую виртуальную машину из Hetzner с Ubuntu 12.04 и начал ее настраивать.

Шаги, которые я сделал, в основном

wget http://apt.puppetlabs.com/puppetlabs-release-precise.deb
sudo dpkg -i puppetlabs-release-precise.deb
sudo apt-get update && sudo apt-get -y install git puppet 

Это вызывает ошибку:

WARNING: The following packages cannot be authenticated!
augeas-lenses debconf-utils ruby virt-what liberror-perl git-man git libaugeas0 libaugeas-ruby1.8 libaugeas-ruby ruby-json libjson-ruby libruby libshadow-ruby1.8 patch

Я не знаю, как решить эту проблему. Я только что создал локальную виртуальную машину с Ubuntu 12.04.3, и она работала без нареканий.

Несколько вещей, которые я пробовал просматривать:

sudo apt-get remove debian-keyring debian-archive-keyring
sudo apt-get clean
sudo apt-get update
sudo apt-get -y install debian-keyring debian-archive-keyring

и

sudo apt-key update
sudo apt-get update

Не помогли.

Есть идеи, где искать проблему?

0
задан 14.04.2020, 19:52

1 ответ

Основная проблема, похоже, связана с изменением имени хоста системы.

Я повторил процесс в другом порядке, сначала сконфигурировав имя хоста, чем загрузку и добавление пакета, и он работал нормально!

1
ответ дан 14.04.2020, 19:53

Теги

Похожие вопросы