apt-get upgrade перезаписывает конфигурации сборки

Ubuntu 13.10 вышла более чем 3 года назад и только имела 9 месяцев обновлений программного обеспечения и поддержки. Это достигло состояния "конца жизненного цикла" в середине 2014. (См. https://www.ubuntu.com/info/release-end-of-life и https://wiki.ubuntu.com/Releases). Так как Ваша версия Ubuntu больше не поддерживается вообще Каноническими, новыми версиями Firefox, не сделаны доступными для Вашей системы. Необходимо будет обновить до Ubuntu 14.04 или 16.04 (или 16.10) для получения продолжающейся безопасности и обновлений программного обеспечения.

0
задан 15.04.2020, 04:25

1 ответ

Когда вы говорите «измененные конфигурации», вы имеете в виду, что вы добавили некоторые файлы конфигурации в /etc/somewhere или что вы скомпилировали пакет с другими параметрами?

Если первое, то эти файлы, если они объявлены Не следует прикасаться к файлам конфигурации при обновлении в соответствии с политикой Debian: http://www.debian.org/doc/debian-policy/ch-files.html .

Если последнее, то да, apt-get делает то, что вы просите: он полностью обновляет пакет (и все его двоичные файлы) до новой версии. Если вы хотите исключить пакет из процесса обновления (точнее, если вы хотите сохранить определенную версию пакета независимо от того, доступна ли обновленная версия), то вам нужно «закрепить» пакет , Подробнее о закреплении см. Здесь:

https://help.ubuntu.com/community/PinningHowto

0
ответ дан 15.04.2020, 04:26
  • 1
    Да, это был последний, и проблема, it' s не один пакет, если I' m разбирающийся в нем, это обновление, например, было для чего-то как perlmagick и несколько других, и поэтому теперь я имею к " pin" их слишком? И другая вещь, он хорошо к " pin" их, ничего забавного не произошло бы? – albert8413 15.04.2020, 04:26
  • 2
    Чтобы быть на 100% уверенными, необходимо прикрепить любые пакеты, которые Вы изменили. Прикрепление безопасно, you' ре, просто сохраняющее те версии без изменения, единственного шанса для чего-то " funny" то, если пакет имеет обновление, которое зависит от более новой версии imagemagick; это просто wouldn' t быть примененным, потому что это потребовало бы нового imagemagick, который Вы определили (с помощью механизма прикрепления) что Вы don' t хотят. – ppotaczek 15.04.2020, 04:27

Теги

Похожие вопросы