php5-fpm: зависит: php5-common (= 5.3.10-1ubuntu3.8), но 5.4.6-1ubuntu1.4 должен быть установлен

Я хочу настроить PHP за Nginx с FastCGI, но я остановился на sudo apt-get -f install php5-fpm

, что я пробовал:

sudo apt-get -f install php5-fpm 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-fpm : Depends: php5-common (= 5.3.10-1ubuntu3.8) but 5.4.6-1ubuntu1.4 is to be installed
E: Unable to correct problems, you have held broken packages.

мой список источников (этот сервер только для украинской сети, без связи с миром)

deb http://mirror.yandex.ru/ubuntu precise universe
deb http://mirror.yandex.ru/ubuntu precise-updates universe

deb http://mirror.yandex.ru/ubuntu quantal-security main restricted
deb-src http://mirror.yandex.ru/ubuntu quantal-security main restricted
1
задан 15.04.2020, 03:55

1 ответ

Проблема в том, что вы смешиваете репозитории разных версий. Вам никогда не следует этого делать!

точная вселенная, потому что у Яндекса нет основного ограниченного

Репозиторий Яндекса содержит main, restricted, [ 112] и multiverse во всех precise precise-updates и precise-security, как можно увидеть здесь:

enter image description here

enter image description here [ 1116]

enter image description here

После того, как вы исправили свои репозитории, просто сделайте sudo apt-get update, и все будет хорошо.

Основная квантовая защита ограничена, потому что мне нужен php5-fpm

Precise имеет пакет!

http://packages.ubuntu.com / поиск? ключевые слова = php5-FPM

0
ответ дан 15.04.2020, 03:55
  • 1
    позволяет говорят, что я помещаю [только 110], чем я can' t устанавливают php5 sudo apt-get install php5 E: Пакет ' php5' не имеет никакого кандидата установки – erikkallen 15.04.2020, 03:56
  • 2
    @dvrecmfo, конечно, php5 находится в основных репозиториях, необходимо поместить что-то вроде этого: paste.ubuntu.com/6220331 – David Z 15.04.2020, 03:56

Теги

Похожие вопросы