Как установить последнюю версию пакета? [Дубликат]

На этот вопрос уже есть ответ:

У меня установлен Qt Creator 2.4 из диспетчера пакетов, но версия 4.8 вышла, и я хочу попробовать. Как правильно обновиться до последней версии, стоит ли загружать и устанавливать ее вручную?

0
задан 15.04.2020, 17:58

1 ответ

Ubuntu обычно не предоставляет самую последнюю версию пакета, потому что Ubuntu фокусируется на стабильности. Поэтому, если вы хотите установить новую версию программы, вы можете либо загрузить код и скомпилировать его из исходного кода (сложнее), либо просто использовать PPA (проще).

Предполагая, что вы предпочитаете проще, просто найдите в панели запуска нужный вам пакет, и вы, вероятно, найдете PPA для того, что ищете. Вот Qtcreator PPA https://launchpad.net/~alexey-ivanov/+archive/qtcreator

PPA

Чтобы установить его, добавьте строки, выделенные на изображении
deb http://ppa.launchpad.net/alexey-ivanov/qtcreator/ubuntu raring main
deb-src http://ppa.launchpad.net/alexey-ivanov/qtcreator/ubuntu raring main

в конце файла /etc/apt/sources.list и запустите sudo apt-get update && sudo apt-get upgrade. Не забудьте изменить raring на версию Ubuntu, которую вы используете.

1
ответ дан 15.04.2020, 17:59

Теги

Похожие вопросы