Невозможно найти пакет linux-kernel-devel

Я почти уверен, что есть еще три ссылки, сообщающие об этой же проблеме. Я получаю

Я перехожу по этой ссылке, чтобы скомпилировать свое собственное ядро ​​

https: // help.ubuntu.com/community/Kernel/Compile/

Инструменты, которые вам понадобятся Для начала вам потребуется установить несколько пакетов. Точные команды для установки этих пакетов зависят от того, какую версию вы используете:

Hardy (8.04):

sudo apt-get install linux-kernel-devel fakeroot kernel-wedge build-essential [ 119] blockquote>

Когда я пробую вышеупомянутые пакеты, fakroot, kernel-wedge, build-essentail кажутся доступными для терминала, за исключением linux-kernel-devel.

$ sudo apt-get install linux-kernel-devel  
Reading package lists... Done 
Building dependency tree         
Reading state information... Done
E:Unable to locate package linux-kernel-devel

Я пытаюсь установить Hardy на свою Ubuntu 12.04.3 LTS. До сих пор я пытался

sudo apt-get update && sudo apt-get install linux-kernel-devel 

Я даже пытался изменить исходный список и добавил строку юниверса в строку ниже.

deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted

Что мне здесь не хватает? Почему Ubuntu не может найти пакет? Я подключен к Интернету.

2
задан 15.04.2020, 19:18

1 ответ

Этот конкретный пакет не упакован в Ubuntu 10.04 и выше. Если вы пытаетесь скомпилировать собственное ядро, правильный способ получить необходимые условия в Ubuntu 10.04 и более поздних версиях - выполнить следующие команды:

sudo apt-get install fakeroot build-essential crash kexec-tools makedumpfile kernel-wedge
sudo apt-get build-dep linux
sudo apt-get install git-core libncurses5 libncurses5-dev libelf-dev asciidoc binutils-dev

Hardy - это совершенно другая версия Ubuntu, и он быть установлен на другую версию. Если вам нужна Ubuntu 8.04 (Hardy Heron), вам нужно найти ее копию онлайн, скачать ее, а затем записать на CD или DVD.

Тем не менее, 8.04 давно не работает, и рекомендуется использовать более новую версию Ubuntu.

4
ответ дан 15.04.2020, 19:18
  • 1
    Удивительный Ian. Я надеялся услышать, что пакет удерживается от использования. Я действительно устанавливал 12. X а не более ранние, так как в документе было сказано, что предпосылка для установки пользовательского ядра должна установить Харди и Lucid, я был персистентным при нахождении, как сделать это. – nwalton 15.04.2020, 19:19

Теги

Похожие вопросы