Обновление Google Chrome не будет установлено из-за неудовлетворенных зависимостей

Сегодня было обновление для Google Chrome , и его нельзя было установить из-за неразрешенных зависимостей. Как я могу это исправить?

Screenshot of Synaptic

14
задан 17.04.2020, 20:42

4 ответа

Попробуйте это.

Загрузите пустые пакеты:

wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32gcc1_4.7.3-1ubuntu1_all.deb
wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32stdc%2B%2B6_4.7.3-1ubuntu1_all.deb
wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/libc6-i386_2.17-0ubuntu5_all.deb

Затем установите их:

sudo dpkg -i lib32gcc1_4.7.3-1ubuntu1_all.deb lib32stdc++6_4.7.3-1ubuntu1_all.deb libc6-i386_2.17-0ubuntu5_all.deb

Затем вы можете установить Google Chrome:

sudo dpkg -i google-chrome-stable_current_i386.deb
3
ответ дан 17.04.2020, 20:45
  • 1
    Работа для меня. Но это не плохо для будущих автоматических обновлений этого, упаковывает? – travis.js 17.04.2020, 20:45
  • 2
    Хороший вопрос. Но так или иначе эти пакеты не могут быть установлены на 32-разрядном Ububntu нормальным способом, таким образом, я думаю они won' t быть обновленным в нормальном слишком. – johnny 5 17.04.2020, 20:45

Возможно, вы столкнулись с этой ошибкой: Неправильные 64-битные зависимости в 32-битной версии Ubuntu . Над этим работают.

Все, что я могу предложить, - это следить за прогрессом этой ошибки и оставаться на текущей версии, пока она не будет исправлена. Там есть несколько комментариев, указывающих, что это исправлено, но затем рассмотрим более свежий отчет об ошибке, который был объединен с # 304017 , поэтому я предлагаю терпение. Если хотите, просто sudo снимите флажок Google Chrome ppa в ваших источниках программного обеспечения. Вы можете включить его в любое время.

4
ответ дан 17.04.2020, 20:43

У меня была точно такая же проблема на двух разных 32-битных машинах 12.04; см. Невозможно выбрать обновления Chrome в Ubuntu 12.04

Однако я могу сообщить, что по состоянию на полдень 23 октября 2013 года проблема, похоже, для меня решена. Обновление Chrome может быть выбрано и успешно установлено.

0
ответ дан 17.04.2020, 20:44

Видите, у меня тоже есть эта проблема, и я провел небольшое собственное исследование, чтобы понять, в чем проблема. Кроме того, у меня есть точно такие же ошибки, которые были опубликованы.

Как выяснилось, разработчики кода Google для 32-битной Ubuntu / Debian Google Chrome «пошутили» и случайно добавили те зависимости, которые имеют 64-битную архитектуру и недоступны для 32-битной Ubuntu / Debian. Как оказалось, 64-битная программа работает нормально.

Все, что мы можем сделать, это ждать, пока не выйдет другое обновление, которое исправит эту проблему; В настоящее время я терпеливо жду, используя Chromium в качестве своей резервной копии. Обязательно обновляйте / устанавливайте при выходе новой версии Google Chrome, поскольку это, возможно, и, мы надеемся, исправит эту проблему.

Если вы не можете ждать, я прочитал, что нестабильная / бета-версия Chrome не имеет этой проблемы, поскольку она была решена во время разработки этой новой версии. Вы можете скачать его здесь.

Я бы только скачал это, если вы не можете ждать или использовать другой браузер, пока не выйдет стабильное обновление.

источник: Обновление Google Chrome не будет установлено из-за неудовлетворенных зависимостей

8
ответ дан 17.04.2020, 20:44

Теги

Похожие вопросы