Дисплей Ubuntu - не существует

Python APT API можно использовать для написания краткого сценария для этого:

#! /usr/bin/python3
import sys
from apt import cache

c = cache.Cache()
for pkg in sys.argv[1:]:
    c[pkg].mark_delete()   

print('\n'.join(pkg.name for pkg in c.get_changes() if pkg.marked_delete))

Пример:

$ apt-get remove -s bash | grep Remv  
Remv winusb [1.0.11+saucy1]
Remv gdm [3.18.3-0ubuntu2]
Remv gdm3 [3.18.3-0ubuntu2]
Remv bash [4.3-14ubuntu1.2] [inxi:amd64 lightdm:amd64 bash-completion:amd64 ]
Remv bash-completion [1:2.1-4.2ubuntu1.1] [inxi:amd64 lightdm:amd64 ]
Remv inxi [2.2.35-0ubuntu1] [lightdm:amd64 ]
Remv lightdm [1.18.3-0ubuntu1.1]

$ apt-cache rdepends bash --installed | sed '1,2d' | sort -u
  bash-completion
    bash:i386
  gdm3
  inxi
  lightdm
  winusb

$ ./check.py bash                                             
inxi
winusb
gdm
gdm3
bash
lightdm
bash-completion

0
задан 16.04.2020, 14:43

1 ответ

Необходимый устаревший графический драйвер недоступен в Ubuntu Software Center в Ubuntu 13.04. Вот почему вы получаете черный экран. Это также причина, по которой ваш ноутбук HP Pavilion dv5-1004nr прекрасно работал с Ubuntu вплоть до Ubuntu 11.04.

Однако вы все равно можете установить правильный графический драйвер для своего ноутбука HP Pavilion dv5 1004nr в Ubuntu 13.04, добавив этот Ubuntu PPA (Personal Package Archive): ppa:makson96/fglrx в Источники программного обеспечения вашей системы. Чтобы установить графический драйвер AMD Catalyst Legacy 13.1 в Ubuntu 13.04, откройте терминал и выполните следующие команды:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy  

... и перезагрузите компьютер, чтобы включить графический драйвер AMD Catalyst Legacy 13.1. [ 114]

Если взглянуть на вещи с более широкой точки зрения, графический драйвер AMD Catalyst Legacy 13.1 не поддерживается для Ubuntu 13.10, а Ubuntu 13.04 не будет поддерживаться обновлениями после января 2014 года. Так что это не даст вам операционную систему, которая поддерживаются обновлениями в течение длительного периода времени, если только вы не установили Ubuntu 12.04, который является версией долгосрочной поддержки, которая поддерживается обновлениями до апреля 2017 года. Перечисленные выше те же команды терминала также являются командами, используемыми для установки AMD Catalyst Legacy 13.1 графический драйвер в Ubuntu 12.04.

В настоящее время у вас все еще есть Ubuntu 13.04, так что это дает вам возможность проверить, решает ли графический драйвер AMD Catalyst Legacy 13.1 вашу проблему с черным экраном, и затем вы можете решить, стоит ли устанавливать Ubuntu 12.04.

0
ответ дан 16.04.2020, 14:44
  • 1
    Я haven' t получил решение Вашей проблемы. Тем не менее, существует еще одна вещь, которую необходимо сделать. Существует веб-сайт, названный PlayTool, который имеет большую полезную информацию о том, как диагностировать возможные проблемы с видеокартой. Я также добавил бы, что, если бы у Вас была полностью поврежденная палка RAM, тогда Вы, вероятно, не получили бы отображения на экране вообще, даже экран-заставка BIOS. – Hemang Aghera 16.04.2020, 14:44
  • 2
    таким образом, если я заменяю 13.04 12.04 LTS, делают я все еще выполняю " склонный - получают upgrade"? я только перешел в 13,04 в надеждах, что Ubuntu решит мою проблему драйвера прежней версии.... – Mustafizur Rahman 16.04.2020, 14:44
  • 3
    Я сделал вышеупомянутое, перезапущенное несколько раз теперь, все еще никакой дисплей. Я знаю, что дисплей работает; я могу вызвать BIOS и получить дисплей - иногда. Когда я использую вспомогательный дисплей и использую " displays" утилита в GUI, это кажется Ubuntu, не обнаруживает созданный в дисплее. Драйвер Прежней версии действительно делал одну вещь - вспомогательный дисплей теперь говорит " отформатируйте не supported" когда рабочий стол запускается. Страница-заставка все еще подходит, хотя, таким образом, все я могу сделать, alt+control+F4, и используйте командную строку. Я действительно хотел бы разрешить это, поскольку ноутбук является большой единицей, и вплоть до 11,04 Ubuntu был лучший O/S I' ve используется. – Mustafizur Rahman 16.04.2020, 14:45
  • 4
    Да, необходимо все еще работать sudo apt-get upgrade и эта команда won' t обновляют Ваше распределение Ubuntu до следующей версии. apt-get upgrade используется для установки новейших версий всех пакетов, в настоящее время устанавливаемых в системе из источников, перечисленных в /etc/apt/sources.list. Пакеты, в настоящее время устанавливаемые с новыми доступными версиями, получены и обновлены; ни при каких обстоятельствах не в настоящее время устанавливаемые пакеты, удаленные или пакеты, не уже установленные полученный и установленный. – Enrique Gil 16.04.2020, 14:45
  • 5
    BTW, прежде чем я сделал fglrx материал прежней версии, который я удалил 13.04 и переустановил 12.04... – Enrique Gil 16.04.2020, 14:46

Теги

Похожие вопросы