Все расширения Chromium выбрасывают ошибки с момента обновления до 13.10 [закрыто]

После обновления до 13.10 все расширения хрома генерируют ошибки:

chrome.extension is not available: 'extension' is not allowed for specified context type content script,  extension page, web page, etc.). [VM] binding (56):427
Uncaught TypeError: Cannot call method 'sendRequest' of undefined include.preload.js:105
Uncaught TypeError: Cannot read property 'onRequest' of undefined include.postload.js:473
GET http://edge.quantserve.com/quant.js  superuser.com/:2047
GET http://www.google-analytics.com/__utm.gif?utmwv=5.4.5&utms=2&utmn=590704726…n%3D(organic)%7Cutmcmd%3Dorganic%7Cutmctr%3D(not%2520provided)%3B&utmu=qQ~  ga.js:61

chrome.extension is not available: 'extension' is not allowed for specified context type  content script,  extension page, web page, etc.). [VM] binding (56):427
Uncaught TypeError: Cannot read property 'onRequest' of undefined content.js:233
chrome.extension is not available: 'extension' is not allowed for specified context type         content script,  extension page, web page, etc.). [VM] binding (56):427
Uncaught TypeError: Cannot read property 'onRequest' of undefined injected.js:169
chrome.extension is not available: 'extension' is not allowed for specified context type content script,  extension page, web page, etc.). [VM] binding (56):427
Uncaught TypeError: Cannot call method 'getURL' of undefined content_js_min.js:5
GET http://engine.adzerk.net/z/8476/adzerk2_2_17_47  superuser.com/:1719
Uncaught TypeError: Cannot call method 'sendRequest' of undefined 

Как это исправить?

15
задан 16.04.2020, 15:01

7 ответов

Обновление до ubuntu 13.10 также обновило Chromium до 29.0.1547.65-0ubuntu2, сломав ВСЕ мои плагины Chromium.

Используя synaptic, выполните «полное удаление» «chromium-browser», которое также удаляет «chromium-codecs-ffmpeg-extra». Переустановите предыдущую стабильную версию Chromium 28 для Ubuntu 13.04 (chromium-browser_28.0.1500.71-0ubuntu1.13.04.1_amd64.deb). Более ранние версии Chromium можно найти по адресу http://www.ubuntuupdates.org/pm/google-chrome-stable . Загрузите соответствующий файл CHROMIUM '.deb', щелкните правой кнопкой мыши, чтобы открыть его с помощью Ubuntu Software Center, и установите.

Все мои плагины / дополнения (Adblock Plus 1.6.1, AutoCopy 1.4.1, LastPass 2.5.5, Omnibox Timer 0.3.1) снова работают, КРОМЕ «Cool Clock» (версия 3.0.1.2).

9
ответ дан 16.04.2020, 15:02
  • 1
    Это работает, за исключением того, что, когда я пытаюсь открыть Gmail теперь, он отказывает, и я получаю " Ай, защелка! " экран. У кого-либо еще есть эта проблема? – PatrickT 16.04.2020, 15:03
  • 2
    @duxk.gh, Люди, которые используют хром don' t хотят использовать хром. They' более обеспеченный Firefox использования ре, поскольку это - открытый исходный код. Делает любой знает если they' ре, работающее над устранением этой проблемы? – David Arenburg 16.04.2020, 15:03
  • 3
    Нет. Я переключился на Firefox на данный момент, и имейте Хром 29 установленных. I' ll проверяют время от времени, чтобы видеть, работают ли расширения в Хроме снова. На данный момент Firefox в порядке... – jangorecki 16.04.2020, 15:04
  • 4
    @duxk.gh Да, расширения работают на меня теперь, но Gmail doesn' t. Удача, понимая его уже? – Claud H 16.04.2020, 15:04
  • 5
    @MatthewAdams я начал использовать Chrome 30 вместо этого. Расширения работают и больше катастрофических отказов; см. мой ответ ниже. – ROMANIA_engineer 16.04.2020, 15:04

К вашему сведению: эта проблема исправлена ​​сегодня с последним официальным обновлением Chromium (версия 30) для Ubuntu 13.10.

2
ответ дан 16.04.2020, 15:03

Я перешел на использование порта Chromium SWIron, http://www.srware.net/en/software_srware_iron.php для Ubuntu, и там все работает нормально (версия SWIron для Chromium такая же, как сломанный в последней Ubuntu).

0
ответ дан 16.04.2020, 15:03

В последней версии этого ppa исправлены ошибки

https://launchpad.net/~saiarcot895/+archive/chromium-beta

Версия 31.0.1650.39 Ubuntu 13.10 (231674)

0
ответ дан 16.04.2020, 15:04

Для меня переход на Chromium 28, , как предложил Джон Литтлтон , привел к краху Gmail и других сайтов Google.

Вместо этого я начал использовать Chrome 30; все мои расширения работают, и я не испытываю внезапных сбоев. Для установки Chrome вы можете добавить PPA и установить следующим образом:

Ключ установки:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Хранилище настроек:

sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

Пакет установки:

[ 112]

где <package name> - имя пакета, который вы хотите установить. Я выбрал google-chrome-stable, но есть также google-chrome-unstable и google-chrome-beta.

Источник (UbuntuUpdates.org)

1
ответ дан 16.04.2020, 15:05
  • 1
    Никакая потребность сделать что-либо вручную - просто загружает пакет и двойной щелчок!: google.com/intl/en/chrome/browser . Репозитории Chrome будут добавлены автоматически. Но я лично просто собирающийся ожидать, пока они не фиксируют этот восходящий поток. – AechoLiu 16.04.2020, 15:05
  • 2
    Обновление является решением, но код, который Вы обеспечили, не работает (устаревшие ссылки) – Adromil Balais 16.04.2020, 15:05

Я только что обновил браузер Chromium до версии 30 (30.0.1599.114-0ubuntu0.13.10.2) и все проблемы исчезли. Самый простой способ обновить браузер Chromium до версии 30 - это использовать PPA для Ubuntu Mozilla Security Team :

sudo add-apt-repository ppa:ubuntu-mozilla-security/ppa 
sudo apt-get update && sudo apt-get upgrade

Вот и все, теперь вы можете протестировать обновленный браузер - проблемы с расширениями хрома должны исчезнуть.

5
ответ дан 16.04.2020, 15:05
  • 1
    Я полагаю, что это является самым легким и лучшее решение. Вы don' t должны удалить что-либо, Вы don' t должны понизить что-либо, Вы получаете более свежую версию, и Вы избавляетесь от ошибок. Спасибо Radu, я получил все работа! – B Misra 16.04.2020, 15:06

Проблема возникает в Chrome v. 29

Решение заключается в обновлении до более новой версии, например. 30 (или понизьте до 28, если хотите)

Чтобы проверить версию, введите в строке URL: chrome://version

Во-первых, вам нужно удалить текущую версию ( ваш данные профиля останутся нетронутыми ):

sudo apt-get remove chromium-browser

Затем установите новую версию. Вы можете скачать установочный пакет здесь: http://www.ubuntuupdates.org/package/ubuntu_mozilla_security/saucy/main/base/chromium-browser

(выберите версию для своего дистрибутива и архитектура)

После того, как у меня была ссылка на установщик, я установил пакет для x64 Saucy через терминал:

wget http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu/pool/main/c/chromium-browser/chromium-browser_30.0.1599.114-0ubuntu0.13.10.2_amd64.deb
sudo dpkg -i chromium-browser_30.0.1599.114-0ubuntu0.13.10.2_amd64.deb 
rm chromium-browser_30.0.1599.114-0ubuntu0.13.10.2_amd64.deb 
2
ответ дан 16.04.2020, 15:06

Теги

Похожие вопросы