Как получить забвение, чтобы остановить сбой?

Я использую Ubuntu Distribution 12.04 и пытаюсь запустить Oblivion, я использовал playonlinux для установки его на виртуальный диск вместе с использованием wine.

Я думаю, что проблема в том, что у меня глючит видеокарта или что-то, что я довольно новичок в Linux, просто перенес из Windows. Вот сообщение об ошибке от playonlinux, я верю.

Когда я запускаю его на playonlinux, в нем отображается меню с кнопками «Воспроизведение, Файлы данных, Опции, Elderscrolls.com, Техническая поддержка, Удаление и Выход».

[10/19/13 14:58:38] - Running wine-1.7.4 OblivionLauncher.exe (Working directory : /home/tyler/.PlayOnLinux/wineprefix/TheElderScrolls4_Oblivion/drive_c/Program Files/Bethesda Softworks/Oblivion)
wine: configuration in '/home/tyler/.PlayOnLinux//wineprefix/TheElderScrolls4_Oblivion' has been updated.
[10/19/13 14:59:02] - Running wine-1.7.4 regedit (Working directory : /home/tyler/.PlayOnLinux)
[10/19/13 14:59:02] - User modified something in the registry manually
[10/19/13 15:02:24] - Running wine-1.7.4 OblivionLauncher.exe (Working directory : /home/tyler/.PlayOnLinux/wineprefix/TheElderScrolls4_Oblivion/drive_c/Program Files/Bethesda Softworks/Oblivion)
[10/19/13 15:18:56] - Running wine-1.7.4 OblivionLauncher.exe (Working directory : /home/tyler/.PlayOnLinux/wineprefix/TheElderScrolls4_Oblivion/drive_c/Program Files/Bethesda Softworks/Oblivion)
[10/19/13 15:19:15] - Running wine-1.7.4 OblivionLauncher.exe (Working directory : /home/tyler/.PlayOnLinux/wineprefix/TheElderScrolls4_Oblivion/drive_c/Program Files/Bethesda Softworks/Oblivion)
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:d3d:wined3d_guess_card No card selector available for card vendor 0000 (using GL_RENDERER "Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)").
fixme:win:EnumDisplayDevicesW ((null),0,0x32f328,0x00000000), stub!
fixme:d3d:wined3d_guess_card No card selector available for card vendor 0000 (using GL_RENDERER "Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)").
fixme:win:EnumDisplayDevicesW ((null),0,0x33ef28,0x00000000), stub!
fixme:d3d:wined3d_guess_card No card selector available for card vendor 0000 (using GL_RENDERER "Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)").
fixme:win:EnumDisplayDevicesW ((null),0,0x33eef8,0x00000000), stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:state_zenable Z buffer disabled, but ARB_depth_clamp isn't supported.
1
задан 17.04.2020, 01:20

1 ответ

Попробуйте запустить

export LD_LIBRARY_PATH=/usr/lib32:$LD_LIBRARY_PATH

Если вы используете 64-битную Ubuntu, она сначала ищет 64 библиотеки, а затем завершается сбоем и закрывается. Это проинструктирует его сначала искать библиотеку 32. Вот как я решил проблему с Цивилизацией 4.

0
ответ дан 17.04.2020, 01:21

Теги

Похожие вопросы