Не удается установить Ubuntu Software Center

Я использую Ubuntu 13.10 32bit с Gnome 3.8, но мне не хватает Ubuntu Software Center . Я пытался установить его через терминал:

$ sudo apt-get install software-center

Но это говорит мне, что зависимости не соблюдаются

The following packages have unmet dependencies:
    software-center : Depends: gir1.2-webkit-3.0 but it is not going to be installed

gir1.2-webkit-3.0 зависит от gir1.2-javascriptcoregtk-3.0 версии 1.10.2-0ubuntu2. Но этот пакет доступен только как версия 2.0.4-2~ubuntu13.04.

Мне не хватает Ubuntu Software Center , а также Менеджера обновлений и пакетов update-notifyer и ubuntu-release-upgrader-gtk.

Как установить пакеты с правильными зависимостями?


Редактировать:

Вывод apt-cache policy gir1.2-javascriptcoregtk-3.0:

gir1.2-javascriptcoregtk-3.0:
  Installed: 2.0.4-2~ubuntu13.04.1
  Candidate: 2.0.4-2~ubuntu13.04.1
  Version table:
 *** 2.0.4-2~ubuntu13.04.1 0
    100 /var/lib/dpkg/status
     1.10.2-0ubuntu2 0
    500 http://de.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages

My sources.list:

deb http://de.archive.ubuntu.com/ubuntu/ saucy main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ saucy-security main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ saucy-updates main restricted universe multiverse
deb http://archive.canonical.com/ubuntu saucy partner
deb http://extras.ubuntu.com/ubuntu saucy main

# spotify
deb http://repository.spotify.com stable non-free

Spotify Я добавил себя.

3
задан 17.04.2020, 04:28

2 ответа

Выходные данные apt-get policy сообщают вам, что gir1.2-javascriptcoregtk-3.0 установлен локально и не поступает из PPA:

gir1.2-javascriptcoregtk-3.0:
...
Version table:
*** 2.0.4-2~ubuntu13.04.1 0
    100 /var/lib/dpkg/status

Это означает, что ваша система не имеет доступа ко всему набору пакетов. предложенный Гномом 3 PPA. Это может привести ко многим проблемам, включая проблемы с зависимостями.

Повторно добавьте PPA с помощью этой команды:

sudo add-apt-repository ppa:gnome3-team/gnome3

Затем обновите и обновите свою систему.

0
ответ дан 17.04.2020, 04:29
  • 1
    на самом деле. Проблема зависимостей была устранена. Но к сожалению центр программного обеспечения продолжает отказывать. I' ll создают новую проблему для этого. – Blastfurnace 17.04.2020, 04:29

ПЕРВЫЙ: запустить sudo apt-get update.
ВТОРОЕ: самое быстрое решение - установить aptitude с sudo apt-get install aptitude и запустить его: он найдет конфликт и предложит решение, если нажать «!» (посмотрите на красную горизонтальную линию внизу интерфейса консоли aptitude).
Выберите решение (любое решение, которое не не удаляет большое число или пакеты, или ядро ​​должно быть в порядке), нажмите G, чтобы применить его.
После этого выйдите из aptitude и запустите sudo apt-get dist-upgrade, чтобы сделать хорошее обновление и перепроверить проблемы.
Не удаляйте ядро ​​или заголовки ядра (смотрите описание пакетов "linux").
ТРЕТЬЕ: После перезагрузки (излишне, но ...) попробуйте установить Ubuntu Software Center.
Надеюсь, вы решите. (стрелка вверх, если вы решите, прокомментируйте здесь, чтобы задать больше вопросов по теме)

0
ответ дан 17.04.2020, 04:29
  • 1
    byf-ferdy: Синаптический не зафиксирует Ваши зависимости, aptitude (работайте, это от консоли) будет, потому что это может предложить Вам разнообразный выбор. Прежде, чем сделать что-либо работает sudo apt-get update для обновления способных списков пакета. Голосуйте, если этот ответ полезен. – DrHell 17.04.2020, 04:30
  • 2
    почему это было провалено? есть ли что-нибудь, что я должен иметь в виду, что это не было упомянуто здесь? – Mats Petersson 17.04.2020, 04:30
  • 3
    Я попробовал его, но Синаптический не может зафиксировать мои поврежденные зависимости. – Hao 17.04.2020, 04:31

Теги

Похожие вопросы