Программное обеспечение и усилитель обновления не открываются в Ubuntu 13.10 [дубликаты]

Есть больше различий между apt и apt-get, чем необычной шкалой прогресса, поэтому вы можете захотеть отключить это , сохраняя все остальные различия:

]

sudo apt -o Dpkg::Progress-Fancy=0 action args...

Некоторые источники показывают Dpkg::Progress-Fancy="0", что хорошо, но эквивалентно Dpkg::Progress-Fancy=0, поскольку оболочки все равно не расширяются 0 и кавычки просто удаляются .

Вы, вероятно, не хотите изменять эту настройку глобально, потому что, когда вы запускаете apt вне Emacs, вам, вероятно, понадобится необычная шкала прогресса. Однако вы можете сделать более короткую команду, которая достигает той же цели, например, с псевдонимом eshell .

1
задан 17.04.2020, 16:33

1 ответ

У меня была такая же проблема. Просто измените информацию lsr-release, выполнив следующие действия:

  1. Перейдите в терминал и введите следующее:

    gksudo gedit /etc/lsb-release
    
  2. Отредактируйте файл, так что вы получите следующее:

    DISTRIB_ID=Ubuntu
    
    DISTRIB_RELEASE=13.10
    
    DISTRIB_CODENAME=saucy
    
    DISTRIB_DESCRIPTION="Ubuntu Saucy Salamander"
    

Примечание. Это решение оптимизировано из следующего ответа Apt "не удалось найти шаблон распространения" Ошибка

0
ответ дан 17.04.2020, 16:33

Теги

Похожие вопросы