& ldquo; sudo update-grub & rdquo; не работает

Когда я запускаю

sudo update-grub

, я получаю следующую ошибку:

/usr/sbin/grub-mkconfig: 1: /etc/default/grub: #: not found

Это мое /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0 GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` 
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="splash quiet"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
4
задан 17.04.2020, 06:46

3 ответа

Попробуйте отредактировать файл, используя gksudo gedit /etc/default/grub.

В вашем файле измените строку

GRUB_DEFAULT=0 GRUB_HIDDEN_TIMEOUT=0

на

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0

То есть в каждой строке должен быть только один параметр. Кроме того, в закомментированной строке вставка пробела после #, где это не так, была бы хорошей идеей.

0
ответ дан 17.04.2020, 06:46

Это случилось со мной, когда я отредактировал файл с помощью OpenOffice Writer, а не pluma / gedit. Я предполагаю, что он добавил какие-то странные символы юникода.
Я исправил это с помощью

sudo cp /usr/share/grub/default/grub /etc/default/grub
0
ответ дан 17.04.2020, 06:46
  • 1
    Я искал решение как это в течение многих часов.Спасибо. – Siva 17.04.2020, 06:47

Одна из проблем была в этом блоке:

GRUB_DEFAULT=0  #Add newline here
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5 #Add newline here too
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` 
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="splash quiet"

Должна быть одна переменная на строку в файле.

Однако могут быть и другие проблемы, поскольку сообщение об ошибке говорит о чем-то совершенно другом. Попробуйте, а затем обновите свой вопрос.

0
ответ дан 17.04.2020, 06:47

Теги

Похожие вопросы