Ubuntu 12.04 не может установить беспроводное соединение

Похоже, что вы добавили это в конец файла .bashrc в вашем домашнем каталоге:

export PS1="\033[0;33m\h:\W \u\$ \e[m"

Вы должны использовать это вместо:

export PS1="\[\033[0;33m\]\h:\W \u\$ \[\e[m\]"

То есть , окружающие escape-последовательности, которые сообщают терминалу, как отображать текст (в данном случае, выполняющий раскрашивание) с помощью \[ и \]. Это сообщает оболочке Bash, что они не должны учитываться , когда определено количество видимых символов, которые вы ввели. (См. Также этот вопрос и этот .)

Между прочим, редко бывает полезно экспортировать PS1. Каждая недавно запущенная интерактивная оболочка Bash, которая должна использовать вашу подсказку, будет читать из .bashrc и устанавливать подсказку для себя. Поэтому я рекомендую опустить export и просто использовать эту строку:

PS1="\[\033[0;33m\]\h:\W \u\$ \[\e[m\]"

Хотя это была единственная часть вашего .bashrc, где я заметил проблему, вы можете сравнить файл с «оригинал»:

diff /etc/skel/.bashrc ~/.bashrc

, который показывает изменения по сравнению с файлом .bashrc, который будет создан для нового пользователя в вашей системе. Обычно отображает только ваши собственные изменения, но иногда /etc/skel/.bashrc меняется между выпусками Ubuntu, поэтому, если ваша учетная запись пользователя была создана до обновления, тогда могут быть другие изменения. Обратите внимание, что не все, что это показывает, является ошибкой! Но это те части, которые я рекомендую вам проверить.

(Вы можете включить вывод этой команды diff в свой вопрос, если не уверены, как ее интерпретировать, или если конкретная измененная строка содержит что-то, что должно быть написано по-другому.)

Наконец , хотя я подозреваю, что это полностью решит вашу проблему, я должен отметить, что обычно поведение, когда вы нажимаете Enter kbd>, фактически не затрагивается этим . Чаще всего, пропуски \[ и \] просто приводят к тому, что оболочка не может обернуть ваши строки, так что если вы наберете что-то длиннее ширины терминала, он вернется к началу та же строка.

0
задан 17.04.2020, 11:57

1 ответ

Пожалуйста, включите это в вашем маршрутизаторе:

отключение HT, поскольку WMM / QoS не поддерживается AP

Затем копируйте и вставляйте по одной строке за раз :

echo "options rt2800pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800pci.conf
sudo modprobe -rfv rt2800pci
sudo modprobe -v rt2800pci
0
ответ дан 17.04.2020, 11:58
  • 1
    Вы имеете в виду модем ADSL? – Gordon Linoff 17.04.2020, 11:58
  • 2
    Вы знаете, как войти в Вашу конфигурацию маршрутизаторов? или Вы владеете маршрутизатором? – rickandmorty 17.04.2020, 11:59
  • 3
    Я выполнил команды прежде и после включения " QoS" и я все еще не могу соединить Wi-Fi. И теперь я не вижу беспроводных сетей или чего-либо названного " wireless". беспроводная опция ноутбука исчезается. – Michał Turczyn 17.04.2020, 11:59
  • 4
    Хорошо, как я могу включить это? Я буквально не знаю то, что это означает... – Adhiraj Jaryal 17.04.2020, 11:59
  • 5
    Если это - также Ваш маршрутизатор, Вы просто входите в него, тогда находят выпадающее меню, в котором говорится WWw/QoS, и включите его. Но идите вперед и выполните другие команды сначала и посмотрите, помогает ли это. – xnetxuserx 17.04.2020, 12:00

Теги

Похожие вопросы