порочный круг между & ldquo; sudo dpkg - перенастроить -a & rdquo; и & ldquo; паника ядра & rdquo;

Я использую Ubuntu 13.04, сегодня я запускаю диспетчер программного обеспечения, в нем было около 250 МБ, включая новое ядро ​​3.8.0-32, и во время их установки произошла паника ядра, я выключил свой ноутбук при нажатии кнопки питания. Затем я перезапустил его, он успешно загрузил сессию, но когда я открываю synaptic, я получаю:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

, когда я запускаю его, снова возникает паника ядра, это происходит во время настройки «libc» или чего-то в этом роде. Пожалуйста, помогите !!!

Редактировать:

uname -r дает мне еще 3.8.0-31 версию ядра.

Edit2:

Это, очевидно, проблема конфигурации libc, так что теперь, как я могу вернуть ее к предыдущей версии? Связанные пакеты в кеше:

libc6_2.17-0ubuntu5.1_i386.deb, libc6-dev_2.17-0ubuntu5.1_i386.deb, libc-dev-bin_2.17-0ubuntu5.1_i386.deb, linux-libc-dev_3.8.0-32.47_i386.deb

Можно ли понизить их, получив ошибку sudo dpkg --configure -a?

Edit3:

Я запускаю [ 1115]

sudo dpkg-reconfigure linux-image-3.8.0-31-generic

Он может настроить предыдущее ядро, так что это не проблема обновления ядра.

1
задан 17.04.2020, 13:42

1 ответ

OMG! Я исправил это наконец. Я скачал вышеуказанные пакеты из пакетов ubuntu

, а затем установил их один за другим с помощью «sudo dpkg -i * .deb», и все они были успешно установлены. Уф!

0
ответ дан 17.04.2020, 13:43
  • 1
    Зафиксируйте свою ссылку, это не было найдено. – Matt Thomas 17.04.2020, 13:43
  • 2
    Ваш критерий поиска Google возвратил пустой список. – riv 17.04.2020, 13:44
  • 3
    На самом деле я нашел их как site:http://packages.ubuntu.com/raring/i386 libc6_2.17-0ubuntu5.1_i386.deb в Google – Matt Thomas 17.04.2020, 13:44
  • 4
    извините я сделал опечатки второпях site:packages.ubuntu.com libc6_2.17-0ubuntu5_i386.deb, я помню, что удалил ".1" в номерах версий, потому что предыдущие номера версий содержат "-0ubuntu5_" not"-0ubuntu5.1_" но необходимо установить тех, которые содержат "-0ubuntu5.1_" – Eric 17.04.2020, 13:44

Теги

Похожие вопросы