Шмель optirun, кажется, зависит от Intel

У меня Lenovo T420 с графикой Intel и Nvidia. При обновлении до Ubuntu Saucy мне пришлось очистить и переустановить bumblebee-nvidia, чтобы выйти за рамки optirun, не найдя драйвер графического процессора. Теперь «optirun glxgears» и «optirun sol» успешно выполняются, но optirun завершается ошибкой в ​​2 средствах просмотра Virtual Life, которые он поддерживал в прошлом, Cool VL (CoolVLViewer-1.26.8.34-Linux-x86) и Imprudence (Imprudence 1.4.0 beta2) , В обоих случаях вывод ошибки огромен, но начинается с

libGL error: не удалось загрузить драйвер: i965

и

[ 114] Ошибка libGL: не удалось загрузить драйвер: swrast

Из всего, что я могу обнаружить, i965 - это графический драйвер Intel, который вообще не должен вызываться. Я не нашел никакой информации о Swrast. Я подозреваю, что некоторые конфигурации X, связанные с Bumblebee, имеют некоторую зависимость от Intel, которая вызывается при определенных вызовах библиотеки, но не при других. Я не обнаружил какой-либо определенной информации в этой строке.

Cool VL Viewer работает без optirun, но жалуется на недостаточную графику Intel.

0
задан 17.04.2020, 17:49

1 ответ

У меня похожая проблема, и после запуска я получил ошибку swrast:

apt-get install libgl1-mesa-swx11

Теперь optirun glxinfo работает нормально.

0
ответ дан 17.04.2020, 17:49

Теги

Похожие вопросы