Беспроводной Интернет в ноутбуке HP 655 (Ubuntu 12.04) отключен после запуска обновлений

Сегодня менеджер обновлений предложил мне загрузить некоторые обновления. Так я и сделал. После установки обновлений мне пришлось перезагрузить систему.

После перезагрузки ноутбук не видит беспроводных сетей.

Я долго искал ответы в Интернете, но ни один из них не относится к моему делу.

У меня есть идея, это связано с тем ядром, которое я сейчас использую (Linux 3.2.0-55). Это новое для Ubuntu 12.04?

Когда я загружаю свою систему, я могу выбрать более старое ядро ​​(linux 3.2.0-32). Когда я использую это, ноутбук видит беспроводные сети.

Это моя сетевая карта в соответствии с командой lspci: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe

У кого-нибудь есть идея исправить мои проблемы с беспроводным интернетом?

2
задан 17.04.2020, 20:53

2 ответа

Хорошо, у меня была такая же проблема некоторое время назад. Я заблокировал ядро ​​от синапсов, как объяснил Дикий Человек. Но затем я решил свою проблему правильной установки драйверов, следуя этому уроку Луиса Альварадо в Askubuntu ♦

Как заставить работать беспроводную карту Ralink RT3290?

Надеюсь, что это поможет!

0
ответ дан 17.04.2020, 20:54

Ваше устройство поддерживается ядром, которое поставлялось вместе с вашим компьютером, поэтому оно было настроено на работу от производителя, поэтому при обновлении системы, включающем обновление ядра, ваша беспроводная сеть перестает работать.

Вы можете зайти в менеджер пакетов synaptic и выбрать блокировку ядра, чтобы при обновлении вы не получали обновлений ядра или могли установить 13.04, которая поддерживает ваше устройство по умолчанию.

Возможно, вам придется установить synaptic, он больше не устанавливается по умолчанию.

Также вы можете сделать:

sudo modprobe -v rt2800pci 

посмотреть, если это включит его, но я думаю, что с обновлением он больше не будет работать.

Если вы хотите установить управление пакетами synaptic, выполните:

sudo apt-get install synaptic

, затем откройте synaptic> введите версию ядра, которую вы хотите заблокировать, в окне фильтра в верхней части synaptic> щелкните по этой версии ядра > затем нажмите на пакет в верхней части окна> затем заблокируйте версию. Теперь, когда вы обновляете, это не должно нарушать вашу беспроводную связь.

Редактировать: Добавлены скриншоты. synaptic lock kernel

1
ответ дан 17.04.2020, 20:55
  • 1
    Я думаю, что это будет работать, если это действительно примет ответ, таким образом, это принесет пользу всем. – Mike 17.04.2020, 20:55
  • 2
    Удостоверьтесь, что это - то, которое Вы блокируете 3.2.0-32. – Vikram Bodicherla 17.04.2020, 20:56
  • 3
    Вы были правы относительно sudo modprobe-v rt2800pci, который не работает. Еще один вопрос, я должен сохранить 12.04 LTS или переключиться на 13,04? Или к 13,10? – Raf 17.04.2020, 20:56
  • 4
    На именно это это должно быть похожим после того, как это заблокировано, если бы это делает тогда, я выполнил бы обновление. – Guykun 17.04.2020, 20:57
  • 5
    Мне нравится 12.04, потому что это стабильно и поддерживается в течение 5 лет, но я не использовал 13.04, и 13.10 просто вышел, требуется больше времени для становления стабильным, но это только поддерживается в течение шести месяцев, которым я верю. – JustCurious 17.04.2020, 20:57

Теги

Похожие вопросы