Как я могу заставить Apache SSL работать в 13.10 после обновления?

Я только что обновился до 13.10 с 13.04, и моя конфигурация Apache не загружается. Я получаю эту ошибку:

AH00526 Syntax error on line 43 of /etc/apache2/mods-enabled/ssl.conf:
SSLSessionCache: 'shmcb' session cache not supported (known names: ) Maybe you
need to load the appropriate socache module (mod_socache_shmcb?).
Action 'configtest' failed.

Я не могу найти пакет для него, и кажется, что он был предоставлен пакетом apache2-bin . Кажется, я не могу найти mod_socache_shmcb в моей системе нигде. Я использую apache2-2.4.6-2ubuntu на amd64. Как я могу заставить SSL работать снова для нескольких виртуальных хостов?

Модуль shmcb socache, кажется, находится там еще в 2.4 согласно документам .

2
задан 18.04.2020, 03:43

2 ответа

Включите модуль, скопировав файл:

cp /etc/apache2/mods-available/socache_shmcb.load /etc/apache2/mods-enabled/

Это обработает первую ошибку.

Затем возникает ошибка, связанная с SSLMutex, поэтому замените эту строку с поддержкой модов / ssl.load на этой инструкцией :

Mutex sysvsem default
4
ответ дан 18.04.2020, 03:44
  • 1
    I' ve, так как изучено a2enmod для включения модулей но это не всегда доступно. – Martijn Courteaux 18.04.2020, 03:44

Лучший способ включить и отключить модули Apache в Ubuntu - использовать команды a2enmod и a2dismod. В этом случае:

sudo a2enmod socache_shmcb
sudo service apache2 restart
3
ответ дан 18.04.2020, 03:44

Теги

Похожие вопросы