Курсор мыши исчезает при каждой второй загрузке Ubuntu 13.10 [закрыто]

Ваша программа на C ++ не работает в Code :: Blocks, потому что у вас не установлен компилятор C ++ (версия G ++) или, если он установлен, вы не настроили компилятор C ++ в настройках компилятора Code :: Blocks , Компилятор C ++ по умолчанию не настроен для любой версии g ++ в Ubuntu 18.04, поэтому его необходимо настроить в настройках компилятора Code :: Blocks.

  1. Установите последнюю версию компилятора g ++ для C ++.

    sudo apt install g++-8 xterm 
    

    При желании также установите последнюю версию gcc (рекомендуется).

    sudo apt install gcc-8-base # recommended version 
    
  2. Начальный код :: Блоки.

  3. Выберите Настройки -> Компилятор -> Глобальные настройки компилятора (большой синий значок шестеренки на левой панели) -> [ 1113] Панель инструментов исполняемых файлов , вкладка.
  4. Выберите вкладку Program Files . Это уже было выбрано на скриншоте ниже.
  5. Нажмите кнопку .. kbd> , которые отмечены курсором мыши на снимке экрана ниже. Перейдите к /usr/bin. Компилятор C должен быть либо gcc, либо опционально gcc-8, компилятор C ++ должен быть g++-8, а компоновщик для динамических библиотек должен быть [ 116]. [+1123]
  6. Нажмите кнопку & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; kbd> , чтобы закрыть окно настроек компилятора .
  7. ]

enter image description here

16
задан 06.05.2020, 00:39

3 ответа

настройки - дисплеи - отключить неизвестный дисплей. это работает для меня

0
ответ дан 06.05.2020, 00:39
  • 1
    это работало на меня красиво (don' t забывают нажимать на " Apply" после отключения дисплея, вместо того, чтобы просто закрыть диалоговое окно) – Abinash Patra 06.05.2020, 00:40
  • 2
    Эта опция существует в 14,04? I' m рассмотрение диалогового окна Дисплеев, но не вижу способа отключить неизвестные дисплеи. – Neewbie 06.05.2020, 00:40

Вы можете проверить эту ошибку

https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1238410

Меня больше не затрагивает новая установка 14.04 dev, но на моей установке 13.10 за 2 недели до релиза это все еще может произойти

Для установки 13.10 отключение плагина gnome-settings-daemon cursor имеет доказал свою эффективность. Чтобы попытаться, в терминале

gsettings set org.gnome.settings-daemon.plugins.cursor active false

Для повторного включения просто запустите ту же команду, но используйте true вместо false

0
ответ дан 06.05.2020, 00:40
  • 1
    Спасибо doug, я перезапустил свою систему пару раз теперь и курсор, было видимо все времена на данный момент. На данный момент все, что я могу сказать, - то, что это решение работает на меня.Спасибо! – Usman 06.05.2020, 00:40
  • 2
    I' m затронутый этим в Ubuntu 14.04 и этом обходном решении didn' t работают на меня:-( – Zhenhir 06.05.2020, 00:41

У меня эта проблема возникает случайно в Ubuntu Gnome 15.04 (иногда во время загрузки, иногда, когда система работает): курсор мыши не появляется, но мышь все еще можно использовать. Один способ заставить его появиться снова, который работал для меня, состоит в том, чтобы изменить разрешение назад и вперед. Вроде сложно, не видя мышки, но у меня есть сенсорный экран, так что это немного проще.

0
ответ дан 06.05.2020, 00:41
  • 1
    У меня просто была проблема на 15,10 на двух компьютерах за один раз, перезагрузка починила один компьютер, и на другом я просто перезапустил X11 пару раз и вернул мышь... – MoxxiManagarm 06.05.2020, 00:41

Теги

Похожие вопросы