Невозможно найти пакет libmysql ++ - dev

Просто чтобы повторить то, что @skytreader ранее прокомментировал, rmvirtualenv - это команда, предоставленная virtualenvwrapper, а не virtualenv. Может быть, у вас не установлено virtualenvwrapper?

См. Справочник команд VirtualEnvWrapper для получения более подробной информации.

1
задан 05.05.2020, 01:35

2 ответа

Пакет libmysql++-dev входит в состав репозитория юниверса . Я предполагаю, что он не найден, потому что Universe не включен в вашей системе. Поэтому включите репозиторий юниверсов , и вы сможете установить его.

В общем, когда пакет не устанавливается, даже если кажется, что вы все делаете правильно, полезно убедиться, что он действительно доступен для версии Ubuntu, которую вы используете, и какой репозиторий его предоставляет. , Для этого вы можете выполнить поиск пакета по адресу http://packages.ubuntu.com/ .

Возможно, это не причина проблемы, конечно. В этом случае я рекомендую дополнить ваш вопрос информацией о том, что вы видели, когда проверяли, была ли включена вселенная, а также информацией, запрошенной GabrielF .

0
ответ дан 05.05.2020, 01:35
  • 1
    @Seth я испытывал желание делать его CW.:)... На самом деле причина состоит в том, что, когда я начал писать его, казалось, что это много было похоже на " возможный duplicate" комментарий, просто более подходящий как ответ. Это было бы прекрасно как обычное, сообщение неCW, но я didn' t чувствуют любую потребность снять флажок. Если я закончил тем, что развернул его с большим количеством подзаголовков и команд оболочки и снимков экрана с нарисованными от руки кругами, я would' ve идется вперед и сделанный им неCW. Конечно, как сообщение CW, люди должны не стесняться рассматривать его как любая другая CW и быть еще более готовыми чем обычно отредактировать его для улучшения..., если они желают. – quentin mayer 05.05.2020, 01:36
  • 2
    Почему эта CW? – Quentin C 05.05.2020, 01:36
  1. Прежде всего, запустите apt-get update. Если вы получили какие-либо ошибки, отредактируйте свой пост и включите вывод. Если вы не получили ошибок, попробуйте установить пакет снова.

  2. Если это не сработает, проверьте, включены ли репозитории юниверсов: откройте центр программного обеспечения и поместите курсор мыши в верхней части рабочего стола. В появившемся меню выберите «Правка» >> «Программные источники». На первой вкладке (Ubuntu Software) проверьте, включен ли юниверс. Если это не так, включите его и снова запустите apt-get update и попробуйте снова установить пакет.

  3. Если это тоже не сработает, вам стоит попробовать другое зеркало. Следуйте инструкциям в разделе 2 и измените поле со списком «Загрузить с». Вы можете увидеть список зеркал с информацией о том, как он обновлен, здесь: https://launchpad.net/ubuntu/+archivemirrors . Это должно помочь вам выбрать один. Не забудьте выбрать тот, который находится рядом с вами.

Если ничего из этого не работает, отредактируйте свой пост, включая содержание вашего /etc/apt/sources.list.

0
ответ дан 05.05.2020, 01:36

Теги

Похожие вопросы