Будут ли в версиях LTS старые двоичные файлы и библиотеки после его окончания?

Изменяет правила переопределения приоритетов каскадов CSS. См. спецификацию CSS2 .

1
задан 05.05.2020, 17:05

1 ответ

Этот раздел отвечает на общий вопрос о программном обеспечении в выпуске LTS и о том, что происходит после EOL. Это относится к большинству любого программного обеспечения в выпуске.

12.04 LTS - долгосрочная поддерживаемая версия, на срок до 5 лет для сервера. Это не означает, что конкретные версии программного обеспечения, включенные в 12.04, будут продолжать существовать впоследствии в более поздних выпусках.

После того, как 12.04 достигнет конца жизни, нет абсолютно никакой гарантии, что версии любого программного обеспечения в 12.04 будут существовать или поддерживаться в более поздних выпусках. Весьма вероятно, что программное обеспечение, которое вам нужно, уже будет переведено на более поздние выпуски, в зависимости от версии в Debian на момент выпуска более поздней версии Ubuntu.

Однако в течение срока службы LTS версии программного обеспечения в выпуске LTS, скорее всего, останутся прежними, учитывая ограничения для выпусков версий в выпусках Ubuntu.


В этом разделе дается ответ на оригинальный вопрос о PHP 5.3 и о том, будет ли он поддерживаться после 12.04 EOL.

Пока 12.04 не является концом жизни, у него будет PHP 5.3.

Однако, поскольку все 12.10 (Quantal) и более поздние версии имеют PHP 5.4.x или новее, а все остальное после этого будет иметь это в зависимости от того, что находится в Debian и что выпустил PHP upstream, после 12.04 нет PHP 5.3 доступен в репозиториях, однако он может быть доступен в PPA. И это, вероятно, будет пронизано ошибками безопасности, которые не будут исправлены к 12.04 EOL.

Если вам было лень читать все это, ответ на ваш вопрос: «Нет, нет никакой гарантии, что PHP 5.3 будет доступен после 12.04 конца жизни». ОЧЕНЬ вероятно, что к 12.04 EOL, даже PHP upstream не будет поддерживать 5.3.x больше, и мы могли бы быть на PHP 5.5.x столь же стабильными и на PHP 5.4.x как на прежних.

0
ответ дан 05.05.2020, 17:05
  • 1
    Спасибо. Позвольте мне разъясниться немного больше:) I' ve наследовал ответственность за веб-приложение PHP, которое работало начиная с PHP 4. Это согласилось с обновлениями PHP 5,3. Это имеет много проблем с PHP 5.4. Я планирую сделать обзор кода и обновление, но время является проблемой. I' m выполнение этого как волонтер. I' m надежда я могу поместить веб-приложение на 12,04 полей с PHP 5.3 и расширить мой период времени для того, чтобы сделать обзор/обновление кода вне конца жизненного цикла в марте 2014 для PHP 5.3. – Dr Mido 05.05.2020, 17:06
  • 2
    @user237342 для расширения комментария Thomas у Вас есть точно 6 месяцев, плюс-минус. – raj kavadia 05.05.2020, 17:06
  • 3
    12.04 EOLs в 2017. Это isn' t беспокойство обо мне. PHP 5.3 EOLs в марте 2014. Это - беспокойство. Для приложения я хочу сохранить PHP 5.3 после марта 2014 в течение, возможно, нескольких месяцев, хорошо в продолжительности жизни 12,04. Следовательно мой исходный вопрос. – sourav.bh 05.05.2020, 17:06
  • 4
    @user237342 That' s вне объема вопроса. При необходимости в PHP 5.3, необходимо будет найти, что постоянно сохраняемый PPA использует, который имеет PHP 5.3 ПОСЛЕ 12.04 EOLs. Но you' ve добрался некоторое время, прежде чем необходимо будет взволновать приблизительно 12,04 лугов EOL. That' s, что мой ответ указывает, и это - ответ для в основном ЛЮБОГО программного обеспечения, в котором подходит этот вопрос. Необходимо будет вручную скомпилировать и установить PHP 5.3 и его плагины сами, если Вы хотите иметь PHP 5.3 после 12.04 EOLs. – sourav.bh 05.05.2020, 17:06
  • 5
    @Braiam, Которые комментируют 6 месяцев, являются абсолютно ложными. 12.04 LTS с 5 годами поддержки со стороны даты выпуска. Апрель 2017 является EOL для 12,04. Read в даты EOL. Это - хорошее графическое описание периодов времени поддержки для выпусков. – Peregreen 05.05.2020, 17:07

Теги

Похожие вопросы