доступ к MySQL с помощью терминала в Ubuntu 13.04

обращаясь к базе данных phpmyadmin из терминала, теперь в Ubuntu. 13.04 я сначала установил сервер mysql с sudo apt-get install mysql-server сервером mysql версии 5.5, теперь в терминале. Я могу проверить, работает ли он по

sudo netstat -tap | grep mysql

, он отвечает мне, запрашивая меня для пароля, а затем

tcp        0      0 localhost:mysql         *:*                     LISTEN             26214/mysqld

, но для подключения с использованием моей учетной записи root я набрал mysql -u root -p, запрашивая пароль, он показывает ERROR 1045 (28000): Access denied for user 'username'@'localhost' (using password: YES)

, когда я пытаюсь это /opt/lampp/bin/mysql -u root -p он запрашивает пароль и говорит ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)

, что находится в /etc/mysql/my.cnf и что в /opt/lampp/bin/mysql

какое-либо решение?

5
задан 06.05.2020, 06:32

6 ответов

Вы пытались установить пароль для root вскоре после установки MySQL ?? Если нет, сначала попробуйте ввести команду в терминале ниже;

mysql -u root

Теперь он должен открыть консоль mysql. И введите следующую строку:

SET PASSWORD FOR 'root'@'localhost' = PASSWORD('yourpassword');

Для выхода из консоли mysql введите exit.

Затем попробуйте восстановить соединение со следующей строкой:

mysql -u root -p

Попробуйте ввести пароль, который вы ввели.

Источник: Как подключиться и создать базу данных в MySQL?

0
ответ дан 06.05.2020, 06:33
  • 1
    эта ошибка прибыла после попытки вышеупомянутые шаги?? – Ria 06.05.2020, 06:33
  • 2
    да. не мог открыть phpmyadmin от localhost xampp. – UXCODA 06.05.2020, 06:34
  • 3
    но когда я снова пытаюсь соединиться mysql -u root -p его показ 'ОШИБКА 2002 (HY000): Can' t соединяются с локальным сервером MySQL через сокет '/var/run/mysqld/mysqld.sock' (2) – djkobi97 06.05.2020, 06:34
  • 4
    @KasunSiyambalapitiya - Разработайте это с новым вопросом, ссылающимся на это сообщение или любые другие шаги, которые Вы попробовали.. и с еще немногими информация. Единственный комментарий не поможет разыскать причину.:) – Chris 06.05.2020, 06:34
  • 5
    @AzkerM я получил ту же ошибку Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' – pfx 06.05.2020, 06:35

да, человек. После того, как я выполнил эти шаги, я смог подключиться к phpmyadmin из терминала, но после перезапуска я вижу, что не могу получить доступ к phpmyadmin с localhost

#2002 - No such file or directory The server is not responding (or the local server's socket is not correctly configured), а также отключен статус из базы данных localhost shwing mysql , все остальные, такие как SSI, PHP, CGI, активированы. в разделе «безопасность» - «phpmyadmin» как «неизвестный» и «пользователь root mysql без пароля».

До того, как все это было активировано и защищено, я сделал это, чтобы установить пароль для root и localhost, причем все было предварительно проверено при установке xampp в linux. my config.inc.php file.location /opt/lampp/phpmyadmin

$cfg['blowfish_secret'] = '$5hfhjfhgst5fg4%43(*&'; /* YOU SHOULD CHANGE THIS FOR A     MORE SECURE COOKIE AUTH! */


/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'wtf11111';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
//$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysql if your server does not have mysqli */
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;

В my.cnf, расположенном в /etc/mysql/my.cnf

client]
port        = 3306
socket      = /var/run/mysqld/mysqld.sock

[mysqld_safe] socket = /var/run/mysqld/mysqld.sock nice = 0

[mysqld] # # * Basic Settings # user = mysql pid-file = /var/run/mysqld/mysqld.pid socket = /var/run/mysqld/mysqld.sock port = 3306 basedir = /usr datadir = /var/lib/mysql tmpdir = /tmp lc-messages-dir = /usr/share/mysql skip-external-locking

0
ответ дан 06.05.2020, 06:33

Ваша установка правильная. Убедитесь, что вы вводите пароль в корневой учетной записи, а не в локальной учетной записи. Чтобы переключиться на учетную запись root, в терминале введите «sudo -i», и теперь вы получите привилегии пользователя root. Теперь введите «mysql -u root -p» и пароль, он наверняка будет работать для вас.

0
ответ дан 06.05.2020, 06:34

Используйте следующую команду

/opt/lampp/bin/mysql -u root -p

Затем введите Enter, после чего потребуется ввести пароль, если вы изменили пароль root, чем вводите этот пароль, в противном случае просто нажмите Enter, оставив его пустым.

0
ответ дан 06.05.2020, 06:35
  • 1
    Это решает вышеупомянутую ошибку Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock – D.R. 06.05.2020, 06:35

Вы можете сбросить пароль для MySQL, войдя в безопасный режим.

Остановите службу MySQL, используя приведенную ниже команду.

/etc/init.d/mysql stop

Затем запустите MySQL, используя в безопасном режиме

mysqld_safe --skip-grant-tables

После входа в MySQL в безопасном режиме выполните приведенную ниже команду для обновления пароля.

ОБНОВЛЕНИЕ пользователя SET Password = password ('MySQL_PWD') WHERE User = 'root'; ПРИВИЛЕГИИ ПРОМЫВКИ;

GRANT ALL PRIVILEGES ON *.* TO root@'localhost' IDENTIFIED BY "MySQL_PWD" WITH GRANT OPTION; PRIVILEGES FLUSH;

После выполнения вышеуказанной команды убейте mysqld и запустите MySQL.

Теперь попробуйте войти в MySQL с обновленным паролем.

0
ответ дан 06.05.2020, 06:36

используйте

/opt/lampp/bin/mysql -u root

, а затем используйте

SET PASSWORD FOR 'root'@'localhost' = PASSWORD('yourpassword');

для установки пароля и затем используйте ctrl + c или используйте выход для выхода из mysql, затем используйте

/opt/lampp/bin/mysql -u root -p

и введите пароль (пароль скрыт), а затем ENTER наслаждайтесь

.
0
ответ дан 06.05.2020, 06:37

Теги

Похожие вопросы