Установка i386 Deb (Hangul 2008) в архитектуру AMD64; dpkg / ошибка библиотеки

Я использую Chrubuntu 12.04 LTS на Chromebook Acer C720.

Поскольку я кореец, я пытаюсь установить «Hangul 2008 Linux», программное обеспечение «MS-word» в корейском стиле, предназначенное для пользователей Linux. Поскольку это только для архитектуры i386 с файлом .rpm, мне нужно было преобразовать эти файлы в файлы .deb с помощью команды иностранца.

Установка этого кода на моем 32-битном Ubuntu 12.04 в моем Virtualbox прошла гладко, связав некоторые файлы lib * из / usr / bin с usr / bin / i386 ....

Но установка этого на моей 64-битной архитектуре chrubuntu останавливается с некоторыми сообщениями об ошибках зависимости для двух файлов deb.

Как выяснилось у другого преемника, я запустил «apt-get install -f» или установил незавершенные файлы lib *, но ошибок зависимости нет, и все файлы lib уже установлены. Я думаю, что, возможно, путь, указанный в этих * .deb-файлах, не совпадает с тем, где находятся настоящие lib-файлы.

Пожалуйста, кто-нибудь может мне помочь с установкой этой программы?

Я получил ошибки

user@chrubuntu:/media/user/USB DISK/Debs43bit-noscritps$ sudo dpkg --force-architecture -i haansoft-hwp7-plugin_7.5.6.482-4axDT3_i386.deb 
[sudo] password for user: 
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
(Reading database ... 196194 files and directories currently installed.)
Preparing to replace haansoft-hwp7-plugin 7.5.6.482-4axDT3 (using haansoft-hwp7-plugin_7.5.6.482-4axDT3_i386.deb) ...
Unpacking replacement haansoft-hwp7-plugin ...
dpkg: dependency problems prevent configuration of haansoft-hwp7-plugin:
 haansoft-hwp7-plugin depends on libatk1.0-0 (>= 1.12.4).
haansoft-hwp7-plugin depends on libc6 (>= 2.1.3).
haansoft-hwp7-plugin depends on libcairo2 (>= 1.2.4).
haansoft-hwp7-plugin depends on libgcc1 (>= 1:4.1.1).
haansoft-hwp7-plugin depends on libgdk-pixbuf2.0-0 (>= 2.22.0).
haansoft-hwp7-plugin depends on libglib2.0-0 (>= 2.12.0).
haansoft-hwp7-plugin depends on libgtk2.0-0 (>= 2.8.0).
haansoft-hwp7-plugin depends on libpango1.0-0 (>= 1.14.0).
haansoft-hwp7-plugin depends on libpng12-0 (>= 1.2.13-4).
haansoft-hwp7-plugin depends on libstdc++6 (>= 4.1.1).

dpkg: error processing haansoft-hwp7-plugin (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
haansoft-hwp7-plugin
user@chrubuntu:/media/user/USB DISK/Debs43bit-noscritps$ 

user@chrubuntu:/media/user/USB DISK/Debs43bit-noscritps$ sudo dpkg --force-architecture -i haansoft-common7-gst_7.5.6.536-5axDT3_i386.deb
dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 196194 files and directories currently installed.)
Preparing to replace haansoft-common7-gst 7.5.6.536-5axDT3 (using haansoft-common7-gst_7.5.6.536-5axDT3_i386.deb) ...
Unpacking replacement haansoft-common7-gst ...
dpkg: dependency problems prevent configuration of haansoft-common7-gst:
haansoft-common7-gst depends on libc6 (>= 2.3.6-6~).
haansoft-common7-gst depends on libgcc1 (>= 1:4.1.1).
haansoft-common7-gst depends on libglib2.0-0 (>= 2.12.0).
haansoft-common7-gst depends on libgstreamer0.10-0 (>= 0.10.0).
haansoft-common7-gst depends on libxml2 (>= 2.6.27).

dpkg: error processing haansoft-common7-gst (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
haansoft-common7-gst

Что я сделал.

root@chrubuntu:/home/user# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
<ч>
root@chrubuntu:/home/user# apt-get install libc6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@chrubuntu:/home/user# apt-get install libgcc1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgcc1 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@chrubuntu:/home/user#
0
задан 06.05.2020, 18:25

1 ответ

Попробуйте эти команды,

sudo dpkg -i --force-architecture --ignore-depends haansoft-hwp7-plugin_7.5.6.482-4axDT3_i386.deb

sudo dpkg -i --force-architecture --ignore-depends haansoft-common7-gst_7.5.6.536-5axDT3_i386.deb
0
ответ дан 06.05.2020, 18:26
  • 1
    Спасибо Avinash Raj, я добавил, что ingnore зависит опции, и это вызвало для окончания с той ошибкой. – nomad 06.05.2020, 18:26
  • 2
    Я отправил другой вопрос, переданный после этого так, я буду радоваться, есть ли у Вас время для взгляда этого также.:) – TheJeff 06.05.2020, 18:26

Теги

Похожие вопросы