Зависимость отсутствует, однако пакет не нарушен?

Я не мог получить ошибку 'require', чтобы уйти, используя любой из вышеперечисленных приемов.

но я обнаружил, что проблема заключалась в том, что мои инструменты машинописи для Visual Studio, где старая версия (1.8.6.0) и последняя версия на сегодняшний день (2.0.6.0)

Вы можете скачать последняя версия инструментов:

https://www.microsoft.com/en-us/download/details.aspx?id=48593

4
задан 06.05.2020, 20:27

2 ответа

Все пакеты, начинающиеся с erlang-abi, являются виртуальными пакетами. Это будет видно из вывода apt-cache:

apt-cache show erlang-abi-15.b
N: Can't select versions from package 'erlang-abi-15.b' as it is purely virtual
N: No packages found

Ваш помощник не учитывает виртуальные пакеты, поэтому он не работает. Именно поэтому Synaptic показывает пакеты с курсивом .

3
ответ дан 06.05.2020, 20:29
  • 1
    @Hibou57 читая Ваш вопрос раздел, Вы спрашиваете " Почему italics" и " Почему это показывает поврежденный в то время как это isn' t". если Вы собираетесь ответить на свой (другой) вопрос, запишите новый вопрос начиная с него doesn' t соответствуют Q& A. – mlvljr 06.05.2020, 20:29
  • 2
    Я принял Ваш ответ, хотя он не сделал непосредственно ответил на начальный вопрос. Запуская с полезной дорожки Вас, если, я изобразил все это и обновил первое сообщение для добавления эффективного ответа. Не стесняйтесь рассматривать его, если Вы желаете. – tibur 06.05.2020, 20:29
  • 3
    Хорошо, I' ve сделал другое редактирование. Надеюсь этот лучший заповедник Q& стиль. – Bruno Soares 06.05.2020, 20:30

Сделайте

apt-cache depends erlang-abi-13.a # see what depends upon it

и

apt-cache rdepends erlang-abi-13.a # see what it depends upon

Затем сделайте то же самое с wings3d. чтобы посмотреть, есть ли в списке erlang-abi-13.a.

Пакеты и требования могут быть немного перепутаны при обновлении дистрибутива. Это может быть причиной этого.

1
ответ дан 06.05.2020, 20:28

Теги

Похожие вопросы