Конфликт версии Wine, приводящий к сбою менеджера обновлений

Я попытался обновить wine с моего существующего 1.5, установив 1.7 через apt-get, но, видимо, это только частично удалось. Теперь похоже, что я пойман в ловушку-22: Когда я пытаюсь установить 1.7, он терпит неудачу, потому что 1.5 уже установлена ​​и использует некоторые из тех же файлов. Очевидно, я не могу удалить ни 1.5, ни установленную часть 1.7 из-за неудовлетворенной зависимости.

При запуске apt-get -f install он пытается установить wine1.7-i386, но это не получается:

Unpacking wine1.7-i386:i386 (from .../wine1.7-i386_1%3a1.7.11-0ubuntu1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/wine1.7-i386_1%3a1.7.11-0ubuntu1_i386.deb (--unpack):
 trying to overwrite '/usr/bin/wine', which is also in package wine1.5 1.5.5-0ubuntu1~ppa1~oneiric1+pulse17
Errors were encountered while processing:
 /var/cache/apt/archives/wine1.7-i386_1%3a1.7.11-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Запуск apt-get autoclean после этого удаляет wine1.7-i386, но в любом случае я могу ' кажется, выходит за рамки этого. Кроме того, Ubuntu Update Manager аварийно завершает работу при загрузке, очевидно, из-за той же ошибки.

Любой совет будет оценен. Спасибо.

1
задан 06.05.2020, 19:51

1 ответ

Удалить wine1.5

sudo apt-get remove wine1.5

Затем установить wine1.7

sudo apt-get remove wine1.7
0
ответ дан 06.05.2020, 19:52
  • 1
    Попробованный это. Посмотрите выше. – jim tollan 06.05.2020, 19:52

Теги

Похожие вопросы