Проблемы при установке Adobe Acrobat Reader

По какой-то причине contents() у меня не сработало, поэтому, если у вас это не сработало, вот решение, которое я принял, я создал jQuery.fn.descendants с возможностью включать текстовые узлы или нет

Использование


Получить все потомки, включая текстовые узлы и узлы элементов

jQuery('body').descendants('all');

Получить все потомки, возвращающие только текстовые узлы

jQuery('body').descendants(true);

Получить все потомки, возвращающие только узлы элементов

jQuery('body').descendants();

Coffeescript Original :

jQuery.fn.descendants = ( textNodes ) ->

    # if textNodes is 'all' then textNodes and elementNodes are allowed
    # if textNodes if true then only textNodes will be returned
    # if textNodes is not provided as an argument then only element nodes
    # will be returned

    allowedTypes = if textNodes is 'all' then [1,3] else if textNodes then [3] else [1]

    # nodes we find
    nodes = []


    dig = (node) ->

        # loop through children
        for child in node.childNodes

            # push child to collection if has allowed type
            nodes.push(child) if child.nodeType in allowedTypes

            # dig through child if has children
            dig child if child.childNodes.length


    # loop and dig through nodes in the current
    # jQuery object
    dig node for node in this


    # wrap with jQuery
    return jQuery(nodes)

Drop In Версия Javascript

var __indexOf=[].indexOf||function(e){for(var t=0,n=this.length;t=0){i.push(r)}if(r.childNodes.length){f.push(n(r))}else{f.push(void 0)}}return f};for(s=0,o=this.length;s

Унифицированная версия Javascript: http://pastebin.com/cX3jMfuD

Это кросс-браузер, небольшой код Array.indexOf включен в код.

0
задан 07.05.2020, 07:46

1 ответ

Только что проверил, я тоже больше не могу его найти, никаких ошибок с твоей стороны. Возможно, он был удален (никогда не узнайте о сторонних пакетах)

Вы можете получить его на веб-сайте adobes .

По умолчанию он предлагает * .bin, но вы можете получить * .deb, нажав «У вас есть другой язык или операционная система?» и выберите Linux> Language> .deb

. Как только он будет загружен, щелкните по нему, и он должен открыться в Ubuntus Software Center, и его можно будет установить / управлять там, как обычно.

0
ответ дан 07.05.2020, 07:47
  • 1
    Спасибо @canofcolliders, I' m на самом деле знающий с предложенной альтернативой. Но это делает вещи более ясными, когда Вы проверили свою сторону. – User111213 07.05.2020, 07:47