обновление: libsdl1.2-dev в Ubuntu12.4 [дубликаты]

На этот вопрос уже есть ответ:

Мне нужно установить libsdl1.2-dev для создания графики, но это не разрешено.

Причина:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libsdl1.2-dev : Hängt ab von: libx11-dev soll aber nicht installiert werden
                 Hängt ab von: libglu1-mesa-dev soll aber nicht installiert werden
                 Hängt ab von: libpulse-dev soll aber nicht installiert werden
                 Hängt ab von: libxt-dev soll aber nicht installiert werden
                 Hängt ab von: libxext-dev soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Update: Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libpulse-dev : Hängt ab von: libpulse0 (= 1:1.1-0ubuntu15) aber 1:1.1-0ubuntu15.4 soll installiert werden
                Hängt ab von: libpulse-mainloop-glib0 (= 1:1.1-0ubuntu15) aber 1:1.1-0ubuntu15.4 soll installiert werden
                Hängt ab von: libglib2.0-dev soll aber nicht installiert werden
 libx11-dev : Hängt ab von: libx11-6 (= 2:1.4.99.1-0ubuntu2.1) aber 2:1.4.99.1-0ubuntu2.2 soll installiert werden
              Empfiehlt: libx11-doc soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


mp@ubuntu:~$ sudo apt-get install libsdl1.2-dev libx11-dev libglu1-mesa-dev libpulse-dev libxt-dev libxext-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libpulse-dev : Hängt ab von: libpulse0 (= 1:1.1-0ubuntu15) aber 1:1.1-0ubuntu15.4 soll installiert werden
                Hängt ab von: libpulse-mainloop-glib0 (= 1:1.1-0ubuntu15) aber 1:1.1-0ubuntu15.4 soll installiert werden
                Hängt ab von: libglib2.0-dev soll aber nicht installiert werden
 libx11-dev : Hängt ab von: libx11-6 (= 2:1.4.99.1-0ubuntu2.1) aber 2:1.4.99.1-0ubuntu2.2 soll installiert werden
              Empfiehlt: libx11-doc soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
0
задан 07.05.2020, 10:59

1 ответ

Попробуйте явно запросить установку всех этих пакетов, например так:

sudo apt-get install libsdl1.2-dev libx11-dev libglu1-mesa-dev libpulse-dev libxt-dev libxext-dev

Это сработает или выдаст другую ошибку. В последнем случае, пожалуйста, обновите ваше сообщение с подробной информацией об этой ошибке, используя функцию редактирования .

0
ответ дан 07.05.2020, 11:00

Теги

Похожие вопросы