Не могу найти openvswitch-brcompat в Ubuntu 13.10

Связанные с временным интервалом расширения, такие как:

public static TimeSpan Seconds(this int seconds)
{
  return TimeSpan.FromSeconds(seconds);
}

public static TimeSpan Minutes(this int minutes)
{
  return TimeSpan.FromMinutes(minutes);
}

, которые позволяют использовать:

1.Seconds()
20.Minutes()

Блокировки расширения, такие как:

public static IDisposable GetReadLock(this ReaderWriterLockSlim slimLock)
{
  slimLock.EnterReadLock();
  return new DisposableAction(slimLock.ExitReadLock);
}

public static IDisposable GetWriteLock(this ReaderWriterLockSlim slimLock)
{
  slimLock.EnterWriteLock();
  return new DisposableAction(slimLock.ExitWriteLock);
}

public static IDisposable GetUpgradeableReadLock(this ReaderWriterLockSlim slimLock)
{
  slimLock.EnterUpgradeableReadLock();
  return new DisposableAction(slimLock.ExitUpgradeableReadLock);
}

, которые позволяют использовать блокировки как:

using (lock.GetUpgradeableReadLock())
{
  // try read
  using (lock.GetWriteLock())
  {
    //do write
  }
}

и многие другие из общих библиотек Lokad

0
задан 14.05.2020, 21:43

1 ответ

Добавьте указанную ниже строку в файл /etc/apt/sources.list, а затем сохраните его,

deb http://cz.archive.ubuntu.com/ubuntu precise-updates main universe

Обновите репозитории,

sudo apt-get update

Установите пакет,

sudo apt-get install openvswitch-brcompat
0
ответ дан 14.05.2020, 21:43

Теги

Похожие вопросы