Беспроводная сеть не активируется при запуске компьютера. Работает после первой спячки

У меня ноутбук Asus f550c с установленной Ubuntu 12.04. Когда оно запускается, беспроводное устройство выключается, и комбинация клавиш fn + F2 для его включения не работает.

Чтобы активировать беспроводное устройство, я использовал обходной путь, чтобы перевести ноутбук в спящий режим и вывести его из спящего режима. После того, как ноутбук по какой-то магической причине выходит из спящего режима, беспроводная карта работает.

Есть ли у кого-нибудь решение, позволяющее избежать необходимости использовать этот обходной путь гибернации, чтобы беспроводная карта работала при запуске?

3
задан 13.05.2020, 16:03

2 ответа

Скопируйте и вставьте эту команду:

echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

Перезагрузка и Wi-Fi должны работать.

Вот ссылка с любезностью полного изложения varun и chili555. http://ubuntuforums.org/showthread.php?t=2181558

4
ответ дан 13.05.2020, 16:04

У меня была странная проблема как это, но его наиболее вероятное абсолютно отдельный вопрос, но решением могло бы быть то же.

Проверка, чтобы видеть, если

sudo ifdown wlan0

работы, где wlan0 является Вашим беспроводным именем карты. Если Вы не знаете название своей карты, используйте

ipconfig 

или

ip -a

для обнаружения его.

Тогда попытка

sudo ifup wlan0

, Если это работает, добавьте его в свой/etc/rc.local, который является сценарием, который работает на запуске. Это - немного hacky, но я надеюсь, что это работает!

, Если это не делает. Тогда я подозреваю, что это могла бы быть проблема управления питанием.

0
ответ дан 13.05.2020, 16:04

Теги

Похожие вопросы