Dota2 fps заморозить

Предупреждение, ошибка в Android Honeycomb и Ice Cream Sandwich

Версии Android: 3.1 - 4.04 есть ошибка, из-за которой setTextSize () внутри TextView работает только 1-й раз (1-й вызов).

Ошибка описана здесь: http://code.google.com/p/android/issues/detail?id=22493 http://code.google.com/p/ android / questions / detail? id = 17343 # c9

Обходной путь - добавить символ новой строки в текст, назначенный TextView, перед изменением размера:

final String DOUBLE_BYTE_SPACE = "\u3000";
textView.append(DOUBLE_BYTE_SPACE);

Я использую его в своем следующий код:

final String DOUBLE_BYTE_SPACE = "\u3000";
AutoResizeTextView textView = (AutoResizeTextView) view.findViewById(R.id.aTextView);
String fixString = "";
if (android.os.Build.VERSION.SDK_INT >= android.os.Build.VERSION_CODES.HONEYCOMB_MR1
   && android.os.Build.VERSION.SDK_INT <= android.os.Build.VERSION_CODES.ICE_CREAM_SANDWICH_MR1) {  
    fixString = DOUBLE_BYTE_SPACE;
}
textView.setText(fixString + "The text" + fixString);

Я добавляю этот символ «\ u3000» слева и справа от моего текста, чтобы держать его по центру. Если он выровнен по левому краю, то добавьте только справа. Конечно, он также может быть встроен в виджет AutoResizeTextView, но я хотел сохранить код исправления снаружи.

-1
задан 19.05.2020, 05:07

1 ответ

КАК УСТАНОВИТЬ ГИБРИДНЫЕ ДРАЙВЕРЫ AMD 13,12 КАТАЛИЗАТОРОВ НА Отредактированном UBUNTU 13.10

: сделайте это перед установкой:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6

sudo apt-get install dkms libqtgui4 wget execstack libelfg0 dh-modaliases

sudo apt-get install linux-headers-generic xserver-xorg-core xserver-xorg-video-all libgcc1

sudo apt-get install ia32-libs lib32gcc1 libc6-i386

Для 64 битов [только 1 117]

cd /usr

sudo ln -svT lib /usr/lib64

Установка ia32libs:

sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386

тогда удаляют старые драйверы:

sudo apt-get remove fglrx*

переустанавливают драйвер Intel:

sudo apt-get install --reinstall xserver-xorg-video-intel

загрузка и установка это:

wget http://www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_amd64.deb

sudo dpkg -i libudev*

И делают шаги ниже:

Загрузка amd-catalyst-13.12-linux-x86.x86_64.zip **

Извлечение это и Вы доберется, amd-catalyst-13.12-linux-x86.x86_64.run **

chmod +x amd-catalyst-13.12-linux-x86.x86_64.run

./amd-catalyst-13.12-linux-x86.x86_64.run --extract catalyst

cd catalyst

Применяют патч вручную: **

в конце файла catalyst/common/lib/modules/fglrx/build_mod/kcl_acpi.c, начиная со строки 990, существует

#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,3)    
    if (!ACPI_SUCCESS(acpi_get_table_with_size(id, 0, &hdr, &tbl_size)))
#else
    tbl_size = 0x7fffffff;
    if (!ACPI_SUCCESS(acpi_get_table(id, 0, &hdr)))
...

, удаляют все до конца файла и замены этим **

#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,3)    
    if (!ACPI_SUCCESS(acpi_get_table_with_size(id, 0, &hdr, &tbl_size)))
#else
    tbl_size = 0x7fffffff;
    if (!ACPI_SUCCESS(acpi_get_table(id, 0, &hdr)))
#endif
    {
        return KCL_ACPI_ERROR;
    }
#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,9,1)
    ((acpi_tbl_table_handler)handler)(hdr);
#else
    ((acpi_table_handler)handler)(hdr);
#endif
    return KCL_ACPI_OK;
}

Выполнение **

sudo ./ati-installer.sh 13.251 --buildpkg Ubuntu/saucy

, владелец Изменения и группа (от корня до Вашего пользователя) для сгенерированных .deb файлов поместили один каталог **

sudo chown <user> fglrx* and sudo chgrp <user> fglrx*

, и установите fglrx* пакеты:

sudo dpkg -i fglrx*.deb

теперь выполненный:

sudo aticonfig --initial -f

и выбор дискретная перезагрузка gpu

sudo aticonfig --px-dgpu

Ваша система

Для открытия amdcccle выполните этот источник sudo/usr/lib/fglrx/bin/amdcccle

https://gist.github.com/moldcraft/8116528

-1
ответ дан 19.05.2020, 05:08
  • 1
    Ty очень для получения информации, но этого didn' t работают на меня. Я сделал все сказанные инструкции, не получая сообщений об ошибках, но когда я перезагрузил его, был точно так же, как прежде: система, казалось, не распознала драйвер. Я сделал это дважды, чтобы быть уверенным, но это просто doesn' t работа. Когда я ввожу " sudo/usr/lib/fglrx/bin/amdcccle" это говорит, что никакой драйвер не установлен, хотя в " программное обеспечение & Updates" утилита, под " drivers" это говорит, что драйвер катализатора установлен. Есть ли любые тесты, которые я мог запустить для выяснения what' s неправильно? – Martin Liversage 19.05.2020, 05:08
  • 2
    Вы, оказывается, находитесь в контакте с каким-то божеством? Я честно wasn' t, даже надеясь это работало бы, но это сделало! Драйверы установлены! Я должен все же проверить, существуют ли проблемы с dota все еще, но на данный момент я просто хочу поблагодарить Вас! – Eugene Mayevski 'Allied Bits 19.05.2020, 05:09
  • 3
    Я отредактировал ответ, попробуйте упомянутые выше шаги. – ddc0660 19.05.2020, 05:09

Теги

Похожие вопросы