14.04 Dpkg Обнаружено ядро: /memtest86+.bin проблема (зависание во время update-grub)

Надеюсь, я не нарушаю никаких правил, открывая новую тему для проблемы, с которой я столкнулся. Поверьте мне, я пробовал просматривать все сайты Askubuntu и множество других сайтов, но ни одно из предложенных решений до сих пор не помогло мне - надеюсь, вы, ребята, сможете помочь мне решить проблему.

Ранее сегодня я выполнил обновление моего сервера Ubuntu до 14.04:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04 LTS
Release:        14.04
Codename:       trusty

У меня возникла следующая проблема:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

Если я запускаю команду, она застревает at: Found kernel: /memtest86+.bin

Пожалуйста, посоветуйте, как поступить (я пробовал несколько решений, включая update-grub и множество других, но ни одно из них не работало).

$ sudo dpkg --configure -a
Processing triggers for initramfs-tools (0.103ubuntu4) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
Setting up mdadm (3.2.5-5ubuntu4) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package mdadm (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mdadm

После перезапуска моего компьютера и запуска sudo dpkg --configure -a я вернулся к исходной проблеме:

Setting up mdadm (3.2.5-5ubuntu4) ...
 Removing any system startup links for /etc/init.d/mdadm-raid ...
update-initramfs: deferring update (trigger activated)
update-grub is /usr/sbin/update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /vmlinuz-3.13.0-24-generic
Found kernel: /vmlinuz-3.2.0-61-generic
Found kernel: /vmlinuz-3.2.0-48-generic
Found kernel: /vmlinuz-3.2.0-24-generic
Found kernel: /vmlinuz-3.0.0-12-server
Found kernel: /vmlinuz-2.6.28-11-server
Found kernel: /vmlinuz-2.6.27-14-server
Found kernel: /vmlinuz-2.6.24-24-server
Found kernel: /vmlinuz-2.6.22-16-server
Found kernel: /vmlinuz-2.6.22-14-server
Found kernel: /memtest86+.bin

Uname -r возвращает

3.13.0-24-generic

Через много проблемы, решенные в dpkg --audit, а затем dpkg --configure <packagename> для перечисленных пакетов

12
задан 22.01.2016, 18:03

4 ответа

После большой проблемы, решенной

dpkg --audit 
# and then 
dpkg --configure
# for packages listed 
4
ответ дан 07.10.2019, 22:56

Эта проблема может произойти в случае виртуализации Hyper-V (Произошел со мной сегодня).

В этом случае ответ должен отключить ОС-probbing в личинке путем открытия конфигурационного файла:

sudo nano /etc/default/grub

И добавление строки:

GRUB_DISABLE_OS_PROBER=true

После сохранения Ваших изменений в/etc/default/grub, восстановите личинку (работающий на Windows 10 Hyper-V с Ubuntu 15.04 VM):

sudo update-grub

и затем склонный - получают обновление или whatev:

sudo apt-get update
16
ответ дан 07.10.2019, 22:56
  • 1
    @SalizarMarxx: don' t оставляют " благодарность you" комментарии. Вместо этого голосуйте за ответ, если Вам нравится он. – Ryan Fox 22.01.2016, 17:12
  • 2
    Имел ту же проблему на KVM, это решило проблему. – Charles Duffy 09.03.2016, 11:59
  • 3
    Имел ту же проблему с VM OpenStack, решение работало приятно там также. – Nate 23.02.2017, 17:34

Моя проблема была то, что мне установили Ubuntu на Hyper-V VM, и я имел, Позволяют Динамическую проверенную Память (который является дефолтом). Как только я выключил его, у меня больше не было проблемы.

3
ответ дан 07.10.2019, 22:56
  • 1
    Добро пожаловать для Выяснения у Ubuntu! Я рекомендую редактирование луг этот ответ развернуть его с определенными деталями о том, как сделать это. (См. также , Как я пишу хороший ответ? для общих рекомендаций о том, на чем виды ответов считают самыми ценными, Спрашивают Ubuntu.) – Mike Dunlavey 15.11.2015, 12:43

У меня была та же проблема с Ubuntu 14.04, которая была обновлена от намного более ранней версии (как Ubuntu 10.04).

Примечание: Это не общее решение, это - то, что работало на меня.

решение этой проблемы состояло в том, чтобы обновить личинку от 0,97 до 2.

Детали:

dpkg --audit

Показал проблему с mdadm, это не может обновить с личинкой 0.97.

Вот отчет об ошибках: https://bugs.launchpad.net/ubuntu / + source/mdadm / + ошибка/1285312

0
ответ дан 07.10.2019, 22:56

Теги

Похожие вопросы