Не могу установить pangox-compat с помощью apt-get

Я не могу установить пакет pangox-compat (необходимый для моего драйвера принтера, Canon MF4120 ), используя apt-get. Пакет существует, и соответствующее репо включено:

$ apt-cache madison pangox-compat
pangox-compat | 0.0.2-4ubuntu1 | http://archive.ubuntu.com/ubuntu/ trusty/main Sources

$ sudo apt-get update
[...]
Hit http://archive.ubuntu.com trusty/main Sources
[...]

$ sudo apt-get install pangox-compat
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package pangox-compat

Я мог бы загрузить пакет и установить его с помощью dpkg, но я бы не совмещал использование dpkg и apt-get

У меня есть Lubuntu 14.04.1

1
задан 27.12.2016, 01:38

3 ответа

установите его через sudo apt-get install libpangox-1.0-dev

0
ответ дан 16.04.2019, 12:51
  1. Загрузка исходный пакет pangox-compat для 14,04 (Исходный Пакет: (0.0.2-4ubuntu1) pangox-compat).

    wget http://archive.ubuntu.com/ubuntu/pool/main/p/pangox-compat/pangox-compat_0.0.2.orig.tar.xz  
    
  2. Извлечение архив, который Вы загрузили.

    tar -xJvf pangox-compat_0.0.2.orig.tar.xz   
    
  3. Установка pangox-compat в системный каталог.

    sudo apt-get install build-essential make    
    cd pangox-compat-0.0.2  
    ./configure  
    make  
    sudo make install # installs pangox-compat into a system directory  
    
0
ответ дан 16.04.2019, 12:51

pangox-compat источник пакет. двоичные пакеты создали из него (те, можно установить использование apt-get install), libpangox-1.0-0 и libpangox-1.0-dev. Если необходимо создать что-то из источника, установите libpangox-1.0-dev. В противном случае libpangox-1.0-0 достаточно.

0
ответ дан 16.04.2019, 12:51

Теги

Похожие вопросы