После обновления до 16.04 перестал работать режим bluetooth audio A2DP

У меня есть хороший Bluetooth-аудио ресивер, подключенный к моей стереосистеме HiFi, и я имел обыкновение подключать его в 14.04 в качестве приемника A2DP с хорошим качеством.

После обновления до 16.04 устройство подключается только как гарнитура, и при попытке переключить его в режим A2DP у меня в системном журнале есть эта ошибка:

May 21 11:35:50 RRyS pulseaudio[6159]: [pulseaudio] module-bluez5-device.c: Refused to switch profile to a2dp_sink: Not connected

, и качество звука является ужасным. Как я могу это исправить?

29
задан 21.05.2016, 23:32

3 ответа

Существует несколько ошибок, открытых об этом, проверяют, например этот (запустился в 15,05) и этот другой, вполне более старый ; причины в целом не хорошо поняты.

Прежде, чем начать изменять системные файлы, можно также проверить Беспроводная колонка никакой звук в Ubuntu 16.04 (кажется другой ошибкой), и A2DP bluetooth doesn' t работают над 16,04 (решенный в комментариях обновления ядра).

фиксация, которая работала на меня, является следующим---благодаря [1 115] пользователь RobertFM в панели запуска и SimFox3 на форумах Дуги . Все следующие инструкции должны быть выполнены от корневой оболочки (sudo -i). Заботьтесь и утройте проверку.

  1. , В первую очередь, сделайте резервное копирование этих файлов (Вы никогда не знаете):

    cp /etc/bluetooth/audio.conf /etc/bluetooth/audio.conf.bak
    cp /etc/pulse/default.pa /etc/pulse/default.pa.bak
    cp /usr/bin/start-pulseaudio-x11 /usr/bin/start-pulseaudio-x11.bak
    
  2. Редактирование /etc/bluetooth/audio.conf и делают это подобным этому:

    # Configuration file for the audio service
    # This section contains options which are not specific to any
    # particular interface
    [General]
    Enable=Gateway,Source
    
    # Switch to master role for incoming connections (defaults to true)
    Master=true
    
    # If we want to disable support for specific services
    # Defaults to supporting all implemented services
    #Disable=Gateway,Source,Socket
    Disable=Socket
    
    # SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
    # Defaults to HCI
    #SCORouting=HCI
    
    # Automatically connect both A2DP and HFP/HSP profiles for incoming
    # connections. Some headsets that support both profiles will only connect the
    # other one automatically so the default setting of true is usually a good
    # idea.
    AutoConnect=true
    
    # Headset interface specific options (i.e. options which affect how the audio
    # service interacts with remote headset devices)
    [Headset]
    
    # Set to true to support HFP, false means only HSP is supported
    # Defaults to true
    HFP=true
    
    # Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
    MaxConnected=2
    
    # Set to true to enable use of fast connectable mode (faster page scanning)
    # for HFP when incoming call starts. Default settings are restored after
    # call is answered or rejected. Page scan interval is much shorter and page
    # scan type changed to interlaced. Such allows faster connection initiated
    # by a headset.
    FastConnectable=true
    
    # Just an example of potential config options for the other interfaces
    #[A2DP]
    #SBCSources=1
    #MPEG12Sources=0
    
  3. Редактирование /etc/pulse/default.pa и комментирует строку

    #load-module module-bluetooth-discover
    

    (действительно только необходимо добавить # в запуске)

  4. Редактирование /usr/bin/start-pulseaudio-x11, и добавьте строку /usr/bin/pactl load-module module-bluetooth-discover после загрузки модуля module-x11-xsmp; на практике необходимо отредактировать файл около конца, чтобы иметь строку файла конфигурации как [1 139]

    if [ x"$SESSION_MANAGER" != x ] ; then
        /usr/bin/pactl load-module module-x11-xsmp "display=$DISPLAY session_manager=$SESSION_MANAGER" > /dev/null
        # add this line here:
        /usr/bin/pactl load-module module-bluetooth-discover
    fi
    
  5. Перезагрузка.

    Теперь необходимо смочь установить устройство на A2DP и обладать высококачественной музыкой:

    Sound settings

    Уведомление, что когда-то необходимо Разъединить и Повторно подключить устройство, чтобы повторно включить A2DP:

    Bluetooth devices

    ... да, это - банка ошибок. Но когда это работает, это работает красиво.

  6. Проблемы после перезагрузки

    После того, как все это, когда-то прием, кажется, работает просто только после следующей перезагрузки. В таком случае попытайтесь следовать ответ rmfought :

    , Какие работы для меня должны подключить bluetooth-устройство, переключитесь на режим HSP/HFP, разъединение, снова соединитесь и затем переключитесь на режим A2DP.

    ... работы для меня также (снова, когда-то). Я должен был даже не соединить восстановление аппаратный ключ однажды.

  7. , Если это все еще не работает...

    , Если это также не работает на Вас, можно попробовать [1 120], этот сценарий ---его автор совершенствует его.

35
ответ дан 29.09.2019, 15:29
  • 1
    audio.conf не присутствует в человечности 16.04, только main.conf, который будет работать? – Erik 01.06.2016, 05:30
  • 2
    @JoakimKoed---you' право ре, я проверил---, который я имел audio.conf-remove, вероятно, остаток от обновления. Я просто воссоздал его---поэтому теперь, я вызываю сомнение, возможно, просто указывает 3, и 4 необходимы? – UlfR 01.06.2016, 05:38
  • 3
    Шаги 3 & 4 не зафиксировал для меня, и я воссоздал audio.conf согласно вышеупомянутому, и никакие не фиксируют. Удаление bluetooth-устройства и восстановления фиксирует, но выполнение, что каждый раз Вы хотите использовать аудио Bluetooth, не выполнимо. – Frank Heikens 15.06.2016, 15:08
  • 4
    @ThomasCarlisle извините, что услышали, что - здесь это работало (никакая потребность к пересоединению) после первого раза. Должна быть другая вещь... – Adamantish 15.06.2016, 19:07
  • 5
    Блестящий! Это добивается цели со мной! Я предлагаю, чтобы Вы добавили ссылку на него в Вашем ответе, поскольку все вместе, кажется, дают полностью рабочее решение проблемы. За Ваше здоровье! – UlfR 08.11.2016, 21:24

Какие работы для меня должен подключить bluetooth-устройство, переключить на режим HSP/HFP, разъединение, повторно подключить и затем переключить на режим A2DP.

38
ответ дан 29.09.2019, 15:29
  • 1
    То же здесь. Однако это, как предполагается, не этот путь, и это раньше работало правильно в предыдущей версии. – Vality 23.09.2016, 09:10
  • 2
    Для меня также, который работал. Но реальная большая боль в ** для чего-то, что работало (почти) безупречно в 15,10 и прежде. – bmpasini 14.10.2016, 23:30
  • 3
    О, верьте мне, я соглашаюсь. it' s огромная боль. Единственный дистрибутив I' ve нашел, что обрабатывает BT правильно из поля, в наше время ОС Solus. – Braiam 03.11.2016, 11:44
  • 4
    Это супер странно, но это работало! – cerd 10.05.2017, 06:45
  • 5
    Святое дерьмо. Didn' t ожидают, что это будет работать, но это сделало. – GKislin 20.12.2017, 00:49

Это - не обязательно решение для тех, кому нужен микрометр, но это работало в Ubuntu 16.04 на меня:

sudo nano /etc/bluetooth/audio.conf

И затем добавляют Disable=Headset под [General].

[General]
Disable=Headset

И перезапуск сервис Bluetooth

sudo service bluetooth restart

И весь creds этому парню: https://jimshaver.net/2015/03/31/going-a2dp-only-on-linux /

5
ответ дан 29.09.2019, 15:29
  • 1
    К несчастью, didn' t удаются для меня. Мой значок панелей Bluetooth является greyed out†¦, Возможно, it' s драйвер/модуль? XPS 13 9350 и человечность 16.04. – Pmpr 16.10.2016, 20:55
  • 2
    @Dolanor, Не уверенный, является ли это все еще проблемой, но, если значок панелей отображается серым, он, скорее всего, означает, что Ваш адаптер Bluetooth является softblocked. Попробуйте rfkill unblock bluetooth и возможно даже bluetoothctl и затем power on (в bluetoothctl-CLI). –  22.03.2017, 02:33
  • 3
    Это работало в моем случае zorinos 12 – haccks 29.03.2018, 02:51
  • 4
    На Ubuntu 18 нет никакого /etc/bluetooth/audio.conf файл. Я добавил Disable=Headset к /etc/bluetooth/main.conf, перезапустил сервис, повторно подключил мои наушники, но профиль аудио был значением по умолчанию off. Не уверенный это работало? –  22.06.2019, 17:50

Теги

Похожие вопросы