Плагин Pepper Flash установлен, но не работает на хром

У меня установлен Pepper Flash Plugin , но он не работает с хромом, и все же каждая веб-страница предлагает установить Adobe Flash.

Я снял и установил его снова, но ничего не изменилось. Я уверен, что он установлен, потому что при попытке новой установки получить это сообщение:

sudo apt-get install pepperflashplugin-nonfree

Reading package lists... Done
Building dependency tree       
Reading state information... Done
pepperflashplugin-nonfree is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

Ps. Вот как я удалил плагин перед его повторной установкой:

apt-get remove --purge pepperflashplugin-nonfree

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  pepperflashplugin-nonfree*
0 upgraded, 0 newly installed, 1 to remove and 6 not upgraded.
After this operation, 66.6 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 199594 files and directories currently installed.)
Removing pepperflashplugin-nonfree (1.3ubuntu1) ...
Purging configuration files for pepperflashplugin-nonfree (1.3ubuntu1) ...

apt-get clean

Спасибо

3
задан 27.01.2015, 00:22

4 ответа

Несмотря на то, что было сказано относительно [1 116] Ubuntu wiki и здесь для простой установки флэш-памяти на Хроме pepperflashplugin-nonfree пакет; я был вынужден вручную скопировать pepperflash сменный файл от Google Chrome до хрома в пути, разъясненном здесь :

<час>

Google Chrome Загрузки и извлечение libpepflashplayer.so от /opt/google/chrome/PepperFlash в Chrome deb Копия файла libpepflashplayer.so к /usr/lib/chromium-browser/plugins Вносят необходимые изменения в запуск Хрома

sudo gedit /etc/chromium-browser/default

, Добавляет это к CHROMIUM_FLAGS

CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/chromium-browser/plugins/libpepflashplayer.so --ppapi-flash-version=11.5.31.2"

, можно получить правильную версию флеш-плагина от "version": тег json в mainfest.json от [1 111] в Chrome deb файл

<час>

Теперь, у меня есть Adobe Flash Player - Версия: 16.0.0.291 на Хроме и это хорошо работает. Я не знаю, мог ли я получить обновления для флэш-памяти на Хроме с помощью этого на Trminal:

sudo update-pepperflashplugin-nonfree --status

, поскольку это ничего не дает на Терминале.

, Если у Вас есть какая-либо идея того, как держать Flash player в курсе на Хроме (вручную не копируя .so файл eachtime новая версия выпущен);

Также о причине [1 113] не скопировал сменный файл в папке Chromium или не обновил CHROMIUM_FLAGS="" в [1 115] automtically, сообщите мне в комментариях.

Спасибо

2
ответ дан 06.10.2019, 13:04
  • 1
    Это - просто идея, как иметь дело с проблемой обновления: вместо копирование сменные файлы к местоположению хрома, создайте символьная ссылка в файл. – Toby Speight 25.10.2015, 20:25
  • 2
    @BogdanWilli Хм, интересный. I' попытка ll это. Спасибо – Matthew Fisher 28.10.2015, 20:18
  • 3
    Символьная ссылка @BogdanWilli работала отлично. Но одна вещь: этим путем номер версии флеш-плагина перед CHROMIUM_FLAGS в эти /etc/chromium-browser/default остался бы старым числом и wouldn' t изменение. Таким образом даже при том, что сам файл был обновлен, но он представляет число неверной версии хрому (он виден в chrome://plugins). Я don' t знают, влияет ли это на функциональность плагина. Однако, если у Вас есть решение для этого также, I' d ценят его. – pts 31.10.2015, 00:02
  • 4
    Также sudo apt-get remove adobe-flashplugin, если Вам все еще установили его, потому что это будет конфликты с pepperflashplugin-несвободным. – Michael Gradek 26.07.2016, 23:35

Вот обновление, я использовал метод, как описано DummyBeginner на версии Flash 23 0 0 185.

Однако я получил Перечный Lib непосредственно от Adobe https://get.adobe.com/flashplayer/? no_redirect

Загрузил .tar.gz для моей версии Linux, внутри я нашел libpepflashplayer.so, скопировал это в каталог "плагинов" Хрома и обновил файл "по умолчанию" с версией, которую я нашел в manifesto.json.

Работы как очарование на chromuim версии 50.0.2661.102 и Ubuntu 14.04 (64-разрядной)

0
ответ дан 06.10.2019, 13:04

Относительно обновлений версии можно добавить к/etc/chromium-browser/default следующей строке:

version=$(grep version /opt/google/chrome/PepperFlash/manifest.json | sed 's|.*"version": ||;s|"||g;s|,||')

и изменение pappi-flash-version отмечают linke соответственно:

CHROMIUM_FLAGS="--ppapi-flash-path=/opt/google/chrome/PepperFlash/ --ppapi-flash-version=$version"

И помещенный фактический путь к файлам , везде, где они, не имея Google Chrome также. Теоретически Вам даже не нужны никакие символьные ссылки, если внутренняя программа не отклоняет нестандартные местоположения по некоторой сумасшедшей причине, которая даже привела бы любого к вопросу, почему это просит местоположение, которое должно быть hardcoded для начала.

Однако, в то время как это, кажется, работает через chrome://плагины на фактических страницах, я добираюсь, "не мог загрузить плагин". Я не думаю, что это вызывается этим методом установки переменных, все же. Если нет действительно сумасшедшие причины.

Странно флэш-память достаточного количества хрома работает над хромом и Firefox..., но не хромом...

1
ответ дан 06.10.2019, 13:04

Благодарит Вашу ручную установку, решил мою проблему. Не должно быть слишком трудно написать сценарий этого.

я выполняю Версию 37.0.2062.120 Хрома на ветвлении Debian 7.1.

у меня есть несколько различная проблема. Если я устанавливаю pepperflash, склонный - добираются, удаляет хром & браузер хрома:

The following packages will be REMOVED:
  chromium chromium-browser
The following NEW packages will be installed:
  pepperflashplugin-nonfree
0 upgraded, 1 newly installed, 2 to remove

противоположное также верно, когда установка хрома, склонного - добирается, удалит pepperflash, если это будет установлено.

Вот то, что я сделал:

  1. установка pepperflashplugin-nonfree. Эта установленная версия 16.0.0.305.

  2. флэш-памяти копирует /usr/lib/pepperflashplugin-nonfree dir для использования позже.

  3. хром установки и браузер хрома, который удалил pepperflashplugin-nonfree.

  4. копия libpepflashplayer.so & manifest.json от резервного копирования на шаге 2 к /usr/lib/chromium/plugins (я не имею /usr/lib/chromium-browser dir).

  5. редактирование /etc/chromium/default и добавляет --ppapi-flash-path=/usr/lib/chromium/plugins/libpepflashplayer.so --ppapi-flash-version=16.0.0.305 to CHROMIUM_FLAGS (я не имею /etc/chromium-browser/default).

, например:

CHROMIUM_FLAGS="--password-store=detect --ppapi-flash-path=/usr/lib/chromium/plugins/libpepflashplayer.so --ppapi-flash-version=16.0.0.305"
0
ответ дан 06.10.2019, 13:04

Теги

Похожие вопросы