Какой вариант выбрать, когда распространитель пакета отправил обновленную версию?

Расширенные настройки после выбора dpkg исправляют поврежденные пакеты:

Advanced settings after selecting dpkg fix broken packages

Configuration file '/etc/gnome/defaults.list'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** defaults.list (Y/I/N/O/D/Z) [default=N] ?

Будет ли установлена ​​версия Ubuntu или 18.04 или просто обновить мою текущую Ubuntu 16.04?

0
задан 21.05.2019, 19:22

3 ответа

В этом конкретном случае OP уже выбрал D для отображения различий в файлах конфигурации, и это связано с типами MIME системы. Если у вас нет очень специфических конфигураций, которые вы создали для открытия вещей с помощью созданных вами пользовательских пусковых установок .desktop, вы, вероятно, захотите принять новую версию сопровождающих.

0
ответ дан 25.10.2019, 10:38

Этот вывод появляется после того, как вы запустили apt upgrade, и не будет обновлять вашу версию Ubuntu - только пакеты (приложения). Если вы работаете в Ubuntu 16.04, вы останетесь 16.04 (однако я бы рекомендовал перейти на 18.04 с do-release-upgrade).

0
ответ дан 25.10.2019, 10:38
  • 1
    Он просто обновился до 18 после того, как я нажал Да – Khan 15.05.2019, 23:16
  • 2
    Я не могу войти, меня перенаправляют обратно на экран входа через 18 – mklement0 15.05.2019, 23:16
  • 3
    Извините, но я не знаю, какую команду вы выполняли. Не могли бы вы вставить здесь, какую команду вы вводили в терминал? –  15.05.2019, 23:17
  • 4
    Sudo apt update & amp; & amp; sudo apt dist-upgrade & amp; & amp; sudo apt autoremove – Marcus Pope 15.05.2019, 23:48
  • 5
    Хорошо. Предполагая, что вы понимаете , что dist-upgrade делает , вы, возможно, удалили некоторые пакеты (в отличие от upgrade). Вы помните, какие пакеты вы удалили? Возможно, они были необходимы. – Marcus Pope 16.05.2019, 00:03

Исходное сообщение об ошибке содержало этот текст:

Configuration file '/etc/gnome/defaults.list'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** defaults.list (Y/I/N/O/D/Z) [default=N] ?

Выбор первой опции, Y or I : install the package maintainer's version, не изменит установленную вами версию Ubuntu. Вместо этого он сделает все совместимым с вашей текущей установленной версией Ubuntu (Ubuntu 16.04). При необходимости он отменит изменения, внесенные вами в вашу систему, которые могут помешать вам нормально обновлять пакеты. Первый параметр Y является наиболее безопасным для выбора, когда он представлен в меню Package distributor has shipped an updated version, поскольку он позволяет вам обновлять вашу систему в обычном режиме и возвращает вашу систему в состояние, при котором нет ничего, что мешало бы управлению пакетами по умолчанию. , Это также облегчит решение проблемы поврежденных пакетов , которая мешает обновлению установленных пакетов и, возможно, с самого начала сгенерировала это сообщение управления пакетами.

1
ответ дан 25.10.2019, 10:38
  • 1
    Да, это то, что я думал и узнал тоже, но когда я выбрал 1, он обновился до 18.04, я понятия не имею, как – rustyx 16.05.2019, 03:39
  • 2
    Кажется необычным для меня – codesniffer 16.05.2019, 03:40
  • 3
    С точки зрения разорванных пакетов, N сохраняет пакеты в их текущем состоянии, даже если они разорваны, и Y исправляет пакеты, чтобы они соответствовали версии сопровождающего пакета, которая совпадает с той, что делается по умолчанию в Ubuntu. – hwase0ng 16.05.2019, 06:46
  • 4
    Как я уже сказал в своем ответе, выбор Y не приведет к обновлению вашей системы. Это только разрешает apt удалить старый или сломанный пакет. – Jepessen 16.05.2019, 06:58

Теги

Похожие вопросы