Установка gtk-config и / или fsv, отсутствие зависимостей GTK

Я пытаюсь установить визуализатор файловой системы (подумайте: «Это система UNIX! Я знаю это!» Из парка Юрского периода) в Ubuntu 10.10.

Я скачал и распаковал .tar.gz. Однако, когда я ./configure, я получаю этот вывод:

loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for ranlib... ranlib
checking for POSIXized ISC... no
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for ANSI C header files... yes
checking whether time.h and sys/time.h may both be included... yes
checking for strings.h... yes
checking for sys/time.h... yes
checking for unistd.h... yes
checking for working const... yes
checking for mode_t... yes
checking for uid_t in sys/types.h... yes
checking for pid_t... yes
checking for size_t... yes
checking for comparison_fn_t... yes
checking for st_blocks in struct stat... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for working alloca.h... yes
checking for alloca... yes
checking for working fnmatch... yes
checking for strftime... yes
checking for getcwd... yes
checking for gettimeofday... yes
checking for mktime... yes
checking for strcspn... yes
checking for strdup... yes
checking for strspn... yes
checking for strtod... yes
checking for strtoul... yes
checking for scandir... yes
checking for inline... inline
checking for off_t... yes
checking for unistd.h... (cached) yes
checking for getpagesize... yes
checking for working mmap... yes
checking for argz.h... yes
checking for limits.h... yes
checking for locale.h... yes
checking for nl_types.h... yes
checking for malloc.h... yes
checking for string.h... yes
checking for unistd.h... (cached) yes
checking for sys/param.h... yes
checking for getcwd... (cached) yes
checking for munmap... yes
checking for putenv... yes
checking for setenv... yes
checking for setlocale... yes
checking for strchr... yes
checking for strcasecmp... yes
checking for strdup... (cached) yes
checking for __argz_count... yes
checking for __argz_stringify... yes
checking for __argz_next... yes
checking for stpcpy... yes
checking for LC_MESSAGES... yes
checking whether NLS is requested... yes
checking whether included gettext is requested... no
checking for libintl.h... yes
checking for gettext in libc... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for gtk-config... no
checking for GTK - version >= 1.2.1... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error: Cannot find proper GTK+ version

Очевидно, что он ищет gtk-config. Однако , по-видимому, он больше не существует в репо. Затем этот пост упомянул, что gtkglarea решил их проблему, как упоминалось в в этом файле .

Конечно, этот автор аккуратно забывает упомянуть, что именно и как gtkglarea решил их проблему, и Google в основном лишен информации о проблеме.

1135 Итак, я прихожу сюда с просьбой о помощи! Я хотел бы установить fsv, но он говорит мне, что gtk-config не существует. Как я могу исправить эту проблему в Ubuntu 10.10?

Спасибо!

РЕДАКТИРОВАТЬ

Итак, с помощью Роберта мне пришлось do:

Из репозиториев Dapper я скачал:

libgtk1.2-dev_1.2.10-18_i386.deb
libgtk1.2_1 .2.10-18_i386.deb
libgtk1.2-common_1.2.10-18_all.deb
gtkglarea5-dev_1.2.3-2ubuntu4_i386.deb
gtkglarea5_1.2.3-2ubuntu4_i386.deb
libglib1.2_1.2.10-10.1build1_i386.deb
libglib1.2-dev_1.2.10-10.1build1_i386.deb

, тогда мне пришлось установить:

  1. libglib1.2
  2. libglib1. 2-dev
  3. libgtk1.2-common
  4. libgtk1.2
  5. libgtk1.2-dev
  6. gtkglarea5
  7. gtkglarea5-dev

Я использовал sudo gdebi .deb для большинства из них (он лучше говорит о зависимостях, если вы их пропустили). В некоторых случаях Гдеби не делает правильные вещи и умирает. Когда это происходит, используйте dpkg -i .deb, и оно должно работать.

6
задан 18.11.2019, 09:34

3 ответа

На GitHub имеется обновленная версия fsv: https://github.com/mcuelenaere/fsv . Он был изменен для работы с GTK 2.0 и работает для меня в Linux Mint 13 (с использованием пакетов Ubuntu 12.04)

0
ответ дан 18.11.2019, 09:35

что программное обеспечение не поддерживается и требует GTK1, который является устаревшей версией графической библиотеки, он недоступен в репозиториях Ubuntu, и я не знаю ни одного репозитория, предоставляющего его.

Я бы порекомендовал вам связаться с автором программного обеспечения и уточнить у него, планируется ли обновление, или иным образом искать поддерживаемое подобное программное обеспечение.

0
ответ дан 18.11.2019, 09:35
  • 1
    никакая такая вещь как подобное сохраняемое программное обеспечение. Ну, существуют другой 3-й стиль, но говорящий they' подобное ре похоже на высказывание, что ENIAC и Ваш компьютер подобны, потому что они оба работают в двоичном файле. Поскольку последнее изменение было сделано в 2001, я высоко подозреваю, что скоро не будет никаких обновлений... – Peter Cordes 18.11.2019, 09:35

Если библиотека все еще используется или требуется кем-то, как она может устареть?

У меня была такая же проблема при сборке Mozilla 1.7.13 (да, старый браузер Mozilla).

В 10.10 я обошел это вручную, установив пакет dapper и все зависимости:

https://launchpad.net/ubuntu/dapper/i386/libgtk1.2-dev/1.2 .10-18

вам понадобится:

libglib1.2_1.2.10-10.1build1_i386.deb
libglib1.2-dev_1.2.10-10.1build1_i386.deb
libgtk1.2-common_1.2.10-18_all.deb
libgtk1.2_1.2.10-18_i386.deb
libgtk1.2-dev_1.2.10-18_i386.deb
0
ответ дан 18.11.2019, 09:35
  • 1
    При попытке установить libgtk1.2-dev_1.2.10-18_i386.deb я добираюсь Breaks existing package 'libgtk1.2' that conflict: 'libgtk-dev'. ошибка. Какие-либо подсказки о том, как зафиксировать это? Google ничего не поднимает. – dreamcrash 18.11.2019, 09:36
  • 2
    А-ч - по-видимому, gdebi иногда глуп. Используя dpkg -i установил его. Похож на I' ve получил другую потребность - configure: error: Cannot find gtkglarea. К Google! – jaggedsoft 18.11.2019, 09:36

Теги

Похожие вопросы