Как мне понизить ядро? [Дубликат]

Возможный дубликат:
Как понизить версию ядра до 11.10

blockquote>

Мой Wi-Fi работал очень хорошо на Ubuntu 10.04 с ядром 2.6.32.28. Теперь, после того как я установил Ubuntu 11.04 с последним ядром, мой Wi-Fi (RT3090) больше не работает. Безопасно ли понижать ядро? Если да, то как понизить его?

3
задан 14.04.2017, 01:25

3 ответа

Я делал именно это в прошлом, когда обновление до 11.04 нарушило мою способность использовать JACK с моей звуковой картой (хотя это больше не проблема с последним ядром).

Я просто добавил строку APT предыдущего дистрибутива в /etc/apt/sources.list (или в отдельном файле в /etc/apt/sources.list.d), например

deb http://archive.ubuntu.com/ubuntu/ maverick-updates main restricted

После обновления списка пакетов в aptitude, предыдущие версии ядра 2.6.32 были доступны в списке. Добавление старого репозитория не нарушает ничего другого, потому что apt не будет по умолчанию понижать пакеты, а все пакеты предыдущего дистрибутива являются более старыми или равными установленным в настоящее время версиям.

Также, как говорит Дананджая , если вы обновились с более раннего дистрибутива, вы все равно должны установить более старые ядра. Однако вы можете добавить строку APT, как предложено выше, чтобы получать обновления безопасности для этого старого ядра.

0
ответ дан 24.04.2019, 15:14

Ранее

Понижение ядра: Как понизить ядро ​​до 11.10

Обновление ядра: Как обновить ядро ​​до 3.1?

0
ответ дан 24.04.2019, 15:14

Это одно из многих решений вашего вопроса,

Вы обновились до Ubuntu 11.04 с 10.10? Если это так, образы ядра 10.10 все еще должны быть в вашей системе. первый запуск,

sudo apt-get install startupmanager

Он установит 'startupmanager', полезный инструмент для легкой настройки системы. После того, как вы установили его, запустите

sudo startupmanager

. Вы увидите главное окно программы, а на вкладке «Параметры загрузки» вы увидите раскрывающийся список «Операционная система по умолчанию». Выберите нужный образ ядра (если у вашей системы есть образ) из этого списка и закройте программу. Перезагрузите компьютер.

Чтобы проверить, загрузили ли вы нужное ядро, запустите эту команду на своем терминале

uname -a

Надеюсь, это поможет.

0
ответ дан 24.04.2019, 15:14

Теги

Похожие вопросы