Как отключить Bluetooth при запуске системы?

Полагаю, вы хотите загрузить пакеты, которые позже будут установлены на машине с Ubuntu. Официальный репозиторий Ubuntu доступен через сеть по адресу http://packages.ubuntu.com/ . Вы можете загрузить пакеты .deb с этого веб-сайта и установить их с помощью dpkg -i в системе Ubuntu.

306
задан 26.02.2020, 05:43

29 ответов

Если вы используете апплет Bluetooth на верхней панели (blueman-applet), у него есть собственная настройка, которая автоматически включает Bluetooth, даже если вы отключили его в других местах (например, / etc / bluetooth / main). .conf или /etc/default/tlp).

Для предотвращения включения Bluetooth при запуске с помощью командной строки:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Или через графический интерфейс:

  1. Щелкните по апплету Bluetooth> Плагины [111 ]> PowerManager > Конфигурация
  2. Снимите флажок Автоматическое включение

При следующей перезагрузке Bluetooth Апплет все еще будет виден, но Bluetooth будет отключен. Чтобы включить его:

Нажмите апплет Bluetooth> Включите Bluetooth

0
ответ дан 26.02.2020, 05:43

В Ubuntu 16.04 я просто отключил запуск службы с помощью systemctl.

Для этого откройте окно терминала и введите следующее:

sudo systemctl disable bluetooth

Вы можете перезагрузиться, так как теперь Bluetooth будет отключен при запуске, или если вы это сделаете не хотите перезагружать и хотите сразу прекратить Bluetooth, вы можете набрать:

sudo service bluetooth stop

0
ответ дан 26.02.2020, 05:44

Для тех из вас, где вставка строки rfkill block bluetooth (или любой другой) в /etc/rc.local не работает, попробуйте включить эту же строку в конец ~/.bashrc

в моем наборе up (Ubuntu 14.04, Thinkpad W540), ни одна опция не работала, вставляя ее в /etc/rc.local, но первая работала в bashrc. Обратите внимание, что это будет работать только для текущего пользователя, а не для всех пользователей в целом.

0
ответ дан 26.02.2020, 05:44

Я думаю, вам следует отредактировать

/etc/default/bluetooth

и установить

BLUETOOTH_ENABLED=0

для отключения службы Bluetooth при загрузке

0
ответ дан 26.02.2020, 05:45

Мне пришлось использовать метод грубой силы, чтобы остановить автоматический запуск bluetoothd при загрузке. Я переименовал исполняемый файл, чтобы его нельзя было найти.

0
ответ дан 26.02.2020, 05:45
  • 1
    It' s быстрее стартовые вещи параллельно. По крайней мере, that' s идея. – makkasi 26.02.2020, 05:46

Начиная с Ubuntu 18.04 (с GNOME) вам необходимо

  1. Редактировать /etc/bluetooth/main.conf и найти

    AutoEnable = true
    

    и изменить значение на :

    AutoEnable = false
    

    Таким образом, это устройство не включается при запуске.

  2. Отредактируйте / etc / default / tlp и найдите:

    #DEVICES_TO_DISABLE_ON_STARTUP="bluetooth wifi wwan"
    

    Измените эту строку следующим образом:

    DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"
    

    Таким образом, это устройство отключено при запуске. [1114 ]

  3. Затем откройте Dash и найдите «Startup Applications». Снимите все пункты, связанные с Bluetooth в списке. Нажмите [Закрыть], чтобы сохранить.

0
ответ дан 26.02.2020, 05:46

Я добавляю

"/etc/init.d/bluetooth stop"

в

"/etc/rc.local" 

до команды «выход 0» для загрузки с отключенным Bluetooth.

0
ответ дан 26.02.2020, 05:46
  • 1
    это не работало над моей 64-разрядной лощиной Ubuntu 14.04 inspiron. Только rfkill работал на меня. – Marcus Downing 26.02.2020, 05:47
  • 2
    Это удалило значок панели задач Bluetooth, но оставило мой индикатор Bluetooth на (указание, что питание все еще отправлялось радио).Править: это в сочетании с Stepbaer' s ответ (InitiallyPowered = false) работал на меня. (ThinkPad x201, Xubuntu 13.10) – Arun Vinoth 26.02.2020, 05:47

Мы можем отключить автоматический запуск Bluetooth следующим образом:

sudo gedit /etc/bluetooth/main.conf

(gedit - мой любимый редактор, вы можете заменить его на xed или на то, что установлено на вашем компьютере. system.)

В самом низу этого файла есть строка:

#AutoEnable=false

Удалите комментарий, например:

AutoEnable=false
0
ответ дан 26.02.2020, 05:47
  • 1
    doesn' t работают у волнистого попугайчика человечности 18.04 – Andres Rojas 26.02.2020, 05:47

Я нашел практическое руководство с чистым «обходным путем» здесь ( ссылка на архив для потомков)

На самом деле меня достаточно /etc/bluetooth/main.conf.

Поиск записи:

AutoEnable=true

и изменить значение на:

AutoEnable=false

Это было достаточно для меня, хотя статья описывает некоторые другие шаги, которые могут или не могут быть необходимым.

В Ubuntu 17.04 и старше опция была названа InitiallyPowered.

0
ответ дан 26.02.2020, 05:47
  • 1
    Это только работало бы, если бы я также использовал Saeed Zarinfam' s ответ помещения /etc/init.d/bluetooth stop в rc.local. Кажется, что, когда сервис запускает, это также навлекает питание для Bluetooth. Мне были нужны оба, чтобы заставить это работать. (ThinkPad x201, Xubuntu 13.10) – Flimm 26.02.2020, 05:48
  • 2
    На моем случае это был AutoEnable=false, но так или иначе +1 для правильного решения от правильного места. – ESR 26.02.2020, 05:48
  • 3
    Didn' t работают на меня на thinkpad t420 – Rohit Sharma 26.02.2020, 05:48
  • 4
    doesn' t работа для ноутбука Samsung 530u3b, Bluetooth находится всегда на после перезагрузки, и проснуться – Lai Xue 26.02.2020, 05:49
  • 5
    " Ищите entry" имеет то, чтобы точно быть бесполезное к тем из нас, чьи main.conf не содержит этот параметр или любой комментарий, указывающий на его местоположение по умолчанию. Так, под которым [Heading] мы должны поместить его? – Sahand 26.02.2020, 05:49

Вы также можете использовать это графическое приложение, которое также делает менеджер Bluetooth

.
0
ответ дан 26.02.2020, 05:48

Я добавляю

"/etc/init.d/bluetooth stop"

в

"/etc/rc.local" 

перед командой «выход 0» для загрузки с отключенным Bluetooth.

0
ответ дан 26.02.2020, 05:49

Введите в терминале следующее:

sudo gedit /etc/modprobe.d/blacklist.conf

В нижней части файла добавьте строку:

blacklist bluetooth

Сохраните файл и перезапустите - Bluetooth теперь должен быть отключен .

0
ответ дан 26.02.2020, 05:49
  • 1
    Попробованный приблизительно 20 вещей на моем ThinkPad человечности 12, это - единственное, которое добилось цели. – VitalyB 26.02.2020, 05:50
  • 2
    @Floqqi: можно ли попробовать его снова? I' ve обновил мой ответ. – ksav 26.02.2020, 05:50
  • 3
    Этот won' t работают над моим ПК... – rastaman 26.02.2020, 05:51

Может быть, вы можете отключить его в Startup Applications. Но эти приложения по умолчанию скрыты. Отобразите скрытые приложения запуска в 12.04: откройте терминал и выполните следующие две команды:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Теперь вы можете снять Bluetooth. (Не удаляйте!)

0
ответ дан 26.02.2020, 05:50
  • 1
    Bluetooth не перечислен среди этих приложений, печально. – Havvy 26.02.2020, 05:51

Вам необходимо отключить его из списка «Запуск приложений» в Системных настройках.

Нажмите на шестеренку в верхней правой части строки меню и выберите «Системные настройки».

Нажмите «Запустить приложения», затем прокрутите вниз, пока не найдете настройку Bluetooth, снимите флажок и все готово.

0
ответ дан 26.02.2020, 05:51
  • 1
    Я can' t находят Bluetooth в Приложениях Запуска.. – cassiomolin 26.02.2020, 05:51
  • 2
    К сожалению, it' s не в приложениях запуска в 11,10. – zkent 26.02.2020, 05:52
  • 3
    Это doesn' t на самом деле мешают подсистемам Bluetooth и аппаратным средствам работать (и значительно: потребление батареи). Это просто останавливает выполнение апплета. – Gert van den Berg 26.02.2020, 05:52
  • 4
    @Oli - спасибо за головы, я никогда на самом деле знал это! Я принял, отключили ли Вы его в приложениях запуска, это не запустило процесс вообще. – Mariyo 26.02.2020, 05:53

1) Установите пакет smbios-utils и добавьте его в Startup Applications с:

sudo smbios-wireless-ctl --bt 0

2) В типе терминала:

[ 111]

и добавьте в конец открытого файла /etc/sudoers строку:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Чтобы включить Bluetooth во время сеанса, запустите в терминале:

sudo smbios-wireless-ctl --bt 1

Это работает для меня на моем Dell D630 с Ubuntu 13.10

0
ответ дан 26.02.2020, 05:52
  • 1
    Вы думаете, что sudo smbios-wireless-ctl --boot --bt 0 работал бы? Кроме того, I' m не уверенный, но это может быть определенным для Dell. – Commercial Suicide 26.02.2020, 05:52
  • 2
    Я знал это. Но если Вы делаете smbios-wireless-ctl --help, часть его имеет --boot Set BIOS boot-time setting. я didn' t знают, что зафиксировали Bluetooth, хотя; благодарит говорить мне. – tbranyen 26.02.2020, 05:52
  • 3
    На самом деле пакет smbios-utils выполняет команды BIOS, таким образом, он включает и выключает физические устройства, связанные с BIOS, таким образом, можно также использовать его для включения и выключения Wi-Fi и т.д. I' m не уверенный, если это работает с какой-либо BIOS или нет. По крайней мере, это работает хорошо с Dell. Между прочим, последние установки Ubuntu 14.04 делают то же самое с Bluetooth и апплетами Wi-Fi, таким образом, я don' t больше нужно в том пакете. – Vivin Paliath 26.02.2020, 05:53

Вы можете изменить службы, запущенные при загрузке, с помощью BUM .

Установить: sudo apt-get install bum

Выполнить: sudo bum

enter image description here

Снять флажок и нажать Применить .

0
ответ дан 26.02.2020, 05:52
  • 1
    Я получаю много " использование неинициализированного value" предупреждения, когда это работает. Извините, can' t доверяют этому. – Tope 26.02.2020, 05:53
  • 2
    Спасибо, desgua, я думал об этом виде инструментов. Я использовал некоторых в прошлом, но они становятся устаревшими, и новая человечность, с их минималистической навязчивой идеей, не идет ни с чем подобным. Действительно ли это - единственное, эй знают, или лучшие эй знают? – Jonas Schäfer 26.02.2020, 05:53
  • 3
    Теперь, пакет не доступен. Это говорит, Задница является виртуальной. – koralgoll 26.02.2020, 05:53
  • 4
    жаль doesn' t работают над elementaryOS Freya – emote_control 26.02.2020, 05:54
  • 5
    Возможно, работы, но сначала это разочаровало меня, потому что это начало показывать Bluetooth как не активированный во время начальной загрузки, почему? и как не выполнение, когда rfkill, апплет и hciconfig показывают ему выполнение. Я выключаю и включаю, но задница продолжает показывать сервис как прочь. Я активировал сервис при начальной загрузке, но состояние сервиса продолжает быть неправильным. – Karol Selak 26.02.2020, 05:54

Я думаю, что лучший способ - это отключить запуск службы в первую очередь. Существует общий метод отключения служб, который отлично работает:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

, который работает для Ubuntu 13.10 и, возможно, также для более ранних версий.

0
ответ дан 26.02.2020, 05:53
  • 1
    как включить Bluetooth при использовании обеспеченный настройки позже? скажите, что я хочу использовать его только в течение 5 минут каждые 10 начальных загрузок.. – smwikipedia 26.02.2020, 05:54

Отредактируйте /etc/default/grub:

sudo nano /etc/default/grub

и измените следующую строку:

GRUB_CMDLINE_LINUX=""

, чтобы сказать это вместо:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Затем обновите grub и перезагрузитесь:

sudo update-grub
0
ответ дан 26.02.2020, 05:54

Нет. Это не всегда в списке приложений для запуска. Я думаю, что лучшее решение - добавить команду rfkill в скрипт rc.local или установить параметр InitiallyPowered в /etc/bluetooth/main.conf.

0
ответ дан 26.02.2020, 05:54
  • 1
    InitiallyPowered, кажется, проигнорирован для меня. – tbranyen 26.02.2020, 05:54

Я использовал Sputnik Kernel , который исправил это на моем Dell Inspiron 14R N4110.

0
ответ дан 26.02.2020, 05:55

Я нашел другой ответ, используя tlp, который отлично работает для меня с Ubuntu 18.04. Вероятно, сначала необходимо установить tlp с помощью

sudo apt install tlp

, а затем файл

/etc/default/tlp

содержит некоторые настройки для таких устройств, как Wi-Fi и Bluetooth. Есть клавиша

RESTORE_DEVICE_STATE_ON_STARTUP

, которая по умолчанию установлена ​​на 0. После того, как я переключил ее на 1, моя последняя настройка запоминается при следующей загрузке. Это означает, что когда я отключаю Bluetooth на верхней панели, он остается отключенным, а когда я включаю Bluetooth, он остается включенным. Также есть ключ

DEVICES_TO_DISABLE_ON_STARTUP

, который можно установить на

DEVICES_TO_DISABLE_ON_STARTUP="bluetooth"

Теперь Bluetooth будет отключен при каждой загрузке. После изменения этой конфигурации Bluetooth может быть включен и отключен через меню и пункт панели. Я думаю, что это лучше, чем удалить его из модулей ядра.

0
ответ дан 26.02.2020, 05:55
  • 1
    TLP не установлен по умолчанию в Ubuntu. Необходимо обновить сообщение соответственно. – Tushar Shukla 26.02.2020, 05:55
  • 2
    @linrunner хорошо, didn' t знают что это. Я протестировал на новом Волнистом попугайчике Ubuntu от Смокинга. Там это работало. Я зафиксировал свой ответ. – Philipp 26.02.2020, 05:56

В Ubuntu Studio 16.04 вы можете отключить апплет Bluetooth при запуске в:

Сессия и запуск> Автозапуск приложения> Апплет Bluetooth

поле, чтобы отключить его.

0
ответ дан 26.02.2020, 05:55
  • 1
    Это - совершенно хорошее решение на моей машине Xubuntu 17.10, за исключением одной вещи: если пользователь хочет начать использовать Bluetooth снова на лету, он должен выполниться, sudo systemctl включают bluetooth.service & & sudo systemctl запускают bluetooth.service. Но Ваше решение определенно решает проблему начальной загрузки. – Jordan S 26.02.2020, 05:56

Чтобы отключить загрузку драйвера Bluetooth при запуске:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

добавьте:

blacklist btusb

Чтобы включить его позже, просто:

sudo modprobe btusb
0
ответ дан 26.02.2020, 05:56
  • 1
    DELL E6410 работает на меня. Хороший, который может работать снова на движении без сброса. – Flimm 26.02.2020, 05:56
  • 2
    " Выполненный gedit как корень и редактирование/etc/modprobe.d/blacklist.conf" < - хорошо, то, что меньше командной строки для Вас? – rolinger 26.02.2020, 05:57
  • 3
    Хорошо работает на Samsung Q35 с Ubuntu 13.10, в то время как ' блок rfkill bluetooth' подход не делает. Спасибо! – Ilja Kartašov 26.02.2020, 05:57
  • 4
    Don' t потрудились пробовать к " избегайте командной строки stuff" когда Вы настраиваете операционную систему. Ctrl+Alt+T и несколько ctrl-shift-V (для вставки) слишком много для выяснения? – Teoman Tıngır 26.02.2020, 05:58
  • 5
    Спасибо за это, которое, действительно кажется, работает, но я старался избегать материала командной строки согласно своему исходному вопросу. Вы думали бы, что это будет столь же просто как отметка поля так, чтобы она помнила что я don' t хотят, чтобы BT запустилась автоматически, но она похожа на свой путь, более сложный, чем это. С Ubuntu' s управляют в течение более быстрого времени начальной загрузки и общего внимания на потребляемую мощность в ноутбуках и нетбуках, я удивлен, что это никогда не обращалось. Я ценю справку все же. – jain 26.02.2020, 05:58

18.04+ пользователям, которые, естественно, не имеют /etc/rc.local, вам нужно создать его и сделать его исполняемым. Чтобы упростить задачу, вы можете просто вставить следующую команду в терминал:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Запустить sudoedit /etc/rc.local и добавить это перед строкой exit 0:

rfkill block bluetooth
[ 1110] Вы все равно сможете включить Bluetooth через апплет верхней панели.

Этот должен работать для большинства систем, но похоже, что в ACPI ядра для Thinkpads скрывается несколько ошибок. Если вы используете Thinkpad, добавьте следующее в /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Или посмотрите ibm-acpi - Дополнительный драйвер ACPI IBM ThinkPad - в некоторых отчетах говорится, что ibm -acpi включает в себя управление Bluetooth (среди других приятных вещей). Но у меня нет аппаратного обеспечения, поэтому я не могу проверить эти заявления. Удачи.

0
ответ дан 26.02.2020, 05:56
  • 1
    если наш rc.local является просто пустым файлом, где должен мы добавлять ' блок rfkill bluetooth'? – bstar 26.02.2020, 05:57
  • 2
    Для Ноутбуков ThinkPad (и только Ноутбуков ThinkPad) это работает: echo disable > /proc/acpi/ibm/bluetooth в/etc/rc.local – 9BallOnTheSnap 26.02.2020, 05:57
  • 3
    На Ubuntu 15.10 с systemd Вам нужен еще немного, чтобы повторно включить использование etc/rc.local файл: askubuntu.com/a/696226/34298 – ramin 26.02.2020, 05:58
  • 4
    Ни один не работал на меня (ThinkPad x201), когда я разместил их по одному в /etc/rc.local. Эти rfkill block bluetooth команда работает, но не на запуске. Флаг-x установлен на /etc/rc.local. I' m рабочий Xubuntu 13.10. – Király István 26.02.2020, 05:58
  • 5
    rfkill block bluetooth работавший для Thinkpad T430u – Kannan T 26.02.2020, 05:58

Это должно отключить запуск Bluetooth в системах на основе Debian:

sudo chkconfig bluetooth off

или в системах на основе RedHat

systemctl disable bluetooth.service
0
ответ дан 26.02.2020, 05:57

16.04+


Начиная с ubuntu 16.04, systemd управляет службами запуска, такими как bluetooth ..., чтобы просмотреть текущее состояние, возникающее в терминале

sudo systemctl status bluetooth.service 

, чтобы отключить Bluetooth при запуске. выдайте эту

sudo systemctl disable bluetooth.service

, затем при следующей перезагрузке Bluetooth не будет активен ... чтобы включить выпуск Bluetooth

sudo systemctl enable bluetooth.service
0
ответ дан 26.02.2020, 05:58
  • 1
    НАКОНЕЦ! Ubuntu 18.10, единственная вещь, которая работала на меня. Ничто иное не работало. – abed 26.02.2020, 05:58
  • 2
    Это работает на меня, но как побочный эффект, blueman-апплет, остановленный для работы также. Это запускается, но doesn' t появляются в области индикатора, таким образом, нет никакого быстрого способа включить Bluetooth, только в терминале. – Tunaki 26.02.2020, 05:58
  • 3
    В Xubuntu, по крайней мере, при нажатии на Blueman он имеет опцию " Поверните Bluetooth Off". я думаю, что это - то, что OP хотел бы автоматизированный. Ваше решение удаляет Blueman в целом, делая его тяжелее, чтобы повторно включить Bluetooth при желании. – zkent 26.02.2020, 05:58
  • 4
    Помещенные sudo systemctl отключают bluetooth.service & & sudo systemctl останавливают bluetooth.service в Запрещать сценарий и chmod 755 на нем. Сделайте то же для sudo systemctl включает bluetooth.service & & sudo systemctl запускают bluetooth.service в Разрешать сценарии. – Astrowie 26.02.2020, 05:59

Шаг 1. Перейдите к терминалу и введите следующую команду для редактирования системного файла /etc/rc.local:

gksudo gedit /etc/rc.local

Шаг 2. Добавьте следующую строку перед строкой exit 0:

rfkill block bluetooth
0
ответ дан 26.02.2020, 05:58
  • 1
    Это установлено мягкий блок на Bluetooth, я думаю он то же, как выключают его обслуживание и работы хорошо. – user3329922 26.02.2020, 05:58
  • 2
    @Robert: $ man rfkill: " Отключают устройство, соответствующее данному индексу. " Несмотря на имя, это только отключает BT; просто попробуйте команду rfkill block bluetooth на терминале, необходимо видеть, что значок идет серый. – Roope Hakulinen 26.02.2020, 05:59

1. block bluetooth в rc.local

Добавьте эту строку в конец файла /etc/rc.local прямо перед строкой exit 0:

rfkill block bluetooth

Это поможет, но только в старые версии Ubuntu, использующие upstart .

2. reenable rc.local на systemd

В Ubuntu 15.10 с systemd в качестве менеджера запуска файл /etc/rc.local больше не используется по умолчанию, поэтому вызовите его на терминале:

[ 111]

Который открывает редактор. В конце файла я добавил:

[Install]
WantedBy=multi-user.target

Эти изменения активируются с помощью

sudo systemctl reenable rc-local

Теперь файл /etc/rc.local используется, как вы его знаете.

3. отключить blueman-applet при запуске

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Теперь blueman-applet виден, и вы можете отключить его из автозагрузки программ

4. Перезагрузитесь, чтобы увидеть эффект

0
ответ дан 26.02.2020, 05:58
  • 1
    Для меня на Ubuntu 17.04 с blueman: gsettings set org.blueman.plugins.powermanager auto-power-on false работал, от wiki.archlinux.org/index.php/Blueman . Хотя я закончил тем, что делал sudo apt remove blueman, тогда управляют Bluetooth через параметры настройки системы и проверяют " Покажите состояние Bluetooth в меню bar". Blueman, запускающийся и включающий Bluetooth, был проблемой. – Jonas Schäfer 26.02.2020, 05:59

Решение для моего ноутбука

«BIOS - Конфигурация USB - EHCI2: отключено»

EHCI1 предназначен для USB-портов (фактически у моего ноутбука 2 порта USB 2.0)

0
ответ дан 26.02.2020, 05:59