Virtualbox, Ubuntu 11.10, linux-kernel 3: не удается запустить виртуальную машину

У меня установлен оракул virtualBox v.4.1.2_Ubuntu r38359.
Программа VM запускается с ошибками:

ВНИМАНИЕ: Символьное устройство / dev / vboxdrv не существует. Пожалуйста, установите пакет virtualbox-ose-dkms и соответствующие заголовки, скорее всего, linux-headers-generic.

Вы не сможете запускать виртуальные машины, пока эта проблема не будет устранена.

(VirtualBox:5642): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(VirtualBox:5642): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(VirtualBox:5642): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(VirtualBox:5642): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

Как я и сделал:
1)

sudo apt-get install virtualbox-ose virtualbox-ose-dkms

ответ:

virtualbox-ose уже является самой новой версией.
virtualbox-ose-dkms - это уже новейшая версия.

2)

sudo apt-get install linux-headers-`uname -r`

ответ:

linux-headers-3.0.0-12-generic-pae уже новейшая версия.


Если я пытаюсь запустить виртуальную машину, у меня появляется 2 окна:
1) Первое:

Не удалось открыть сеанс для виртуальной машины. машина winxp. Виртуальная машина winxp неожиданно прервалась во время запуска с кодом выхода 1.

Код результата: NS_ERROR_FAILURE (0x80004005)
Компонент: Машина
Интерфейс: IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}

2 ) Второй:

Драйвер ядра не установлен (rc = -1908). Пожалуйста, установите пакет virtualbox-dkms и запустите 'modprobe vboxdrv' от имени пользователя root.

Попытка:

$ sudo modprobe vboxdrv
FATAL: модуль vboxdrv не найден.

;

$ /etc/init.d/virtualbox start
* Запуск модулей ядра VirtualBox
* Нет подходящего модуля для запуска ядро найдено [ошибка]

10
задан 07.12.2019, 04:23

7 ответов

Понятия не имею !, но у меня такая же проблема, как и у тебя. Я только что попытался решить путем установки поддержки версии vbox на версию ядра. это работало нормально. Я имею в виду, что если у вас vbox версии 4.X.X поддержка, то есть версия вашего ядра ОС (ваш компьютер). Если вы хотите проверить версию ядра, перейдите к типу терминала: uname -s .

0
ответ дан 07.12.2019, 04:24

Перейдите в Dash, затем в центр программного обеспечения и удалите весь пакет virtualbox ...

Добавление хранилища VirtualBox:

    sudo add-apt-repository "deb http://download.virtualbox.org/virtualbox/debian oneiric contrib"
    wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add -
    sudo apt-get update

Установка VirtualBox 4.1:

    sudo apt-get install virtualbox-4.1

Если вы хотите USB 2.0, VirtualBox RDP и Загрузка PXE для карт Intel на ваших гостевых машинах, вам нужно установить пакет расширений, который можно скачать здесь .

Установка пакета расширений

После загрузки пакета расширений откройте VirtualBox и перейдите к «Файл -> Настройки», в разделе «Расширения» нажмите значок «Добавить пакет» и найдите ваш загруженный пакет расширений.

<час>

Следуйте петиции:

sudo apt-get install kernel-package 
sudo apt-get install linux-source

Попробуйте удалить старый модуль.

sudo apt-get remove virtualbox-ose-modules*
sudo apt-get purge virtualbox-ose-modules*

Затем установите новый.

sudo apt-get install virtualbox-ose-modules-`uname -r`

и попробуйте это

sudo /etc/init.d/vboxdrv setup

0
ответ дан 07.12.2019, 04:24
  • 1
    Не может загрузить virtualBox снова на должное отсутствие трафика. Потребность решить его без целой переустановки, если возможный (для использования настолько меньшего количества трафика насколько возможно). – B. Clay Shannon 07.12.2019, 04:25
  • 2
    " склонные sudo - получают пакет ядра установки " " склонные sudo - получают установку linux-source" that' s приблизительно 82 МБ для загрузки - невозможный (ограничение трафика). Ничто, чтобы удалить или произвести чистку. Не может загрузить " E: Couldn' t находят любой пакет regex ' virtualbox-ose-modules-3.0.0-12-generic-pae' ". последний " sudo:/etc/init.d/vboxdrv: управляйте не found" – John Kaster 07.12.2019, 04:25

Была такая же проблема: "WARNING: The character device /dev/vboxdrv не существует. Пожалуйста, установите пакет virtualbox-ose-dkms и соответствующие заголовки, скорее всего, linux-headers-generic. "Хотя все пакеты VirtualBox были установлены.

  1. Удалите все виртуальные ящики: sudo apt-get purge virtualbox

    [ 115]
  2. Перейдите по адресу: https://www.virtualbox.org/wiki/Downloads (Загрузите один для Ubuntu 12.10 мой случай)

  3. Установите пакет.

  4. Теперь все работает нормально и получайте удовольствие от Linux!

0
ответ дан 07.12.2019, 04:25
  • 1
    да, но в моем случае i couldn' t позволяют себе загрузить новый пакет – Roel 07.12.2019, 04:25

Просто используйте графический интерфейс Ubuntu Software Center, вместо того, чтобы использовать командную строку apt-get

Поиск Virtualbox

  • Должен получить как минимум два попадания.
  • Сначала удалите двоичные файлы решения для виртуализации x86 (выделите и нажмите «удалить»)
  • Затем выделите и удалите Virtualbox

После удаления обоих установите Virtualbox

  • Это автоматически переустановит базовые двоичные файлы и перестроит ядро ​​Virtualbox

Это должно сделать это.

0
ответ дан 07.12.2019, 04:26
  • 1
    Уже решенный с Javier Rivera справка. Спасибо, тем не менее, ^_^ – Roman 07.12.2019, 04:26

В моем случае я сделал следующее:

  1. Перейдите сюда: https://www.virtualbox.org/wiki/Downloads и загрузите оттуда Пакет Virtualbox

  2. Загрузите с сайта ссылку на пакет расширений

  3. Установите пакет (Не беспокойтесь о PPA / Repository или о чем-либо, так как пакет в конечном итоге добавит его в репозиторий)

  4. Установите пакет расширений с помощью Virtualbox Manager

ПРИМЕЧАНИЕ. - Чтобы уберечь себя от проблем, необходимо удалите установленный вами виртуальный ящик и все связанные с ним репозитории.

После этого, когда появится обновление, система уведомит вас об этом, как и все другие программы Ubuntu.

Текущая версия сейчас 4.1.4

0
ответ дан 07.12.2019, 04:26
  • 1
    OOHH!. И от friend' s домой, место кафе, girlfriend' s, mom' s, сосед? – Raz Megrelidze 07.12.2019, 04:27
  • 2
    Другая проблема состоит в том, что я не могу повторно загрузить virtualbox из-за ограничения трафика – Hernaldo Gonzalez 07.12.2019, 04:27
  • 3
    I' m не в моем собственном городе для тех вариантов кроме мест кафе, но надо надеяться решение прибудет без него – Jim McKeeth 07.12.2019, 04:28

Вы пытались собрать модуль ядра? Он должен был быть собран во время установки, но похоже, что это не удалось. Вы можете попробовать:

sudo dkms install virtualbox/4.1.2

Это должно собрать модуль.

0
ответ дан 07.12.2019, 04:27
  • 1
    " подготовка к Ядру, ненужная для этого ядра. Пропуск... Создание модуля: очистка области сборки.... делает KERNELRELEASE=3.0.0-12-generic-pae-C/lib/modules/3.0.0-12-generic-pae/build M =/var/lib/dkms/virtualbox/4.1.2/build.............. чистя область сборки.... DKMS: Завершенная сборка. " " ted@calister:~ $ virtualbox ПРЕДУПРЕЖДЕНИЕ: устройство посимвольного ввода-вывода/dev/vboxdrv не существует. Установите virtualbox-ose-dkms пакет и соответствующие заголовки, наиболее вероятный linux-headers-generic. Вы не будете в состоянии запустить VMs, пока эта проблема не будет решена. " Тем не менее та же ошибка – Akbar Badhusha 07.12.2019, 04:27
  • 2
    Это говорит большое о dkms, он, как предполагается, работает отдельно. Попробуйте sudo dkms, устанавливают virtualbox/4.1.2 – Massimiliano Kraus 07.12.2019, 04:27
  • 3
    Несомненно, это могло помочь. Можно также удалить VirtualBox и установить его из репозиториев Oracle как hhlp предложенный. – jamie yello 07.12.2019, 04:28
  • 4
    Созданный хорошо, но все еще принятие той же проблемы; Если я показываю Вам синтезируемый текст после " sudo dkms создают virtualbox/4.1.2"? – Sameera R. 07.12.2019, 04:28
  • 5
    Необходимо будет сделать,/etc/init.d/virtualbox начинают загружать модули. – Nitin Sawant 07.12.2019, 04:29

Ну, первое, что меня поражает, это то, что вы, кажется, смешиваете открытые версии и проприетарные версии VirtualBox. Я не знаю, если это важно, но это может.

Убедитесь, что вы используете версию VirtualBox с открытым исходным кодом, или установите драйверы для проприетарной версии с пакетом virtualbox-dkms

0
ответ дан 07.12.2019, 04:27
  • 1
    virtualbox-dkms не является собственным. Они - драйверы ядра, но открытый исходный код. Компоненты собственной разработки виртуального поля находятся теперь в дополнительном пакете. – mxmissile 07.12.2019, 04:27
  • 2
    уже установленный. – granadaCoder 07.12.2019, 04:28

Теги

Похожие вопросы