Получение ошибки от apt-get при попытке установить пакет php5

Я бы порекомендовал использовать sudo chmod.666 ~ / Windows

https://help.ubuntu.com/community/FilePermissions

4
задан 15.12.2019, 03:03

4 ответа

bkzland ответил на вопрос напрямую, но я хотел бы предложить вам другое решение для локальной веб-разработки с LAMP в Ubuntu с Zend Community Edition - небольшое улучшение, если вы хотите это потому, что вы только начинаете.

Если вы перейдете по ссылке Zend Community Edition выше, вы найдете подробные инструкции, которые работают очень хорошо с минимальными усилиями. Перейти с PHP 5.3. И обратите внимание, что в их инструкциях предполагается, что вы вошли в систему как пользователь root. (Потому что их команды оболочки начинаются с #) Чтобы стать root ...

sudo su -

И тогда команды, которые они предоставляют, будут работать и для вас. Также получите дополнительные возможности: php-5.3-extra-extensions-zend-server, phpmyadmin-zend-server, zend-server-framework-dojo, zend-server-framework-extras.

Я бы не стал погружаться в Zend Framework, потому что вы только начинаете, но он есть, если вы хотите поиграть с ним. Если вы работаете с фреймворком на чистом PHP, CodeIgniter - это хороший фреймворк, с которого можно начать и, возможно, придерживаться. Кроме того, загрузите и установите IDE : версию Eclipse со многими встроенными плагинами PHP ( Helios ) или, возможно, Komodo Edit .

Корень сайта будет находиться в / var / www. Не забудьте установить часовой пояс PHP. Для этого есть веб-интерфейс для установки по адресу http: // localhost: 10081 / ZendServer / . Настройка сервера -> Директивы:

Zend Community Edition PHP Directives

Удачи!

0
ответ дан 15.12.2019, 03:03

Я только что начал работать, скопировав предполагаемый файл .php в папку html. Не удалось сделать это через диспетчер файлов, поэтому sudo в терминале.

sudo cp testphp.php /var/www/html/
0
ответ дан 15.12.2019, 03:04

Может быть, у php есть другое имя пакета? Я не знаю, я им не пользуюсь.

Но вы можете попробовать установить это: http://www.apachefriends.org/en/xampp-linux.html Я использую его, и он работает.

0
ответ дан 15.12.2019, 03:05

php5 на самом деле является метапакетом. Вы должны решить, хотите ли вы использовать php5-модуль для apache или установить CLI / CGI-версию и использовать ее.

Я просто предположу, что вы хотите использовать первый вариант: попробуйте apt-get install libapache2-mod-php5. Если это по-прежнему не работает, проверьте apt-cache search php5 и посмотрите, есть ли там какие-либо пакеты, может произойти сбой в конфигурации вашего apt-репозитория.

Примечание. Для php7 имя пакета - libapache2-mod-php7.0, а НЕ libapache2-mod-php7 (Ubuntu 16.04).

0
ответ дан 15.12.2019, 03:05

Теги

Похожие вопросы